]> git.pld-linux.org Git - packages/python-coverage.git/blobdiff - python-coverage.spec
- updated to 5.5
[packages/python-coverage.git] / python-coverage.spec
index b1e2e15672efb645c86344c4e59be02f196d0252..cad68e773a80ff78c72459cda68d33c19e4d26be 100644 (file)
 Summary:       Tool for measuring code coverage of Python programs
 Summary(pl.UTF-8):     Narzędzie do szacowania pokrycia kodu programów w Pythonie
 Name:          python-%{module}
-Version:       4.5.4
-Release:       7
+# keep 5.x here for python2 support
+Version:       5.5
+Release:       1
 License:       Apache v2.0
 Group:         Development/Languages/Python
 #Source0Download: https://pypi.org/simple/coverage/
 Source0:       https://files.pythonhosted.org/packages/source/c/coverage/%{module}-%{version}.tar.gz
-# Source0-md5: c33cab2aed8780aac32880cb6c7616b7
+# Source0-md5: 22e8fc8c26c46e76fb3c7f99a5f6eb92
 URL:           http://coverage.readthedocs.org/
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.714
 %if %{with python2}
-BuildRequires: python-devel >= 1:2.6
-BuildRequires: python-setuptools >= 1:35.0.2
+BuildRequires: python-devel >= 1:2.7
+BuildRequires: python-setuptools >= 1:42.0.2
 %if %{with tests}
-BuildRequires: python-eventlet >= 0.22.0
-BuildRequires: python-flaky >= 3.4.0
+BuildRequires: python-eventlet >= 0.25.1
+BuildRequires: python-flaky >= 3.7.0
 BuildRequires: python-gevent >= 1.2.2
-BuildRequires: python-greenlet >= 0.4.13
-BuildRequires: python-mock >= 2.0.0
-BuildRequires: python-pycontracts >= 1.8.2
-BuildRequires: python-pyparsing >= 2.4.0
-BuildRequires: python-pytest >= 3.2.5
-BuildRequires: python-pytest-xdist >= 1.20.1
-BuildRequires: python-unittest-mixins >= 1.4
+BuildRequires: python-greenlet >= 0.4.15
+BuildRequires: python-hypothesis >= 4.57.1
+BuildRequires: python-mock >= 3.0.5
+BuildRequires: python-pycontracts >= 1.8.12
+BuildRequires: python-pytest >= 4.6.11
+BuildRequires: python-pytest-xdist >= 1.34.0
+BuildRequires: python-unittest-mixins >= 1.6
 %endif
 %endif
 %if %{with python3}
-BuildRequires: python3-devel >= 1:3.3
-BuildRequires: python3-setuptools >= 1:35.0.2
+BuildRequires: python3-devel >= 1:3.5
+BuildRequires: python3-setuptools >= 1:42.0.2
 %if %{with tests}
-BuildRequires: python3-eventlet >= 0.22.0
-BuildRequires: python3-flaky >= 3.4.0
-BuildRequires: python3-greenlet >= 0.4.13
-BuildRequires: python3-pycontracts >= 1.8.2
-BuildRequires: python3-pyparsing >= 2.4.0
-BuildRequires: python3-pytest >= 3.2.5
-BuildRequires: python3-pytest-xdist >= 1.20.1
-BuildRequires: python3-unittest-mixins >= 1.4
+BuildRequires: python3-eventlet >= 0.25.1
+BuildRequires: python3-flaky >= 3.7.0
+BuildRequires: python3-greenlet >= 0.4.15
+BuildRequires: python3-hypothesis >= 4.57.1
+BuildRequires: python3-pycontracts >= 1.8.12
+BuildRequires: python3-pytest >= 4.6.11
+BuildRequires: python3-pytest-xdist >= 1.34.0
+BuildRequires: python3-unittest-mixins >= 1.6
 %endif
 %endif
 %if %{with doc}
-BuildRequires: python-doc8 >= 0.8.0
-BuildRequires: python-pyenchant >= 2.0.0
-BuildRequires: python-sphinxcontrib-spelling >= 4.0.1
-BuildRequires: python-sphinx_rtd_theme >= 0.2.4
-BuildRequires: sphinx-pdg-2 >= 1.6.6
+BuildRequires: python3-doc8 >= 0.8.1
+BuildRequires: python3-pyenchant >= 3.2.0
+BuildRequires: python3-sphinxcontrib-restbuilder >= 0.3
+BuildRequires: python3-sphinxcontrib-spelling >= 7.1.0
+BuildRequires: python3-sphinx_autobuild >= 2020.9.1
+BuildRequires: python3-sphinx_rtd_theme >= 0.5.1
+BuildRequires: python3-sphinx_tabs >= 2.0.0
+BuildRequires: sphinx-pdg-3 >= 3.4.3
 %endif
-Requires:      python-modules >= 1:2.6
+Requires:      python-modules >= 1:2.7
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -76,7 +80,7 @@ kodu, który mógłby zostać wykonany, ale nie był.
 Summary:       Tool for measuring code coverage of Python programs
 Summary(pl.UTF-8):     Narzędzie do szacowania pokrycia kodu programów w Pythonie
 Group:         Development/Languages/Python
-Requires:      python3-modules >= 1:3.3
+Requires:      python3-modules >= 1:3.5
 
 %description -n python3-%{module}
 Coverage.py is a tool for measuring code coverage of Python programs.
@@ -135,7 +139,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc CHANGES.rst CONTRIBUTORS.txt NOTICE.txt README.rst TODO.txt
+%doc CHANGES.rst CONTRIBUTORS.txt NOTICE.txt README.rst
 %attr(755,root,root) %{_bindir}/coverage
 %attr(755,root,root) %{_bindir}/coverage2
 %attr(755,root,root) %{_bindir}/coverage-%{py_ver}
@@ -150,7 +154,7 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with python3}
 %files -n python3-%{module}
 %defattr(644,root,root,755)
-%doc CHANGES.rst CONTRIBUTORS.txt NOTICE.txt README.rst TODO.txt
+%doc CHANGES.rst CONTRIBUTORS.txt NOTICE.txt README.rst
 %attr(755,root,root) %{_bindir}/coverage3
 %attr(755,root,root) %{_bindir}/coverage-%{py3_ver}
 %dir %{py3_sitedir}/coverage
This page took 0.054421 seconds and 4 git commands to generate.