]> git.pld-linux.org Git - packages/postgresql.git/blobdiff - postgresql.spec
- added Patch11: postgresql-ssl-libpq-mem-leak-1.patch
[packages/postgresql.git] / postgresql.spec
index cc6f935518ad673ccf7bdcd56d2f14dc2ff4196d..7dbf21f9319663a5261191b971f68ed0e9d71fb0 100644 (file)
@@ -4,13 +4,15 @@
 #
 # Conditional build:
 %bcond_without tests                   # disable testing
-%bcond_without tcl                             # disables Tcl support
+%bcond_without tcl                     # disables Tcl support
 %bcond_without kerberos5               # disable kerberos5 support
 %bcond_without perl                    # disable perl support
+%bcond_without pgsql_locale            # disable PostgreSQL locale
+%bcond_without pgsql_multibyte         # disable PostgreSQL multibyte
 %bcond_without python                  # disable python support
-%bcond_with            jdbc                    # enable JDBC driver
+%bcond_with    jdbc                    # enable JDBC driver
 %bcond_with    absolute_dbpaths        # enable absolute paths to create database
-                                                               # (disabled by default because it is a security risk)
+                                       # (disabled by default because it is a security risk)
 
 %include       /usr/lib/rpm/macros.python
  
@@ -46,6 +48,8 @@ Patch6:               %{name}-com_err.patch
 Patch7:                %{name}-ecpg_link.patch
 Patch8:                %{name}-ecpg-includedir.patch
 Patch9:                %{name}-contrib_install.patch
+Patch10:       %{name}-tsearch2-compound_word_support_20031210.patch
+Patch11:       %{name}-ssl-libpq-mem-leak-1.patch
 Icon:          postgresql.xpm
 URL:           http://www.postgresql.org/
 BuildRequires: autoconf
@@ -736,8 +740,24 @@ Cryptographic functions for PostgreSQL.
 %description module-pgcrypto -l pl
 Funkcje kryptograficzne dla PostgreSQL.
 
+%package module-tsearch2
+Summary:       Full text extension for PostgreSQL
+Summary(pl):   Rozszerzenie pe³notekstowe dla PostgreSQL-a
+Group:         Applications/Databases
+Requires:      %{name} = %{version}
+
+%description module-tsearch2
+Implementation of a new data type tsvector - a searchable data type
+with indexed access:
+http://www.sai.msu.su/~megera/postgres/gist/tsearch/V2/
+
+%description module-tsearch2 -l pl
+Implementacja nowego typu danych tsvector - typu danych podlegaj±cego
+przeszukiwaniu z dostêpem poprzez indeksy:
+http://www.sai.msu.su/~megera/postgres/gist/tsearch/V2/
+
 %prep
-%setup  -q
+%setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p0
@@ -748,6 +768,8 @@ Funkcje kryptograficzne dla PostgreSQL.
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
+%patch10 -p1
+%patch11 -p0
 
 tar xzf doc/man*.tar.gz
 
@@ -759,11 +781,12 @@ find contrib -type d -name CVS -exec rm -rf {} \;
 
 %build
 rm -f config/libtool.m4
+install /usr/share/automake/config.* config/
 %{__aclocal} -I config
 %{__autoconf}
 %configure CFLAGS="%{rpmcflags} -DNEED_REENTRANT_FUNCS"\
-       %{!?_without_pgsql_locale:--enable-locale} \
-       %{!?_without_pgsql_multibyte:--enable-multibyte} \
+       %{?with_pgsql_locale:--enable-locale} \
+       %{?with_pgsql_multibyte:--enable-multibyte} \
        --disable-rpath \
        --enable-nls \
        --enable-thread-safety \
@@ -781,11 +804,12 @@ rm -f config/libtool.m4
        %{?with_kerberos5:--with-krb5=%{_prefix}} \
        --with-openssl \
        --with-x \
-%{?_with_jdbc: --with-java}
+       %{?with_jdbc:--with-java}
 
 %{__make}
 %{__make} -C contrib/pg_autovacuum
 %{__make} -C contrib/pgcrypto
+%{__make} -C contrib/tsearch2
 %ifnarch sparc sparcv9 sparc64 alpha ppc
 %{?with_tests:%{__make} check}
 %endif
@@ -808,6 +832,9 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
 %{__make} -C contrib/pgcrypto install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%{__make} -C contrib/tsearch2 install \
+       DESTDIR=$RPM_BUILD_ROOT
+
 touch $RPM_BUILD_ROOT/var/log/pgsql
 
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/postgresql
@@ -904,6 +931,8 @@ fi
 %files -f main.lang
 %defattr(644,root,root,755)
 %doc contrib/pg_autovacuum/README*
+%doc doc/FAQ* doc/README* doc/bug.template
+%doc COPYRIGHT README HISTORY
 %attr(754,root,root) /etc/rc.d/init.d/*
 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/sysconfig/*
 
@@ -960,10 +989,6 @@ fi
 %{_mandir}/man1/postgres.1*
 %{_mandir}/man1/postmaster.1*
 
-%doc contrib
-%doc doc/FAQ* doc/README*
-%doc COPYRIGHT README HISTORY doc/bug.template
-
 %files doc
 %defattr(644,root,root,755)
 %doc doc/unpacked/*
@@ -1081,3 +1106,9 @@ fi
 %doc contrib/pgcrypto/README*
 %attr(755,root,root) %{_pgmoduledir}/pgcrypto.so
 %{_datadir}/%{name}/pgcrypto.sql
+
+%files module-tsearch2
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_pgmoduledir}/tsearch2.so
+%{_datadir}/%{name}/tsearch2.sql
+%{_datadir}/%{name}/untsearch2.sql
This page took 0.033038 seconds and 4 git commands to generate.