]> git.pld-linux.org Git - packages/poldek.git/blobdiff - poldek.spec
- force switch to db4.2 and rpm built with it, release 16
[packages/poldek.git] / poldek.spec
index 8001f86ae67b8c5202072cbbb1e652d3e11a396a..c2a202437a0fa0a9d00d3eca8d86b0f3efc30f2d 100644 (file)
@@ -1,39 +1,62 @@
-# conditional build
-#  --with static   -- don't use shared libraries
-#  --without imode -- don't build interactive mode
-#  --without curl  -- don't link curl
+#
+# Conditional build:
+%bcond_with    static  # don't use shared libraries
+%bcond_without imode   # don't build interactive mode
+%bcond_with    curl    # link with curl
+#
+# required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
+%define        ver_db  4.2.50-1
+%define        ver_rpm 4.3-0.20030610.29
 Summary:       RPM packages management helper tool
 Summary(pl):   Pomocnicze narzêdzie do zarz±dzania pakietami RPM
 Name:          poldek
-Version:       0.17.8
-Release:       3
+Version:       0.18.1
+Release:       16
 License:       GPL v2
 Group:         Applications/System
-Source0:       http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.gz
+Source0:       http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.bz2
+# Source0-md5: 8af8090d401254939911e456e2f09e60
 Source1:       %{name}.conf
+Patch0:                %{name}-static.patch
+Patch1:                %{name}-etc_dir.patch
+Patch2:                %{name}-rpm4.2.patch
+Patch3:                %{name}-rpm4.1-fix.patch
+Patch4:                %{name}-retr_term.patch
+Patch5:                %{name}-deps-fix.patch
+Patch6:                %{name}-broken-rpmdb.patch
+Patch7:                %{name}-epoch0.patch
+Patch8:                %{name}-ldb4.patch
 URL:           http://team.pld.org.pl/~mis/poldek/
-#%{!?_with_static:Requires:    trurlib >= 0.43.6}
-Requires:      rpm >= 4.0.2-62
+BuildRequires: automake
+BuildRequires: autoconf
 BuildRequires: bzip2-devel
-%{?_with_curl:BuildRequires:   curl-devel >= 7.8}
-BuildRequires: db3-devel >= 3.1.14-2
-BuildRequires: openssl-devel
+%{?with_curl:BuildRequires:    curl-devel >= 7.8}
+BuildRequires: db-devel >= %{ver_db}
+BuildRequires: gettext-autopoint
+BuildRequires: openssl-devel >= 0.9.7c
 BuildRequires: pcre-devel
 BuildRequires: popt-devel
 BuildRequires: readline-devel
-BuildRequires: rpm-devel >= 4.0.2
-#BuildRequires:        trurlib-devel >= 0.43.6
+BuildRequires: rpm-devel >= %{ver_rpm}
 BuildRequires: zlib-devel
 BuildRequires: /usr/bin/pod2man
-%{?_with_static:BuildRequires: bzip2-static}
-%{?_with_curl:%{?_with_static:BuildRequires:   curl-static}}
-%{?_with_static:BuildRequires: openssl-static}
-%{?_with_static:BuildRequires: popt-static}
-%{?_with_static:BuildRequires: rpm-static}
-#%{?_with_static:BuildRequires:        trurlib-static}
-%{?_with_static:BuildRequires: zlib-static}
-%{?_with_static:BuildRequires: pcre-static}
-%{?_with_static:BuildRequires: db1-static}
+%if %{with static}
+BuildRequires: bzip2-static
+%{?with_curl:BuildRequires:    curl-static}
+BuildRequires: db-static >= %{ver_db}
+BuildRequires: ncurses-static
+BuildRequires: openssl-static
+BuildRequires: pcre-static
+BuildRequires: popt-static
+BuildRequires: readline-static
+BuildRequires: rpm-static
+BuildRequires: zlib-static
+BuildRequires: glibc-static
+%endif
+Requires:      db >= %{ver_db}
+Requires:      rpm >= %{ver_rpm}
+Requires:      sed
+Requires:      openssl >= 0.9.7c
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -46,42 +69,56 @@ interactive mode. The interactive mode puts you into a readline
 interface with command line autocompletion and history, similar to the
 shell mode of Perl's CPAN.
 
-%{?_with_static:This version is statically linked}
+%{?with_static:This version is statically linked.}
 
-%{?_without_imode:This version hasn't got interactive mode.}
+%{!?with_imode:This version hasn't got interactive mode.}
 
 %description -l pl
 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
-instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji 
-usuwania pakietów.
+instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji i
+usuwania pakietów.
 
-Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get)
-lub interaktywnym. Tryb interaktywny posiada interfejs readline 
-z dope³nianiem komend i histori±, podobny do trybu shell perlowego 
-modu³u CPAN. 
+Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get) lub
+interaktywnym. Tryb interaktywny posiada interfejs readline z
+dope³nianiem komend i histori±, podobny do trybu shell perlowego
+modu³u CPAN.
 
-%{?_with_static:Ta wersja jest konsolidowana statycznie.}
+%{?with_static:Ta wersja jest konsolidowana statycznie.}
 
-%{?_without_imode:Ta wersja nie posiada trybu interaktywnego.}
+%{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
 
 %prep
 %setup -q
+%patch0        -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p0
+%patch4 -p1
+%patch5 -p0
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
 
 %build
+%{__autopoint}
+%{__aclocal} -I m4
+%{__autoconf}
+%{__automake}
 %configure \
-       %{?_with_static:--enable-static} \
-       %{?_without_imode:--disable-imode} \
-       %{?_with_curl:--with-curl}
+       %{?with_static:--enable-static} \
+       %{!?with_imode:--disable-imode} \
+       %{?with_curl:--with-curl}
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_sysconfdir}
 
-# no strip cause program's beta stage and core may be useful
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
-%{?_with_static:rm -f $RPM_BUILD_ROOT/%{_bindir}/rpmvercmp}
-sed "s/i686/%{_target_cpu}/g" < %{SOURCE1} > $RPM_BUILD_ROOT/etc/%{name}.conf
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
+sed "s|/i686/|/%{_target_cpu}/|g" < %{SOURCE1} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
 
 %find_lang %{name}
 
@@ -94,3 +131,4 @@ rm -rf $RPM_BUILD_ROOT
 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}.conf
 %attr(755,root,root) %{_bindir}/*
 %{_mandir}/man1/%{name}*
+%lang(pl) %{_mandir}/pl/man1/%{name}*
This page took 0.068303 seconds and 4 git commands to generate.