]> git.pld-linux.org Git - packages/poldek.git/blobdiff - poldek.spec
- changed patch number
[packages/poldek.git] / poldek.spec
index 7554904484ab14b292b80e810a69ae32612ace60..42f1342fa393aef4d45dcea990c273741c09ab0d 100644 (file)
@@ -1,39 +1,60 @@
 #
-# conditional build:
-#  --with static       - don't use shared libraries
-#  --without imode     - don't build interactive mode
-#  --without curl      - don't link curl
+# Conditional build:
+%bcond_with    static  # don't use shared libraries
+%bcond_without imode   # don't build interactive mode
+%bcond_with    curl    # link with curl
+%bcond_with    ignarch # add option ignorearch
 #
+# required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
+%define        ver_db  4.2.50-1
+%define        ver_rpm 4.3-0.20030610.29
 Summary:       RPM packages management helper tool
 Summary(pl):   Pomocnicze narzêdzie do zarz±dzania pakietami RPM
 Name:          poldek
-Version:       0.18.1
-Release:       1.1
+Version:       0.18.3
+Release:       8
 License:       GPL v2
 Group:         Applications/System
-Source0:       http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.bz2
+Source0:       http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.gz
+# Source0-md5: 339c54b86bfd733851c0f7125057f446
 Source1:       %{name}.conf
+Patch0:                %{name}-etc_dir.patch
+Patch1:                %{name}-retr_term.patch
+Patch2:                %{name}-cap_match_req-fix.patch
+%{?with_ignarch:Patch3:        %{name}-ignorearch.patch}
+Patch4:                %{name}-progress.patch
 URL:           http://team.pld.org.pl/~mis/poldek/
-Requires:      rpm >= 4.0.2-62
-Requires:      sed
-BuildRequires: bzip2-devel
-%{?_with_curl:BuildRequires:   curl-devel >= 7.8}
 BuildRequires: automake
 BuildRequires: autoconf
-BuildRequires: openssl-devel
+BuildRequires: bzip2-devel
+%{?with_curl:BuildRequires:    curl-devel >= 7.8}
+BuildRequires: db-devel >= %{ver_db}
+BuildRequires: gettext-autopoint
+BuildRequires: openssl-devel >= 0.9.7d
 BuildRequires: pcre-devel
 BuildRequires: popt-devel
 BuildRequires: readline-devel
-BuildRequires: rpm-devel >= 4.0.2-62
+BuildRequires: rpm-devel >= %{ver_rpm}
 BuildRequires: zlib-devel
-BuildRequires: /usr/bin/pod2man
-%{?_with_static:BuildRequires: bzip2-static}
-%{?_with_curl:%{?_with_static:BuildRequires:   curl-static}}
-%{?_with_static:BuildRequires: openssl-static}
-%{?_with_static:BuildRequires: pcre-static}
-%{?_with_static:BuildRequires: popt-static}
-%{?_with_static:BuildRequires: rpm-static}
-%{?_with_static:BuildRequires: zlib-static}
+BuildRequires: perl-tools-pod
+%if %{with static}
+BuildRequires: bzip2-static
+%{?with_curl:BuildRequires:    curl-static}
+BuildRequires: db-static >= %{ver_db}
+BuildRequires: ncurses-static
+BuildRequires: openssl-static
+BuildRequires: pcre-static
+BuildRequires: popt-static
+BuildRequires: readline-static
+BuildRequires: rpm-static
+BuildRequires: zlib-static
+BuildRequires: glibc-static
+%endif
+Requires:      db >= %{ver_db}
+Requires:      ed
+Requires:      rpm >= %{ver_rpm}
+Requires:      sed
+Requires:      openssl >= 0.9.7c
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -46,59 +67,65 @@ interactive mode. The interactive mode puts you into a readline
 interface with command line autocompletion and history, similar to the
 shell mode of Perl's CPAN.
 
-%{?_with_static:This version is statically linked.}
+%{?with_static:This version is statically linked.}
 
-%{?_without_imode:This version hasn't got interactive mode.}
+%{!?with_imode:This version hasn't got interactive mode.}
 
 %description -l pl
 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
-instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji
-usuwania pakietów.
+instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji i
+usuwania pakietów.
 
-Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get)
-lub interaktywnym. Tryb interaktywny posiada interfejs readline
-dope³nianiem komend i histori±, podobny do trybu shell perlowego
+Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get) lub
+interaktywnym. Tryb interaktywny posiada interfejs readline z
+dope³nianiem komend i histori±, podobny do trybu shell perlowego
 modu³u CPAN.
 
-%{?_with_static:Ta wersja jest konsolidowana statycznie.}
+%{?with_static:Ta wersja jest konsolidowana statycznie.}
 
-%{?_without_imode:Ta wersja nie posiada trybu interaktywnego.}
+%{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
 
 %prep
 %setup -q
+%patch0 -p1
+%patch1 -p1
+%patch2 -p0
+%{?with_ignarch:%patch3 -p1}
+%patch4 -p1
 
 %build
-if ! grep -q AM_GNU_GETTEXT_VERSION configure.in ; then
-       cp configure.in configure.in.orig
-       sed -e 's/AM_GNU_GETTEXT\(.*\)/AM_GNU_GETTEXT\1\
-AM_GNU_GETTEXT_VERSION(0.10.40)/' \
-               -e 's=po/Makefile.in=po/Makefile.in intl/Makefile=' \
-               configure.in.orig >configure.in
-       autopoint --force
-fi
+%{?with_ignarch:rm -f po/pl.gmo}
+%{__autopoint}
 %{__aclocal} -I m4
 %{__autoconf}
 %{__automake}
+cp -f config.sub trurlib
 %configure \
-       %{?_with_static:--enable-static} \
-       %{?_without_imode:--disable-imode} \
-       %{?_with_curl:--with-curl}
+       %{?with_static:--enable-static} \
+       %{!?with_imode:--disable-imode} \
+       %{?with_curl:--with-curl}
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_sysconfdir}
 
-# no strip cause program's beta stage and core may be useful
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
-%{?_with_static:rm -f $RPM_BUILD_ROOT/%{_bindir}/rpmvercmp}
-sed "s|/i686/|/%{_target_cpu}/|g" < %{SOURCE1} > $RPM_BUILD_ROOT/etc/%{name}.conf
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
+sed "s|/i686/|/%{_target_cpu}/|g" < %{SOURCE1} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
 
 %find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%triggerpostun -- poldek <= 0.18.3-5
+if grep -q '^promoteepoch.*yes' /etc/poldek.conf ; then
+       echo -e ',s:^promoteepoch:# promoteepoch:g\n,w' | ed -s /etc/poldek.conf
+fi
+
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc README* NEWS TODO *sample* conf/poldekrc*
This page took 0.0290859999999999 seconds and 4 git commands to generate.