]> git.pld-linux.org Git - packages/phpPgAdmin.git/blobdiff - phpPgAdmin.spec
- upgraded to 5.0.2
[packages/phpPgAdmin.git] / phpPgAdmin.spec
index f79f1c2f9a80a27417fa9280b300c852368c96a2..d60c368a22356be13d4ab22d360af32f702ee13c 100644 (file)
@@ -1,23 +1,31 @@
 # TODO
-# - use system adodb
-# - separate internal files (classes, libraries) and public files (.js, .css, index.php) to htdocs and above and point docroot to htdocs dir
+# - separate internal files (classes, libraries) and public files (.js, .css,
+#   index.php) to htdocs and above and point docroot to htdocs dir
 Summary:       phpPgAdmin - web-based PostgreSQL administration
-Summary(pl):   phpPgAdmin - administracja bazami PostgreSQL przez WWW
+Summary(pl.UTF-8):     phpPgAdmin - administracja bazami PostgreSQL przez WWW
 Name:          phpPgAdmin
-Version:       4.0.1
-Release:       1.8
+Version:       5.0.2
+Release:       1
 License:       GPL v2+
 Group:         Applications/Databases/Interfaces
 Source0:       http://dl.sourceforge.net/phppgadmin/%{name}-%{version}.tar.bz2
-# Source0-md5: 7e0c18a01538572d3c2b435725e68fe2
+# Source0-md5: 4e4d462100ed602d4f6c9b47b1586aba
+Source1:       %{name}-apache.conf
+Source2:       %{name}-lighttpd.conf
+Source3:       http://www.quarto.pl/~gotar/%{name}-jscalendar.tar.bz2
+# Source3-md5: 84115f772a723cc742352c589df9af29
 Patch0:                %{name}-config.patch
+#Patch1:       %{name}-adodb.patch
+Patch2:                %{name}-calendar.patch
 URL:           http://phppgadmin.sourceforge.net/
-BuildRequires: rpmbuild(macros) >= 1.264
+BuildRequires: rpmbuild(macros) >= 1.268
 Requires(triggerpostun):       sed >= 4.0
-Requires:      php >= 3:4.1
-Requires:      php-pcre
-Requires:      php-pgsql >= 3:4.1
+#Requires:     adodb >= 4.67-1.17
+Requires:      php(pcre)
+Requires:      php(pgsql)
+Requires:      php(session)
 Requires:      webapps
+Requires:      webserver(php) >= 5.0
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -30,22 +38,21 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 phpPgAdmin is a fully functional web-based administration utility for
 a PostgreSQL database server. It handles all the basic functionality
 as well as some advanced features such as triggers, views and
-functions (stored procs).
+functions (stored procedures).
 
-%description -l pl
-phpPgAdmin jest w pe³ni funkcjonalnym, bazowanym na WWW, narzêdziem
+%description -l pl.UTF-8
+phpPgAdmin jest w pełni funkcjonalnym, bazowanym na WWW, narzędziem
 administracyjnym dla serwera baz danych PostgreSQL. Posiada wszystkie
-podstawowe mo¿liwo¶ci, jak i czê¶æ bardziej zaawansowanych jak
-prze³±czniki, widoki i funkcje (procedury sk³adowane).
+podstawowe możliwości, jak i część bardziej zaawansowanych jak
+przełączniki, widoki i funkcje (procedury składowane).
 
 %prep
-%setup -q
+%setup -q -a3
 %patch0 -p1
-rm -f conf/config.inc.php-dist
-
-cat > apache.conf <<EOF
-Alias /pgadmin /usr/share/phpPgAdmin
-EOF
+#%patch1 -p1
+%patch2 -p1
+mv conf/config.inc.php{-dist,}
+find . -name \*.orig -exec rm -f \{\} \;
 
 # remove language source files (or one wants to make -devel subpackage?)
 mv -f lang/translations.php .
@@ -59,30 +66,30 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir}}
 
 cp -a *.php *.txt *.js $RPM_BUILD_ROOT%{_appdir}
-cp -a classes help images lang libraries themes xloadtree $RPM_BUILD_ROOT%{_appdir}
+cp -a classes help images js lang libraries themes xloadtree $RPM_BUILD_ROOT%{_appdir}
 cp -a conf/*.php $RPM_BUILD_ROOT%{_sysconfdir}
 
-install apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
-install apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
-#install lighttpd.conf $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
+install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
 
-%triggerin -- apache1
+%triggerin -- apache1 < 1.3.37-3, apache1-base
 %webapp_register apache %{_webapp}
 
-%triggerun -- apache1
+%triggerun -- apache1 < 1.3.37-3, apache1-base
 %webapp_unregister apache %{_webapp}
 
-%triggerin -- apache >= 2.0.0
+%triggerin -- apache < 2.2.0, apache-base
 %webapp_register httpd %{_webapp}
 
-%triggerun -- apache >= 2.0.0
+%triggerun -- apache < 2.2.0, apache-base
 %webapp_unregister httpd %{_webapp}
 
-#%triggerin -- lighttpd
-#%webapp_register lighttpd %{_webapp}
-#
-#%triggerun -- lighttpd
-#%webapp_unregister lighttpd %{_webapp}
+%triggerin -- lighttpd
+%webapp_register lighttpd %{_webapp}
+
+%triggerun -- lighttpd
+%webapp_unregister lighttpd %{_webapp}
 
 %triggerpostun -- %{name} < 4.0.1-1.2
 # rescue app config
@@ -97,6 +104,12 @@ if [ -f /etc/httpd/httpd.conf ]; then
        httpd_reload=1
 fi
 
+# change config version number for 4.1.2
+if [ -f /etc/webapps/phpPgAdmin/config.inc.php ]; then
+       echo "Adjusting configuration for phpPgAdmin 4.1.2"
+       sed -i -e '/conf.*version/s/[0-9][0-9][\t ]*;/17;/' /etc/webapps/phpPgAdmin/config.inc.php
+fi
+
 # migrate from httpd (apache2) config dir
 if [ -f /etc/httpd/phpPgAdmin.conf.rpmsave ]; then
        cp -f %{_sysconfdir}/httpd.conf{,.rpmnew}
@@ -133,14 +146,10 @@ if [ -L /etc/httpd/httpd.conf/99_phpPgAdmin.conf ]; then
 fi
 
 if [ "$httpd_reload" ]; then
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd reload 1>&2
-       fi
+       %service httpd reload
 fi
 if [ "$apache_reload" ]; then
-       if [ -f /var/lock/subsys/apache ]; then
-               /etc/rc.d/init.d/apache reload 1>&2
-       fi
+       %service apache reload
 fi
 
 %clean
@@ -153,7 +162,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %attr(750,root,http) %{_sysconfdir}
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
-#%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
 
 %{_appdir}
This page took 0.033831 seconds and 4 git commands to generate.