]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- 5.2.5RC2
[packages/php.git] / php.spec
index e784bccd13b9a25c489e40e0f7b16f02ae9553f5..f4e7e78580b8e3cd52e297b27d017f73404d7b55 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -12,7 +12,6 @@
 # - make additional headers and checking added by mail patch configurable
 # - apply -hardened patch by default ?
 # - modularize session, standard (output from pure php -m)?
-# - XXX php-fcgi thinks it is cgi api!!!!! XXXX
 #
 # Conditional build:
 %bcond_with    fdf             # with FDF (PDF forms) module           (BR: proprietary lib)
@@ -73,7 +72,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %endif
 
 %define                _rel 0.2
-%define                _rc RC1
+%define                _rc RC2
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     JÄ™zyk skryptowy PHP
@@ -88,7 +87,7 @@ License:      PHP
 Group:         Libraries
 #Source0:      http://www.php.net/distributions/%{name}-%{version}.tar.bz2
 Source0:       http://downloads.php.net/ilia/%{name}-%{version}%{_rc}.tar.bz2
-# Source0-md5: 2f0c9ecbd50213958e9b69ec69f715ec
+# Source0-md5: deb66ac45b18ced1077365b0e0179995
 Source2:       zend.gif
 Source3:       %{name}-mod_%{name}.conf
 Source4:       %{name}-cgi-fcgi.ini
@@ -1818,18 +1817,22 @@ done
 # FCGI
 %if %{with fcgi}
 cp -af php_config.h.fcgi main/php_config.h
+rm -rf sapi/cgi/.libs sapi/cgi/*.lo
 %{__make} sapi/cgi/php-cgi -f Makefile.fcgi
 cp -r sapi/cgi sapi/fcgi
-rm -rf sapi/cgi/.libs sapi/cgi/*.lo
+[ "$(echo '<?=php_sapi_name();' | ./sapi/fcgi/php-cgi -qn)" = cgi-fcgi ] || exit 1
 %endif
 
 # CGI
 cp -af php_config.h.cgi main/php_config.h
+rm -rf sapi/cgi/.libs sapi/cgi/*.lo
 %{__make} sapi/cgi/php-cgi -f Makefile.cgi
+[ "$(echo '<?=php_sapi_name();' | ./sapi/cgi/php-cgi -qn)" = cgi ] || exit 1
 
 # CLI
 cp -af php_config.h.cli main/php_config.h
 %{__make} sapi/cli/php -f Makefile.cli
+[ "$(echo '<?=php_sapi_name();' | ./sapi/cli/php -n)" = cli ] || exit 1
 
 %if %{with tests}
 # Run tests, using the CLI SAPI
This page took 0.027593 seconds and 4 git commands to generate.