]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- 5.2.5RC2
[packages/php.git] / php.spec
index 8cd1763d90ccd90a37c661a70a70e252b2d2fe1e..f4e7e78580b8e3cd52e297b27d017f73404d7b55 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -71,7 +71,8 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define        _rel 2
+%define                _rel 0.2
+%define                _rc RC2
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
@@ -79,13 +80,14 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          php
-Version:       5.2.4
-Release:       %{_rel}%{?with_hardening:hardened}
+Version:       5.2.5
+Release:       %{_rel}%{?_rc:.%{_rc}}%{?with_hardening:hardened}
 Epoch:         4
 License:       PHP
 Group:         Libraries
-Source0:       http://www.php.net/distributions/%{name}-%{version}.tar.bz2
-# Source0-md5: 55c97a671fdabf462cc7a82971a656d2
+#Source0:      http://www.php.net/distributions/%{name}-%{version}.tar.bz2
+Source0:       http://downloads.php.net/ilia/%{name}-%{version}%{_rc}.tar.bz2
+# Source0-md5: deb66ac45b18ced1077365b0e0179995
 Source2:       zend.gif
 Source3:       %{name}-mod_%{name}.conf
 Source4:       %{name}-cgi-fcgi.ini
@@ -127,7 +129,7 @@ Patch26:    %{name}-versioning.patch
 Patch27:       %{name}-linkflags-clean.patch
 Patch28:       %{name}-pear.patch
 Patch29:       %{name}-config-dir.patch
-Patch30:       %{name}-mysql.patch
+Patch30:       %{name}-bug-42952.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -839,6 +841,7 @@ Summary:    ming extension module for PHP
 Summary(pl.UTF-8):     Moduł ming dla PHP
 Group:         Libraries
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Requires:      ming >= 0.3
 Provides:      php(ming)
 
 %description ming
@@ -1551,7 +1554,7 @@ compression support to PHP.
 Moduł PHP umożliwiający używanie kompresji zlib.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{version}%{_rc}
 %patch27 -p1
 %patch0 -p1
 %patch1 -p1
@@ -1569,7 +1572,7 @@ cp php.ini-dist php.ini
 # for ac2.53b/am1.6b - AC_LANG_CXX has AM_CONDITIONAL, so cannot be invoked
 # conditionally...
 %patch11 -p1
-#%patch12 -p1 # breaks with ac cache vars, but later -lpthread is missing ...
+%patch12 -p1
 %patch13 -p1
 %patch14 -p1
 %patch15 -p1
@@ -1651,30 +1654,32 @@ apxs2
 %endif
 "
 for sapi in $sapis; do
+       : SAPI $sapi
        [ -f Makefile.$sapi ] && continue # skip if already configured (for faster debugging purposes)
 
-       %configure \
-       `
+       sapi_args=''
        case $sapi in
        cgi)
-               echo --enable-discard-path --enable-force-cgi-redirect
-       ;;
+               sapi_args='--enable-discard-path --enable-force-cgi-redirect'
+               ;;
        cli)
-               echo --disable-cgi
-       ;;
+               sapi_args='--disable-cgi'
+               ;;
        fcgi)
-               echo --enable-fastcgi --with-fastcgi=/usr --enable-force-cgi-redirect
-       ;;
+               sapi_args='--enable-fastcgi --with-fastcgi=/usr --enable-force-cgi-redirect'
+               ;;
        apxs1)
-               ver=%(rpm -q --qf '%%{version}' apache1-apxs)
-               echo --with-apxs=%{apxs1} --with-apache-version=$ver
-       ;;
+               ver=$(rpm -q --qf '%{V}' apache1-devel)
+               sapi_args="--with-apxs=%{apxs1} --with-apache-version=$ver"
+               ;;
        apxs2)
-               ver=%(rpm -q --qf '%%{version}' apache-apxs)
-               echo --with-apxs2=%{apxs2} --with-apache-version=$ver
-       ;;
+               ver=$(rpm -q --qf '%{V}' apache-devel)
+               sapi_args="--with-apxs2=%{apxs2} --with-apache-version=$ver"
+               ;;
        esac
-       ` \
+
+       %configure \
+       $sapi_args \
 %if "%{!?configure_cache:0}%{?configure_cache}" == "0"
        --cache-file=config.cache \
 %endif
@@ -1802,7 +1807,7 @@ done
 %{__make} build-modules
 
 %if %{with apache1}
-%{__make} libtool-sapi LIBTOOL_SAPI=sapi/apache/libphp5.la -f Makefile.apxs1 LDFLAGS=-lpthread
+%{__make} libtool-sapi LIBTOOL_SAPI=sapi/apache/libphp5.la -f Makefile.apxs1
 %endif
 
 %if %{with apache2}
@@ -1812,18 +1817,22 @@ done
 # FCGI
 %if %{with fcgi}
 cp -af php_config.h.fcgi main/php_config.h
-%{__make} sapi/cgi/php-cgi -f Makefile.fcgi LDFLAGS=-lpthread
-cp -r sapi/cgi sapi/fcgi
 rm -rf sapi/cgi/.libs sapi/cgi/*.lo
+%{__make} sapi/cgi/php-cgi -f Makefile.fcgi
+cp -r sapi/cgi sapi/fcgi
+[ "$(echo '<?=php_sapi_name();' | ./sapi/fcgi/php-cgi -qn)" = cgi-fcgi ] || exit 1
 %endif
 
 # CGI
 cp -af php_config.h.cgi main/php_config.h
-%{__make} sapi/cgi/php-cgi -f Makefile.cgi LDFLAGS=-lpthread
+rm -rf sapi/cgi/.libs sapi/cgi/*.lo
+%{__make} sapi/cgi/php-cgi -f Makefile.cgi
+[ "$(echo '<?=php_sapi_name();' | ./sapi/cgi/php-cgi -qn)" = cgi ] || exit 1
 
 # CLI
 cp -af php_config.h.cli main/php_config.h
-%{__make} sapi/cli/php -f Makefile.cli LDFLAGS=-lpthread
+%{__make} sapi/cli/php -f Makefile.cli
+[ "$(echo '<?=php_sapi_name();' | ./sapi/cli/php -n)" = cli ] || exit 1
 
 %if %{with tests}
 # Run tests, using the CLI SAPI
This page took 0.033694 seconds and 4 git commands to generate.