]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- hack flex scanners to avoid colliding global symbol
[packages/php.git] / php.spec
index b3c48e2eaaf7a30334f2dd2201536caea31349c7..d8e7a7e92ff52d8d1a131d70a46fa28e5bce1f6c 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -112,7 +112,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %define                magic_mime      /usr/share/misc/magic.mime
 %endif
 
-%define                rel     14
+%define                rel     35
 %define                orgname php
 %define                ver_suffix 52
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -197,6 +197,7 @@ Patch44:    %{orgname}-include_path.patch
 Patch45:       %{orgname}-imap-annotations.patch
 Patch46:       %{orgname}-imap-myrights.patch
 Patch47:       suhosin.patch
+Patch48:       no-sslv2.patch
 Patch49:       %{orgname}-m4-divert.patch
 Patch50:       extension-shared-optional-dep.patch
 Patch51:       spl-shared.patch
@@ -209,6 +210,7 @@ Patch57:    php-php_dl.patch
 Patch58:       php-svn-281516.patch
 Patch59:       %{orgname}-systzdata.patch
 Patch60:       bug-60986.patch
+Patch61:       php-bug-71475.patch
 # http://spot.fedorapeople.org/php-5.3.6-libzip.patch
 Patch65:       system-libzip.patch
 Patch66:       bug-47930.patch
@@ -223,6 +225,9 @@ Patch75:    php-secbug-67498.patch
 Patch76:       CVE-2015-0232.patch
 Patch77:       x32.patch
 Patch78:       php-bug-68486.patch
+Patch79:       libevent-2.1.patch
+Patch80:       mysqli-err.patch
+Patch81:       openssl.patch
 # CENTALT patches
 # Backport from 5.3.6
 Patch311:      php-5.3.6-bug-47435.patch
@@ -405,19 +410,32 @@ PHP as DSO module for Apache 1.3.x.
 PHP jako moduł DSO (Dynamic Shared Object) dla Apache 1.3.x.
 
 %package -n apache-mod_%{name}
+Summary:       PHP support for Apache 2.x
+Summary(pl.UTF-8):     Wsparcie PHP dla Apache 2.x
+Group:         Development/Languages/PHP
+Requires:      apache-mod_%{name}-core = %{epoch}:%{version}-%{release}
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Provides:      webserver(php) = %{version}
+Obsoletes:     phpfi
+
+%description -n apache-mod_%{name}
+PHP support for Apache 2.x.
+
+%description -n apache-mod_%{name} -l pl.UTF-8
+Wsparcie PHP dla Apache 2.x.
+
+%package -n apache-mod_%{name}-core
 Summary:       PHP DSO module for Apache 2.x
 Summary(pl.UTF-8):     Moduł DSO (Dynamic Shared Object) PHP dla Apache 2.x
 Group:         Development/Languages/PHP
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      apache(modules-api) = %{apache_modules_api}
 Requires:      apache-mod_mime
-Provides:      webserver(php) = %{version}
-Obsoletes:     phpfi
 
-%description -n apache-mod_%{name}
+%description -n apache-mod_%{name}-core
 PHP as DSO module for Apache 2.x.
 
-%description -n apache-mod_%{name} -l pl.UTF-8
+%description -n apache-mod_%{name}-core -l pl.UTF-8
 PHP jako moduł DSO (Dynamic Shared Object) dla Apache 2.x.
 
 %package fcgi
@@ -588,6 +606,9 @@ Obsoletes:  php54-devel
 Obsoletes:     php55-devel
 Obsoletes:     php56-devel
 Obsoletes:     php70-devel
+Obsoletes:     php71-devel
+Obsoletes:     php72-devel
+Obsoletes:     php73-devel
 
 %description devel
 The php-devel package lets you compile dynamic extensions to PHP.
@@ -647,7 +668,7 @@ Requires:   %{name}-common = %{epoch}:%{version}-%{release}
 Provides:      %{name}-bzip2 = %{epoch}:%{version}-%{release}
 Provides:      php(bz2)
 Provides:      php(bzip2)
-Obsoletes:     php-bzip2
+Obsoletes:     php-bzip2 < 4:5.2.14-3
 
 %description bz2
 This is a dynamic shared object (DSO) for PHP that will add bzip2
@@ -1320,8 +1341,7 @@ URL:              http://www.php.net/manual/en/ref.pdo-pgsql.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      %{name}-pdo = %{epoch}:%{version}-%{release}
 Provides:      php(pdo-pgsql)
-Provides:      php-pecl-PDO_PGSQL
-Obsoletes:     php-pecl-PDO_PGSQL
+Obsoletes:     php-pecl-PDO_PGSQL < 4:5.2.17-1
 
 %description pdo-pgsql
 This is a dynamic shared object (DSO) for PHP that will add PDO
@@ -1924,6 +1944,7 @@ done
 %if %{with suhosin}
 %patch47 -p1
 %endif
+%patch48 -p1
 %patch49 -p1
 %patch50 -p1
 %patch51 -p1
@@ -1936,6 +1957,7 @@ done
 %patch58 -p4
 %patch59 -p1
 %patch60 -p4
+%patch61 -p1
 %{?with_system_libzip:%patch65 -p1}
 %patch66 -p2
 %patch67 -p1
@@ -1949,6 +1971,9 @@ done
 %patch76 -p1
 %patch77 -p1
 %patch78 -p1
+%patch79 -p1
+%patch80 -p1
+%patch81 -p1
 
 # Bugfix backport from 5.3.6
 %patch311 -p1 -b .bug-47435
@@ -1959,6 +1984,9 @@ done
 # causes regression -> magic_quotes_gpc setting cannot be changed
 #%%patch402 -p1 -b .bug-323016
 
+# cleanup backups after patching
+find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
+
 # conflict seems to be resolved by recode patches
 rm -f ext/recode/config9.m4
 
@@ -1995,6 +2023,9 @@ mv sapi/cli/tests/022.phpt{,.broken}
 
 sh -xe %{_sourcedir}/skip-tests.sh
 
+# make colliding symbol static
+%{__sed} -i -e 's/^char \*yytext/static &/' Zend/zend_{ini,language}_scanner.c
+
 %build
 API=$(awk '/#define PHP_API_VERSION/{print $3}' main/php.h)
 if [ $API != %{php_api_version} ]; then
@@ -2069,7 +2100,9 @@ for sapi in $sapis; do
        esac
 
        %configure \
+       CFLAGS="%{rpmcflags} -DOPENSSL_NO_SSL2=1 -DOPENSSL_NO_SSL3=1" \
        FORCE_APACHE_VERSION="${apache_ver}" \
+       EXTRA_LDFLAGS="%{rpmldflags}" \
        $sapi_args \
 %if "%{!?configure_cache:0}%{?configure_cache}" == "0"
        --cache-file=config.cache \
@@ -2081,7 +2114,6 @@ for sapi in $sapis; do
        --with-system-tzdata \
        --%{!?debug:dis}%{?debug:en}able-debug \
        %{?with_zts:--enable-maintainer-zts} \
-       %{?with_suhosin:--enable-suhosin} \
        %{?with_zend_multibyte:--enable-zend-multibyte} \
        --enable-inline-optimization \
        --enable-bcmath=shared \
@@ -2615,9 +2647,12 @@ fi
 %files -n apache-mod_%{name}
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/httpd/conf.d/*_mod_php.conf
+%attr(755,root,root) %{_libdir}/apache/mod_php.so
+
+%files -n apache-mod_%{name}-core
+%defattr(644,root,root,755)
 %dir %{_sysconfdir}/apache2handler.d
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php-apache2handler.ini
-%attr(755,root,root) %{_libdir}/apache/mod_php.so
 %attr(755,root,root) %{_libdir}/apache/libphp5-*.*.so
 %endif
 
This page took 0.031398 seconds and 4 git commands to generate.