]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- hack flex scanners to avoid colliding global symbol
[packages/php.git] / php.spec
index a6d426c0ae26d318a0d927f52d813a83a5014eed..d8e7a7e92ff52d8d1a131d70a46fa28e5bce1f6c 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -112,7 +112,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %define                magic_mime      /usr/share/misc/magic.mime
 %endif
 
-%define                rel     26
+%define                rel     35
 %define                orgname php
 %define                ver_suffix 52
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -226,6 +226,8 @@ Patch76:    CVE-2015-0232.patch
 Patch77:       x32.patch
 Patch78:       php-bug-68486.patch
 Patch79:       libevent-2.1.patch
+Patch80:       mysqli-err.patch
+Patch81:       openssl.patch
 # CENTALT patches
 # Backport from 5.3.6
 Patch311:      php-5.3.6-bug-47435.patch
@@ -606,6 +608,7 @@ Obsoletes:  php56-devel
 Obsoletes:     php70-devel
 Obsoletes:     php71-devel
 Obsoletes:     php72-devel
+Obsoletes:     php73-devel
 
 %description devel
 The php-devel package lets you compile dynamic extensions to PHP.
@@ -1969,6 +1972,8 @@ done
 %patch77 -p1
 %patch78 -p1
 %patch79 -p1
+%patch80 -p1
+%patch81 -p1
 
 # Bugfix backport from 5.3.6
 %patch311 -p1 -b .bug-47435
@@ -2018,6 +2023,9 @@ mv sapi/cli/tests/022.phpt{,.broken}
 
 sh -xe %{_sourcedir}/skip-tests.sh
 
+# make colliding symbol static
+%{__sed} -i -e 's/^char \*yytext/static &/' Zend/zend_{ini,language}_scanner.c
+
 %build
 API=$(awk '/#define PHP_API_VERSION/{print $3}' main/php.h)
 if [ $API != %{php_api_version} ]; then
@@ -2092,6 +2100,7 @@ for sapi in $sapis; do
        esac
 
        %configure \
+       CFLAGS="%{rpmcflags} -DOPENSSL_NO_SSL2=1 -DOPENSSL_NO_SSL3=1" \
        FORCE_APACHE_VERSION="${apache_ver}" \
        EXTRA_LDFLAGS="%{rpmldflags}" \
        $sapi_args \
@@ -2105,7 +2114,6 @@ for sapi in $sapis; do
        --with-system-tzdata \
        --%{!?debug:dis}%{?debug:en}able-debug \
        %{?with_zts:--enable-maintainer-zts} \
-       %{?with_suhosin:--enable-suhosin} \
        %{?with_zend_multibyte:--enable-zend-multibyte} \
        --enable-inline-optimization \
        --enable-bcmath=shared \
This page took 0.0520080000000001 seconds and 4 git commands to generate.