]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- hack flex scanners to avoid colliding global symbol
[packages/php.git] / php.spec
index 38688cdfc58b8796523c76f20e1025107ab75ce8..d8e7a7e92ff52d8d1a131d70a46fa28e5bce1f6c 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -112,7 +112,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %define                magic_mime      /usr/share/misc/magic.mime
 %endif
 
-%define                rel     31
+%define                rel     35
 %define                orgname php
 %define                ver_suffix 52
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -2023,6 +2023,9 @@ mv sapi/cli/tests/022.phpt{,.broken}
 
 sh -xe %{_sourcedir}/skip-tests.sh
 
+# make colliding symbol static
+%{__sed} -i -e 's/^char \*yytext/static &/' Zend/zend_{ini,language}_scanner.c
+
 %build
 API=$(awk '/#define PHP_API_VERSION/{print $3}' main/php.h)
 if [ $API != %{php_api_version} ]; then
@@ -2111,7 +2114,6 @@ for sapi in $sapis; do
        --with-system-tzdata \
        --%{!?debug:dis}%{?debug:en}able-debug \
        %{?with_zts:--enable-maintainer-zts} \
-       %{?with_suhosin:--enable-suhosin} \
        %{?with_zend_multibyte:--enable-zend-multibyte} \
        --enable-inline-optimization \
        --enable-bcmath=shared \
This page took 0.045564 seconds and 4 git commands to generate.