]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
Up to 7.4.13
[packages/php.git] / php.spec
index 8d3bfe1f9b4a041be2e12b3a4d634c1448155f1f..c90ac7cdf0039b7f444ca823d9e8374f81100bc1 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -29,7 +29,7 @@
 %bcond_without phpdbg          # disable phpdbg SAPI
 # - Extensions
 %bcond_without bcmath          # without bcmath extension module
-%bcond_without bz2             # without bz2 extension module
+%bcond_without bzip2           # without bz2 extension module
 %bcond_without calendar        # without calendar extension module
 %bcond_without ctype           # without ctype extension module
 %bcond_without curl            # without CURL extension module
 %undefine      with_pdo_sqlite
 %endif
 
-%define                rel     1
 %define                orgname php
 %define                ver_suffix 74
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -150,7 +149,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 7 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       7.4.3
+Version:       7.4.13
 Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -159,7 +158,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       https://php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: 853df4727b2dcde52e9cc9d944f87498
+# Source0-md5: ccf5b33ab267b742c408d589934a143d
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
@@ -197,7 +196,6 @@ Patch43:    %{orgname}-silent-session-cleanup.patch
 Patch44:       %{orgname}-include_path.patch
 Patch50:       extension-shared-optional-dep.patch
 Patch53:       fix-test-run.patch
-Patch55:       bug-52078-fileinode.patch
 Patch59:       %{orgname}-systzdata.patch
 Patch60:       %{orgname}-oracle-instantclient.patch
 Patch66:       php-db.patch
@@ -465,7 +463,9 @@ Summary:    /usr/bin/php symlink
 Summary(pl.UTF-8):     Dowiązanie symboliczne /usr/bin/php
 Group:         Development/Languages/PHP
 Requires:      %{name}-cli = %{epoch}:%{version}-%{release}
+%if "%_rpmversion" != "4.16.0"
 Obsoletes:     /usr/bin/php
+%endif
 Obsoletes:     php-program < 4:5.3.28-7
 
 %description program
@@ -624,6 +624,7 @@ Obsoletes:  php56-devel
 Obsoletes:     php70-devel
 Obsoletes:     php71-devel
 Obsoletes:     php73-devel
+Obsoletes:     php80-devel
 
 %description devel
 The php-devel package lets you compile dynamic extensions to PHP.
@@ -1897,8 +1898,6 @@ cp -p php.ini-production php.ini
 %patch50 -p1
 
 %patch53 -p1
-%undos ext/spl/tests/SplFileInfo_getInode_basic.phpt
-%patch55 -p1
 %patch59 -p1 -b .systzdata
 %if %{with instantclient}
 %patch60 -p1 -b .instantclient
@@ -2206,6 +2205,7 @@ for sapi in $sapis; do
        --%{!?with_debug:dis}%{?with_debug:en}able-debug \
        %{?with_zts:--enable-maintainer-zts} \
        --enable-inline-optimization \
+       --enable-option-checking=fatal \
        %{__enable_disable bcmath bcmath shared} \
        %{__enable_disable calendar calendar shared} \
        %{__enable_disable ctype ctype shared} \
@@ -2255,7 +2255,7 @@ for sapi in $sapis; do
        --enable-tokenizer=shared \
        --enable-xml=shared \
        --enable-xmlreader=shared \
-       %{__with_without bz2 bz2 shared} \
+       %{__with_without bzip2 bz2 shared} \
        %{__with_without curl curl shared} \
        --with-db4 \
        %{__with_without iconv iconv shared} \
@@ -2614,7 +2614,14 @@ fi
 # restart webserver at the end of transaction
 [ ! -f /etc/httpd/conf.d/??_mod_php.conf ] || %service -q httpd restart
 
-%triggerpostun common -- php-common < 4:5.3.28-7
+%triggerpostun common -- %{name}-common < 4:5.6.4-2, php-common < 4:5.6.4-2
+# switch to browscap package if the ini file has original value
+%{__sed} -i -e 's#%{_sysconfdir}/browscap.ini#/usr/share/browscap/php_browscap.ini#' %{_sysconfdir}/php.ini
+# disable browscap, if optional package not present
+if [ ! -e /usr/share/browscap/php_browscap.ini ]; then
+       %{__sed} -i -e 's#^browscap = /usr/share/browscap/php_browscap.ini#;&#' %{_sysconfdir}/php.ini
+fi
+
 # migrate configs /etc/php/conf.d -> /etc/phpXY/conf.d/
 # do config migration in php-common trigger, as the trigger is ran after all packages are upgraded
 # this way we can stick to one trigger, instead of attaching one for each (sub)package!
@@ -2635,14 +2642,6 @@ for f in /etc/php/*.ini.rpmsave /etc/php/*.d/*.ini.rpmsave; do
        ' $nf
 done
 
-%triggerpostun common -- %{name}-common < 4:5.6.4-2, php-common < 4:5.6.4-2
-# switch to browscap package if the ini file has original value
-%{__sed} -i -e 's#%{_sysconfdir}/browscap.ini#/usr/share/browscap/php_browscap.ini#' %{_sysconfdir}/php.ini
-# disable browscap, if optional package not present
-if [ ! -e /usr/share/browscap/php_browscap.ini ]; then
-       %{__sed} -i -e 's#^browscap = /usr/share/browscap/php_browscap.ini#;&#' %{_sysconfdir}/php.ini
-fi
-
 %triggerpostun -n apache-mod_%{name} -- apache-mod_%{name} < 4:7.0.0-2.RC4
 sed -i -e 's#modules/libphp[57].so#modules/mod_php.so#g' /etc/httpd/conf.d/*_mod_php.conf
 
@@ -2846,7 +2845,7 @@ fi
 %attr(755,root,root) %{php_extensiondir}/bcmath.so
 %endif
 
-%if %{with bz2}
+%if %{with bzip2}
 %files bz2
 %defattr(644,root,root,755)
 %doc ext/bz2/CREDITS
This page took 0.042467 seconds and 4 git commands to generate.