]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
version phpdbg binary/man to allow parallel install
[packages/php.git] / php.spec
index 2f35ac5ec52128bedc0f216ef4ea3a9d5cef580c..b776de00cd6009925d008523d5dc6363dc05ea60 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -1,5 +1,4 @@
 # TODO 5.6:
-# - phpdbg: link with libphp_common
 # - enable --with-fpm-systemd, but ensure it checks for sd_booted()
 # - build with system libgd 2.1, see 73c5128
 # TODO 5.4:
@@ -18,9 +17,6 @@
 # - wddx: restore session support (not compiled in due DL extension check)
 # - make additional headers and checking added by mail patch configurable
 # - modularize standard (output from pure php -m)?
-# - WARNING: Phar: sha256/sha512 signature support disabled if ext/hash is
-#   built shared, also PHAR_HAVE_OPENSSL is false if openssl is built shared.
-#   make it runtime dep and add Suggests (or php warning messages)
 # - some mods should be shared:
 #$ php -m
 # [PHP Modules]
@@ -153,7 +149,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel     2
+%define                rel     1
 %define                orgname php
 %define                ver_suffix 56
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -164,7 +160,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       5.6.17
+Version:       5.6.23
 Release:       %{rel}
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -173,7 +169,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: 5e080e4b7df5db24f1b64313f8114bd8
+# Source0-md5: c2d2155e50bcbaa0ee7a63845862c894
 Source2:       %{orgname}-mod_%{orgname}.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
@@ -234,6 +230,7 @@ Patch67:    mysql-lib-ver-mismatch.patch
 
 Patch69:       fpm-conf-split.patch
 Patch70:       mysqlnd-ssl.patch
+Patch72:       phar-hash-shared.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -1519,6 +1516,7 @@ Summary(pl.UTF-8):        Moduł phar dla PHP
 Group:         Libraries
 URL:           http://www.php.net/manual/en/book.phar.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Requires:      %{name}-hash = %{epoch}:%{version}-%{release}
 Requires:      %{name}-spl = %{epoch}:%{version}-%{release}
 Requires:      alternatives
 Suggests:      %{name}-cli
@@ -2089,8 +2087,9 @@ exit 1
 %patch67 -p1
 
 %patch70 -p1
+%patch72 -p1
 
-sed -i -e '/PHP_ADD_LIBRARY_WITH_PATH/s#xmlrpc,#xmlrpc-epi,#' ext/xmlrpc/config.m4
+%{__sed} -i -e '/PHP_ADD_LIBRARY_WITH_PATH/s#xmlrpc,#xmlrpc-epi,#' ext/xmlrpc/config.m4
 
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
@@ -2344,6 +2343,7 @@ for sapi in $sapis; do
        esac
 
        %configure \
+       EXTRA_LDFLAGS="%{rpmldflags}" \
        $sapi_args \
 %if "%{!?configure_cache:0}%{?configure_cache}" == "0"
        --cache-file=config.cache \
@@ -2644,7 +2644,12 @@ libtool --mode=install install -p sapi/litespeed/php $RPM_BUILD_ROOT%{_sbindir}/
 
 %if %{with phpdbg}
 %{__make} -f Makefile.phpdbg install-phpdbg \
+       INSTALL="libtool --mode=install install -p" \
        INSTALL_ROOT=$RPM_BUILD_ROOT
+
+# version the .phar files
+mv $RPM_BUILD_ROOT%{_bindir}/phpdbg{,%{ver_suffix}}
+mv $RPM_BUILD_ROOT%{_mandir}/man1/phpdbg{,%{ver_suffix}}.1
 %endif
 
 %if %{with milter}
@@ -3043,8 +3048,8 @@ fi
 %if %{with phpdbg}
 %files phpdbg
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/phpdbg
-%{_mandir}/man1/phpdbg.1*
+%attr(755,root,root) %{_bindir}/phpdbg%{ver_suffix}
+%{_mandir}/man1/phpdbg%{ver_suffix}.1*
 %endif
 
 %if %{with milter}
This page took 0.028345 seconds and 4 git commands to generate.