]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- update to 5.2.4,
[packages/php.git] / php.spec
index 7dd97be4139303d40e0427618a530c8a008cd8fa..8cd1763d90ccd90a37c661a70a70e252b2d2fe1e 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -46,7 +46,7 @@
 %bcond_without apache2         # disable building apache 2.x module
 %bcond_without fcgi            # disable building FCGI SAPI
 %bcond_without zts             # disable experimental-zts
-%bcond_without tests
+%bcond_with    tests           # default off; test process very often hangs on buildersl; perform "make test"
 %bcond_with    versioning      # build with experimental versioning (to load php4/php5 into same apache)
 
 %define apxs1          /usr/sbin/apxs1
@@ -71,7 +71,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define        _rel 3
+%define        _rel 2
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
@@ -79,13 +79,13 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          php
-Version:       5.2.2
+Version:       5.2.4
 Release:       %{_rel}%{?with_hardening:hardened}
 Epoch:         4
 License:       PHP
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{name}-%{version}.tar.bz2
-# Source0-md5: d084337867d70b50a10322577be0e44e
+# Source0-md5: 55c97a671fdabf462cc7a82971a656d2
 Source2:       zend.gif
 Source3:       %{name}-mod_%{name}.conf
 Source4:       %{name}-cgi-fcgi.ini
@@ -127,6 +127,7 @@ Patch26:    %{name}-versioning.patch
 Patch27:       %{name}-linkflags-clean.patch
 Patch28:       %{name}-pear.patch
 Patch29:       %{name}-config-dir.patch
+Patch30:       %{name}-mysql.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -377,6 +378,7 @@ Provides:   php(spl)
 Provides:      php(standard)
 Provides:      php(zend_extension_api) = %{zend_extension_api}
 Provides:      php(zend_module_api) = %{zend_module_api}
+%{?with_pcre:Provides: php-pcre}
 Provides:      php5(debug) = %{php_debug}
 Provides:      php5(thread-safety) = %{zend_zts}
 Obsoletes:     php-pcre < 4:5.2.0
@@ -1506,6 +1508,7 @@ Summary:  xsl extension module for PHP
 Summary(pl.UTF-8):     Moduł xsl dla PHP
 Group:         Libraries
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Requires:      %{name}-dom = %{epoch}:%{version}-%{release}
 Requires:      libxslt >= 1.0.18
 # actually not true, functionality is similar, but API differs
 Provides:      php(xsl)
@@ -1589,6 +1592,7 @@ patch -p1 < %{PATCH22} || exit 1
 
 %patch28 -p1
 %patch29 -p1
+%patch30 -p1
 
 # conflict seems to be resolved by recode patches
 rm -f ext/recode/config9.m4
@@ -1798,7 +1802,7 @@ done
 %{__make} build-modules
 
 %if %{with apache1}
-%{__make} libtool-sapi LIBTOOL_SAPI=sapi/apache/libphp5.la -f Makefile.apxs1
+%{__make} libtool-sapi LIBTOOL_SAPI=sapi/apache/libphp5.la -f Makefile.apxs1 LDFLAGS=-lpthread
 %endif
 
 %if %{with apache2}
@@ -1808,14 +1812,14 @@ done
 # FCGI
 %if %{with fcgi}
 cp -af php_config.h.fcgi main/php_config.h
-%{__make} sapi/cgi/php -f Makefile.fcgi LDFLAGS=-lpthread
+%{__make} sapi/cgi/php-cgi -f Makefile.fcgi LDFLAGS=-lpthread
 cp -r sapi/cgi sapi/fcgi
 rm -rf sapi/cgi/.libs sapi/cgi/*.lo
 %endif
 
 # CGI
 cp -af php_config.h.cgi main/php_config.h
-%{__make} sapi/cgi/php -f Makefile.cgi LDFLAGS=-lpthread
+%{__make} sapi/cgi/php-cgi -f Makefile.cgi LDFLAGS=-lpthread
 
 # CLI
 cp -af php_config.h.cli main/php_config.h
@@ -1858,11 +1862,11 @@ sed -i -e "s|^libdir=.*|libdir='%{_libdir}'|" $RPM_BUILD_ROOT%{_libdir}/libphp_c
 sed -i -e 's|libphp_common.la|$(libdir)/libphp_common.la|' $RPM_BUILD_ROOT%{_libdir}/php/build/acinclude.m4
 
 # install CGI
-libtool --silent --mode=install install sapi/cgi/php $RPM_BUILD_ROOT%{_bindir}/php.cgi
+libtool --silent --mode=install install sapi/cgi/php-cgi $RPM_BUILD_ROOT%{_bindir}/php.cgi
 
 # install FCGI
 %if %{with fcgi}
-libtool --silent --mode=install install sapi/fcgi/php $RPM_BUILD_ROOT%{_bindir}/php.fcgi
+libtool --silent --mode=install install sapi/fcgi/php-cgi $RPM_BUILD_ROOT%{_bindir}/php.fcgi
 %endif
 
 # install CLI
This page took 0.031678 seconds and 4 git commands to generate.