]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- rel 2; Add PDO::MYSQL_ATTR_SSL_VERIFY_SERVER_CERT (backport)
[packages/php.git] / php.spec
index 6374c330ee8f3694e04c7d0b20156357d1463dde..8c0c82b29b1aea46240c0c931a941c586061f250 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -74,7 +74,7 @@
 %bcond_without mhash           # without mhash extension (supported by hash extension)
 %bcond_without mssql           # without MS SQL extension module
 %bcond_without mysql           # without ext/mysql support
-%bcond_without mysqli          # without mysqli support (Requires mysql > 4.1)
+%bcond_without mysqli          # without mysqli support (Requires mysql >= 4.1)
 %bcond_without mysqlnd         # without mysqlnd support in mysql related extensions
 %bcond_with    oci             # with Oracle oci8 extension module     (BR: proprietary libs)
 %bcond_without odbc            # without ODBC extension module
@@ -154,7 +154,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel     1
+%define                rel     2
 %define                orgname php
 %define                ver_suffix 56
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -165,7 +165,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       5.6.29
+Version:       5.6.30
 Release:       %{rel}
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -174,7 +174,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: 190bf5b52d1fc68d5500a8cdc7e33164
+# Source0-md5: 68753955a8964ae49064c6424f81eb3e
 Source2:       %{orgname}-mod_%{orgname}.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
@@ -236,6 +236,7 @@ Patch67:    mysql-lib-ver-mismatch.patch
 Patch69:       fpm-conf-split.patch
 Patch70:       mysqlnd-ssl.patch
 Patch72:       phar-hash-shared.patch
+Patch73:       php-pdo-ssl.patch
 URL:           http://php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -1498,7 +1499,6 @@ Requires: %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      %{name}-pdo = %{epoch}:%{version}-%{release}
 Provides:      php(pdo-pgsql)
 Provides:      php(pdo_pgsql)
-Provides:      php-pecl-PDO_PGSQL = 4:5.3.28-7
 Obsoletes:     php-pdo-pgsql < 4:5.3.28-7
 Obsoletes:     php-pecl-PDO_PGSQL < 4:5.2.1-2
 
@@ -2130,6 +2130,7 @@ exit 1
 
 %patch70 -p1
 %patch72 -p1
+%patch73 -p1
 
 %{__sed} -i -e '/PHP_ADD_LIBRARY_WITH_PATH/s#xmlrpc,#xmlrpc-epi,#' ext/xmlrpc/config.m4
 
@@ -2209,7 +2210,6 @@ sed -i -e 's#-fvisibility=hidden##g' configure*
 %{__rm} ext/sockets/tests/mcast_ipv?_recv.phpt
 # causes stack exhausion
 %{__rm} Zend/tests/bug54268.phpt
-%{__rm} Zend/tests/bug68412.phpt
 
 # avoid issues when two builds run simultaneously
 %ifarch %{x8664}
@@ -2758,8 +2758,8 @@ touch $RPM_BUILD_ROOT%{_sbindir}/php-fpm
 %endif
 
 %{__sed} -i -e '
-       s#/usr/lib/php#%{php_extensiondir}#
-       s#/etc/php#%{_sysconfdir}#
+       s#/usr/lib/php#%{php_extensiondir}#g
+       s#/etc/php/#%{_sysconfdir}/#g
        s#@processname@#%{name}-fpm#g
 ' $RPM_BUILD_ROOT{/etc/{rc.d/init.d/%{name}-fpm,logrotate.d/%{name}-fpm},%{_sysconfdir}/php-fpm.conf,%{_sysconfdir}/fpm.d/www.conf}
 %endif
@@ -2798,8 +2798,8 @@ cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/php-apache2handler.ini
 # ensure that paths are correct for current php version and arch
 grep -El '/etc/php/|/usr/lib/php/' $RPM_BUILD_ROOT%{_sysconfdir}/*.ini | xargs -r \
 %{__sed} -i -e '
-       s#/usr/lib/php#%{php_extensiondir}#
-       s#/etc/php#%{_sysconfdir}#
+       s#/usr/lib/php#%{php_extensiondir}#g
+       s#/etc/php/#%{_sysconfdir}/#g
 '
 
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/conf.d
This page took 0.040512 seconds and 4 git commands to generate.