]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
cleanup configure options not accepting directory
[packages/php.git] / php.spec
index db7bae040d75b4491058486e516b7815a8641073..897907740ca5c8a201e802c69070499af57737d0 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -38,6 +38,7 @@
 %bcond_without dom             # without DOM extension module
 %bcond_without enchant         # without Enchant extension module
 %bcond_without exif            # without EXIF extension module
+%bcond_without ffi             # without FFI extension module
 %bcond_without fileinfo        # without fileinfo extension module
 %bcond_without filter          # without filter extension module
 %bcond_without ftp             # without FTP extension module
@@ -152,7 +153,7 @@ Summary(ru.UTF-8):  PHP Версии 7 - язык препроцессирова
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
 Version:       7.4.0
-Release:       0.1
+Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
@@ -223,6 +224,7 @@ BuildRequires:      elfutils-devel
 %{?with_enchant:BuildRequires: enchant-devel >= 1.1.3}
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
 %{?with_argon2:BuildRequires:  libargon2-devel >= 20161029}
+%{?with_ffi:BuildRequires:     libffi-devel}
 %{?with_sodium:BuildRequires:  libsodium-devel >= 1.0.8}
 %if %{with pdo_dblib}
 BuildRequires: freetds-devel >= 0.82
@@ -834,6 +836,17 @@ support in image files.
 %description exif -l pl.UTF-8
 Moduł PHP dodający obsługę znaczników EXIF w plikach obrazków.
 
+%package ffi
+Summary:       %{modname} - Foreign Function Interface
+Group:         Libraries
+URL:           https://www.php.net/manual/en/book.ffi.php
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Provides:      php(ffi) = %{version}
+
+%description ffi
+FFI is a multi-platform extension for PHP that allows you to bind to
+functions from arbitrary shared libraries and call them.
+
 %package fileinfo
 Summary:       libmagic bindings
 Summary(pl.UTF-8):     Wiązania do libmagic
@@ -2241,7 +2254,7 @@ for sapi in $sapis; do
        --with-pdo-dblib=shared \
 %endif
 %if %{with pdo_firebird}
-       --with-pdo-firebird=shared,/usr \
+       --with-pdo-firebird=shared \
 %endif
        %{?with_mhash:--with-mhash=yes} \
        --with-mysql-sock=/var/lib/mysql/mysql.sock \
@@ -2249,9 +2262,8 @@ for sapi in $sapis; do
        %{?with_pdo_oci:--with-pdo-oci=shared%{?with_instantclient:,instantclient,%{_libdir}}} \
        %{?with_pdo_odbc:--with-pdo-odbc=shared,unixODBC,/usr} \
        %{?with_pdo_pgsql:--with-pdo-pgsql=shared} \
-       %{?with_pdo_sqlite:--with-pdo-sqlite=shared,/usr} \
-       %{?with_webp:--with-webp-dir=/usr --with-webp} \
-       --without-libexpat-dir \
+       %{?with_pdo_sqlite:--with-pdo-sqlite=shared} \
+       %{?with_webp:--with-webp} \
        %{__enable_disable posix posix shared} \
        --enable-shared \
        %{__enable_disable session session shared} \
@@ -2270,15 +2282,16 @@ for sapi in $sapis; do
        %{__with_without curl curl shared} \
        --with-db4 \
        %{__with_without iconv iconv shared} \
-       %{?with_enchant:--with-enchant=shared,/usr} \
-       --with-freetype-dir=shared \
+       %{?with_enchant:--with-enchant=shared} \
+       --with-freetype \
        %{__with_without gettext gettext shared} \
-       %{__enable_disable gd gd shared%{?with_system_gd:,/usr}} \
+       %{__enable_disable gd gd shared} \
        %{?with_system_gd:--with-external-gd} \
        --with-gdbm \
        %{__with_without gmp gmp shared} \
+       %{__with_without ffi ffi shared} \
        %{?with_imap:--with-imap=shared --with-imap-ssl} \
-       --with-jpeg-dir=/usr \
+       --with-jpeg \
        %{?with_ldap:--with-ldap=shared --with-ldap-sasl} \
        %{?with_mm:--with-mm} \
        %{?with_mysqlnd:--enable-mysqlnd=shared} \
@@ -2288,25 +2301,22 @@ for sapi in $sapis; do
        %{?with_openssl:--with-openssl=shared} \
        %{?with_kerberos5:--with-kerberos} \
        --with-tcadb=/usr \
-       %{__with_without pcre pcre-regex /usr} \
        %{?with_pcre:--with-external-pcre} \
        %{__enable_disable filter filter shared} \
-       %{__with_without pgsql pgsql shared,/usr} \
+       %{__with_without pgsql pgsql shared} \
        %{__enable_disable phar phar shared} \
-       --with-png-dir=/usr \
        %{?with_pspell:--with-pspell=shared} \
        %{__with_without readline readline shared} \
        %{?with_recode:--with-recode=shared} \
        %{?with_snmp:--with-snmp=shared} \
        %{!?with_pdo_sqlite:--without-pdo-sqlite} \
-       %{__with_without sqlite3 sqlite3 shared,/usr} \
+       %{__with_without sqlite3 sqlite3 shared} \
        %{?with_tidy:--with-tidy=shared} \
-       %{?with_odbc:--with-unixODBC=shared,/usr} \
+       %{?with_odbc:--with-unixODBC=shared} \
        %{__with_without xmlrpc xmlrpc shared,/usr} \
        %{?with_xsl:--with-xsl=shared} \
        --with-zlib=shared \
-       --with-zlib-dir=shared,/usr \
-       %{?with_zip:--with-zip=shared,/usr} \
+       %{?with_zip:--with-zip=shared} \
 
        # save for debug
        cp -f Makefile Makefile.$sapi
@@ -2720,6 +2730,7 @@ fi \
 %extension_scripts dom
 %extension_scripts enchant
 %extension_scripts exif
+%extension_scripts ffi
 %extension_scripts fileinfo
 %extension_scripts filter
 %extension_scripts ftp
@@ -2958,6 +2969,14 @@ fi
 %attr(755,root,root) %{php_extensiondir}/exif.so
 %endif
 
+%if %{with ffi}
+%files ffi
+%defattr(644,root,root,755)
+%doc ext/ffi/CREDITS
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/ffi.ini
+%attr(755,root,root) %{php_extensiondir}/ffi.so
+%endif
+
 %if %{with fileinfo}
 %files fileinfo
 %defattr(644,root,root,755)
This page took 0.036904 seconds and 4 git commands to generate.