]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
cleanup configure options not accepting directory
[packages/php.git] / php.spec
index 65e939470db5fa0b26672df8284d67c304314666..897907740ca5c8a201e802c69070499af57737d0 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2,9 +2,6 @@
 # - mysqlnd driver doesn't support reconnect: https://bugs.php.net/bug.php?id=52561
 # TODO 5.6:
 # - enable --with-fpm-systemd, but ensure it checks for sd_booted()
-# TODO 5.4:
-# - update imap annotations patch (needs api porting)
-# - update imap myrights patch (needs api porting)
 # TODO:
 # - fileinfo extension bundles magic db in library: data_file.c (dump of magic.mgc) is 14M
 #   - 2.3M fileinfo.so php54-fileinfo-5.4.6-0.15.x86_64
@@ -41,6 +38,7 @@
 %bcond_without dom             # without DOM extension module
 %bcond_without enchant         # without Enchant extension module
 %bcond_without exif            # without EXIF extension module
+%bcond_without ffi             # without FFI extension module
 %bcond_without fileinfo        # without fileinfo extension module
 %bcond_without filter          # without filter extension module
 %bcond_without ftp             # without FTP extension module
@@ -155,7 +153,7 @@ Summary(ru.UTF-8):  PHP Версии 7 - язык препроцессирова
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
 Version:       7.4.0
-Release:       0.1
+Release:       1
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
@@ -201,8 +199,6 @@ Patch41:    %{orgname}-fpm-config.patch
 Patch42:       %{orgname}-fpm-shared.patch
 Patch43:       %{orgname}-silent-session-cleanup.patch
 Patch44:       %{orgname}-include_path.patch
-Patch45:       %{orgname}-imap-annotations.patch
-Patch46:       %{orgname}-imap-myrights.patch
 Patch50:       extension-shared-optional-dep.patch
 Patch53:       fix-test-run.patch
 Patch55:       bug-52078-fileinode.patch
@@ -215,7 +211,7 @@ Patch68:    php-mysql-ssl-context.patch
 Patch70:       mysqlnd-ssl.patch
 Patch71:       libdb-info.patch
 URL:           http://php.net/
-%{?with_pdo_firebase:%{!?with_interbase_inst:BuildRequires:    Firebird-devel >= 1.0.2.908-2}}
+%{?with_pdo_firebird:%{!?with_interbase_inst:BuildRequires:    Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake >= 1.4d
@@ -228,6 +224,7 @@ BuildRequires:      elfutils-devel
 %{?with_enchant:BuildRequires: enchant-devel >= 1.1.3}
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
 %{?with_argon2:BuildRequires:  libargon2-devel >= 20161029}
+%{?with_ffi:BuildRequires:     libffi-devel}
 %{?with_sodium:BuildRequires:  libsodium-devel >= 1.0.8}
 %if %{with pdo_dblib}
 BuildRequires: freetds-devel >= 0.82
@@ -246,8 +243,8 @@ BuildRequires:      libjpeg-devel
 BuildRequires: libltdl-devel >= 1.4
 BuildRequires: libpng-devel >= 1.0.8
 %{?with_intl:BuildRequires:    libstdc++-devel}
-%{?with_webp:BuildRequires:    libwebp-devel}
 BuildRequires: libtool >= 2:2.4.6
+%{?with_webp:BuildRequires:    libwebp-devel}
 BuildRequires: libxml2-devel >= 1:2.7.6-4
 %{?with_xsl:BuildRequires:     libxslt-devel >= 1.1.0}
 %{?with_zip:BuildRequires:     libzip-devel >= 1.3.1}
@@ -559,8 +556,8 @@ Provides:   %{name}-core
 Provides:      %{name}-date
 Provides:      %{name}-hash = %{epoch}:%{version}-%{release}
 Provides:      %{name}-pcre = %{epoch}:%{version}-%{release}
-Provides:      %{name}-spl = %{epoch}:%{version}-%{release}
 Provides:      %{name}-reflection
+Provides:      %{name}-spl = %{epoch}:%{version}-%{release}
 Provides:      %{name}-standard
 Provides:      php(core) = %{version}
 Provides:      php(date)
@@ -839,6 +836,17 @@ support in image files.
 %description exif -l pl.UTF-8
 Moduł PHP dodający obsługę znaczników EXIF w plikach obrazków.
 
+%package ffi
+Summary:       %{modname} - Foreign Function Interface
+Group:         Libraries
+URL:           https://www.php.net/manual/en/book.ffi.php
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Provides:      php(ffi) = %{version}
+
+%description ffi
+FFI is a multi-platform extension for PHP that allows you to bind to
+functions from arbitrary shared libraries and call them.
+
 %package fileinfo
 Summary:       libmagic bindings
 Summary(pl.UTF-8):     Wiązania do libmagic
@@ -1903,8 +1911,6 @@ cp -p php.ini-production php.ini
 %patch42 -p1
 %patch43 -p1
 %patch44 -p1
-#%patch45 -p1 # imap annotations. fixme
-#%patch46 -p1 # imap myrights. fixme
 %patch50 -p1
 
 %patch53 -p1
@@ -1940,7 +1946,7 @@ find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 #%{__rm} -r ext/dba/libinifile
 #%{__rm} -r ext/gd/libgd
 #%{__rm} -r ext/mbstring/libmbfl
-%{__rm} -r ext/pcre/pcre2lib
+#%{__rm} -r ext/pcre/pcre2lib
 #%{__rm} -r ext/soap/interop
 %{__rm} -r ext/xmlrpc/libxmlrpc
 #%{__rm} -r ext/zip/lib
@@ -2248,7 +2254,7 @@ for sapi in $sapis; do
        --with-pdo-dblib=shared \
 %endif
 %if %{with pdo_firebird}
-       --with-pdo-firebird=shared,/usr \
+       --with-pdo-firebird=shared \
 %endif
        %{?with_mhash:--with-mhash=yes} \
        --with-mysql-sock=/var/lib/mysql/mysql.sock \
@@ -2256,9 +2262,8 @@ for sapi in $sapis; do
        %{?with_pdo_oci:--with-pdo-oci=shared%{?with_instantclient:,instantclient,%{_libdir}}} \
        %{?with_pdo_odbc:--with-pdo-odbc=shared,unixODBC,/usr} \
        %{?with_pdo_pgsql:--with-pdo-pgsql=shared} \
-       %{?with_pdo_sqlite:--with-pdo-sqlite=shared,/usr} \
-       %{?with_webp:--with-webp-dir=/usr --with-webp} \
-       --without-libexpat-dir \
+       %{?with_pdo_sqlite:--with-pdo-sqlite=shared} \
+       %{?with_webp:--with-webp} \
        %{__enable_disable posix posix shared} \
        --enable-shared \
        %{__enable_disable session session shared} \
@@ -2277,15 +2282,16 @@ for sapi in $sapis; do
        %{__with_without curl curl shared} \
        --with-db4 \
        %{__with_without iconv iconv shared} \
-       %{?with_enchant:--with-enchant=shared,/usr} \
-       --with-freetype-dir=shared \
+       %{?with_enchant:--with-enchant=shared} \
+       --with-freetype \
        %{__with_without gettext gettext shared} \
-       %{__enable_disable gd gd shared%{?with_system_gd:,/usr}} \
+       %{__enable_disable gd gd shared} \
        %{?with_system_gd:--with-external-gd} \
        --with-gdbm \
        %{__with_without gmp gmp shared} \
+       %{__with_without ffi ffi shared} \
        %{?with_imap:--with-imap=shared --with-imap-ssl} \
-       --with-jpeg-dir=/usr \
+       --with-jpeg \
        %{?with_ldap:--with-ldap=shared --with-ldap-sasl} \
        %{?with_mm:--with-mm} \
        %{?with_mysqlnd:--enable-mysqlnd=shared} \
@@ -2295,25 +2301,22 @@ for sapi in $sapis; do
        %{?with_openssl:--with-openssl=shared} \
        %{?with_kerberos5:--with-kerberos} \
        --with-tcadb=/usr \
-       %{__with_without pcre pcre-regex /usr} \
        %{?with_pcre:--with-external-pcre} \
        %{__enable_disable filter filter shared} \
-       %{__with_without pgsql pgsql shared,/usr} \
+       %{__with_without pgsql pgsql shared} \
        %{__enable_disable phar phar shared} \
-       --with-png-dir=/usr \
        %{?with_pspell:--with-pspell=shared} \
        %{__with_without readline readline shared} \
        %{?with_recode:--with-recode=shared} \
        %{?with_snmp:--with-snmp=shared} \
        %{!?with_pdo_sqlite:--without-pdo-sqlite} \
-       %{__with_without sqlite3 sqlite3 shared,/usr} \
+       %{__with_without sqlite3 sqlite3 shared} \
        %{?with_tidy:--with-tidy=shared} \
-       %{?with_odbc:--with-unixODBC=shared,/usr} \
+       %{?with_odbc:--with-unixODBC=shared} \
        %{__with_without xmlrpc xmlrpc shared,/usr} \
        %{?with_xsl:--with-xsl=shared} \
        --with-zlib=shared \
-       --with-zlib-dir=shared,/usr \
-       %{?with_zip:--with-zip=shared,/usr} \
+       %{?with_zip:--with-zip=shared} \
 
        # save for debug
        cp -f Makefile Makefile.$sapi
@@ -2727,6 +2730,7 @@ fi \
 %extension_scripts dom
 %extension_scripts enchant
 %extension_scripts exif
+%extension_scripts ffi
 %extension_scripts fileinfo
 %extension_scripts filter
 %extension_scripts ftp
@@ -2745,16 +2749,16 @@ fi \
 %extension_scripts odbc
 %extension_scripts opcache
 %extension_scripts openssl
+%extension_scripts pcntl
 %extension_scripts pdo
 %extension_scripts pdo-dblib
 %extension_scripts pdo-firebird
-%extension_scripts pdo-oci
 %extension_scripts pdo-mysql
+%extension_scripts pdo-oci
 %extension_scripts pdo-odbc
 %extension_scripts pdo-pgsql
 %extension_scripts pdo-sqlite
 %extension_scripts pgsql
-%extension_scripts pcntl
 %extension_scripts posix
 %extension_scripts pspell
 %extension_scripts recode
@@ -2965,6 +2969,14 @@ fi
 %attr(755,root,root) %{php_extensiondir}/exif.so
 %endif
 
+%if %{with ffi}
+%files ffi
+%defattr(644,root,root,755)
+%doc ext/ffi/CREDITS
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/ffi.ini
+%attr(755,root,root) %{php_extensiondir}/ffi.so
+%endif
+
 %if %{with fileinfo}
 %files fileinfo
 %defattr(644,root,root,755)
This page took 0.059604 seconds and 4 git commands to generate.