]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- backport from PHP CVS to fix compilation with PostgreSQL 7.2.x
[packages/php.git] / php.spec
index e6a86a997ce64743742860a0367da776c022797a..5f80fc21be5ae0e36652abc1280d0b46b1442674 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -1,18 +1,8 @@
-#
-# Automatic pear requirements finding:
-%include       /usr/lib/rpm/macros.php
-
-%define        _apache2        %(rpm -q apache-devel 2> /dev/null | grep -Eq '\\-2\\.[0-9]+\\.' && echo 1 || echo 0)
-%define        apxs            /usr/sbin/apxs
 
-%if %{_apache2}
-%define        without_recode          1
-%define        without_mm              1
-%endif
+# SECURITY: CAN-2003-0097 CAN-2003-0166 CAN-2003-0172(?) CAN-2003-0860 CAN-2003-0861 CAN-2003-0863 CAN-2004-0263(?) CAN-2004-0594 CAN-2004-0595 CAN-2004-0958 CAN-2004-0959
 
-%ifnarch %{ix86}
-%define        without_msession        1
-%endif
+# Automatic pear requirements finding:
+%include       /usr/lib/rpm/macros.php
 
 # Conditional build:
 %bcond_with interbase   # - with InterBase extension module    (BR: proprietary libs)
 %bcond_without xmlrpc   # - without XML-RPC extension module
 %bcond_without xslt     # - without XSLT extension module
 
+%define        _apache2        %(rpm -q apache-devel 2> /dev/null | grep -Eq '\\-2\\.[0-9]+\\.' && echo 1 || echo 0)
+%define        apxs            /usr/sbin/apxs
+
+%if %{_apache2}
+%undefine      with_recode
+%undefine      with_mm
+%endif
+
+%ifnarch %{ix86}
+%undefine      with_msession
+%endif
+
 Summary:       The PHP HTML-embedded scripting language for use with Apache
 Summary(fr):   Le langage de script embarque-HTML PHP pour Apache
 Summary(pl):   Jêzyk skryptowy PHP -- u¿ywany wraz z serwerem Apache
@@ -53,7 +55,7 @@ Summary(ru):  PHP 
 Summary(uk):   PHP ÷ÅÒÓ¦§ 4 -- ÍÏ×Á ÐÒÅÐÒÏÃÅÓÕ×ÁÎÎÑ HTML-ÆÁÊ̦×, ×ÉËÏÎÕ×ÁÎÁ ÎÁ ÓÅÒ×ÅÒ¦
 Name:          php
 Version:       4.2.3
-Release:       15
+Release:       17
 Epoch:         3
 Group:         Libraries
 License:       PHP
@@ -91,9 +93,13 @@ Patch20:     %{name}-ini.patch
 Patch21:       %{name}-acam.patch
 Patch22:       %{name}-xmlrpc-fix.patch
 Patch23:       %{name}-iconv-bug18039.patch
+# CAN-2002-1396
 Patch24:       %{name}-wrap.patch
+# CAN-2003-0442
 Patch25:       %{name}-sessid.patch
+# similar to CAN-2004-0263(?)
 Patch26:       %{name}-vhost.patch
+Patch27:       %{name}-gd_free.patch
 Icon:          php4.gif
 URL:           http://www.php.net/
 BuildRequires: apache-devel
@@ -1350,6 +1356,7 @@ cp php.ini-dist php.ini
 %patch24 -p1
 %patch25 -p1
 %patch26 -p1
+%patch27 -p1
 
 install -d manual
 bzip2 -dc %{SOURCE3} | tar -xf - -C manual
@@ -1406,7 +1413,7 @@ for i in cgi apxs ; do
        --enable-yp=shared \
        --with-bz2=shared \
        %{?with_cpdf:--with-cpdflib=shared} \
-       --with-cpdflin
+       --with-cpdflin \
        --with-crack=shared \
 %if %{defined with_curl}
        --with-curl=shared \
This page took 0.064687 seconds and 4 git commands to generate.