]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- up to 5.3.8
[packages/php.git] / php.spec
index d07af02b829bec9007ca5dda7d800edcbb762ab2..5be991ef8df270eb0091467d3bb05f118f6098af 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -4,7 +4,7 @@
 # - wddx: restore session support (not compiled in due DL extension check)
 # - deal with modules removed from php and not moved to PECL, still not obsoleted anywhere
 #   - removed from php 5.0 (currently in php4):
-#   db [pecl-svn], hyperwave [pecl-svn], java [pecl-svn], mcal [pecl-svn], overload [???], qtdom [pecl-svn]
+#   db [pecl-svn], hyperwave [pecl-svn], java [pecl-svn], mcal [pecl-svn], qtdom [pecl-svn]
 #   - removed from php 5.1:
 #   oracle [pecl-svn]
 #   - removed from php 5.2:
 %bcond_without filter          # without filter extension module
 %bcond_without imap            # without IMAP extension module
 %bcond_without interbase       # without InterBase extension module
+%bcond_without kerberos5       # without Kerberos5 support
 %bcond_without litespeed       # build litespeed module
 %bcond_without ldap            # without LDAP extension module
+%bcond_without mhash           # without mhash extension (supported by hash extension)
 %bcond_without mm              # without mm support for session storage
 %bcond_without mssql           # without MS SQL extension module
 # don't turn it on by default; see TODO item for mysqlnd in this spec
 %bcond_without odbc            # without ODBC extension module
 %bcond_without openssl         # without OpenSSL support and OpenSSL extension (module)
 %bcond_without pcre            # without PCRE extension module
+%bcond_without pdo_sqlite      # without PDO SQLite extension module
 %bcond_without pgsql           # without PostgreSQL extension module
 %bcond_without phar            # without phar extension module
 %bcond_without pspell          # without pspell extension module
 %bcond_without recode          # without recode extension module
 %bcond_without snmp            # without SNMP extension module
-%bcond_without sqlite          # without SQLite extension module
+%bcond_without sqlite2         # without SQLite extension module
 %bcond_without sqlite3         # without SQLite3 extension module
 %bcond_without sybase_ct       # without Sybase-CT extension module
 %bcond_without tidy            # without Tidy extension module
@@ -102,7 +105,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel     8
+%define                rel     1
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
@@ -110,13 +113,13 @@ Summary(pt_BR.UTF-8):     A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          php
-Version:       5.3.5
-Release:       %{rel}%{?with_type_hints:th}
+Version:       5.3.8
+Release:       %{rel}%{?with_type_hints:.th}%{?with_oci8:.oci}
 Epoch:         4
 License:       PHP
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{name}-%{version}.tar.bz2
-# Source0-md5: 8aaf20c95e91f25c5b6a591e5d6d61b9
+# Source0-md5: 704cd414a0565d905e1074ffdc1fadfb
 Source2:       %{name}-mod_%{name}.conf
 Source3:       %{name}-cgi-fcgi.ini
 Source4:       %{name}-apache.ini
@@ -159,7 +162,6 @@ Patch26:    %{name}-pear.patch
 Patch27:       %{name}-config-dir.patch
 Patch29:       %{name}-fcgi-graceful.patch
 Patch31:       %{name}-fcgi-error_log-no-newlines.patch
-Patch32:       %{name}-curl-limit-speed.patch
 Patch34:       %{name}-libtool.patch
 Patch35:       %{name}-tds.patch
 Patch36:       %{name}-mysql-charsetphpini.patch
@@ -184,6 +186,9 @@ Patch57:    bug-52448.patch
 Patch59:       %{name}-systzdata.patch
 Patch60:       %{name}-oracle-instantclient.patch
 Patch61:       %{name}-krb5-ac.patch
+Patch62:       mcrypt-libs.patch
+Patch63:       %{name}-mysql-nowarning.patch
+Patch64:       %{name}-m4.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -197,6 +202,7 @@ BuildRequires:      db-devel >= 4.0
 BuildRequires: elfutils-devel
 #BuildRequires:        fcgi-devel
 #BuildRequires:        flex
+%{?with_kerberos5:BuildRequires:       heimdal-devel}
 BuildRequires: mysql-devel
 BuildRequires: pkgconfig
 BuildRequires: sed >= 4.0
@@ -244,12 +250,14 @@ BuildRequires:    readline-devel
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpm-build >= 4.4.0
 BuildRequires: rpmbuild(macros) >= 1.566
-%{?with_sqlite:BuildRequires:  sqlite-devel}
-%{?with_sqlite3:BuildRequires: sqlite3-devel >= 3.3.9}
+%{?with_sqlite2:BuildRequires: sqlite-devel}
+%if %{with sqlite3} || %{with pdo_sqlite}
+BuildRequires: sqlite3-devel >= 3.3.9
+%endif
 BuildRequires: t1lib-devel
 %{?with_tidy:BuildRequires:    tidy-devel}
 %{?with_odbc:BuildRequires:    unixODBC-devel}
-%{?with_xmlrpc:BuildRequires:  xmlrpc-epi-devel}
+%{?with_xmlrpc:BuildRequires:  xmlrpc-epi-devel >= 0.54.1}
 BuildRequires: zlib-devel >= 1.0.9
 %if %{with apache1}
 BuildRequires: apache1-devel
@@ -466,19 +474,18 @@ Provides: php(ereg)
 Provides:      php(hash)
 Provides:      php(libxml)
 Provides:      php(modules_api) = %{php_api_version}
-Provides:      php(overload)
 Provides:      php(reflection)
 Provides:      php(standard)
 Provides:      php(zend_extension_api) = %{zend_extension_api}
 Provides:      php(zend_module_api) = %{zend_module_api}
 Provides:      php-date
 Provides:      php-ereg
-Provides:      php-overload
 Provides:      php-reflection
 Provides:      php-standard
 Provides:      php5(debug) = %{php_debug}
 Provides:      php5(thread-safety) = %{zend_zts}
 %{!?with_mysqlnd:Obsoletes:    php-mysqlnd}
+%{?with_pcre:%requires_ge_to   pcre pcre-devel}
 Obsoletes:     php-pecl-domxml
 Conflicts:     php4-common < 3:4.4.4-8
 Conflicts:     rpm < 4.4.2-0.2
@@ -803,9 +810,11 @@ Group:             Libraries
 URL:           http://www.php.net/manual/en/book.gmp.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Provides:      php(hash)
+%if %{with mhash}
 Provides:      php(mhash)
 Provides:      php-mhash = %{epoch}:%{version}-%{release}
 Obsoletes:     php-mhash < 4:5.3.0
+%endif
 Obsoletes:     php-pecl-hash
 
 %description hash
@@ -1828,7 +1837,6 @@ cp php.ini-production php.ini
 %patch27 -p1
 %patch29 -p1
 %patch31 -p1
-%patch32 -p1
 %if "%{pld_release}" != "ac"
 %patch34 -p1
 %endif
@@ -1860,7 +1868,9 @@ cp php.ini-production php.ini
 %patch59 -p1
 %patch60 -p1
 %patch61 -p1
-
+%patch62 -p1
+%patch63 -p1
+%patch64 -p1
 %{__rm} -r sapi/litespeed
 gzip -dc %{SOURCE15} | tar xf - -C sapi/
 
@@ -2034,20 +2044,19 @@ for sapi in $sapis; do
 %if %{with interbase} && %{without interbase_inst}
        --with-pdo-firebird=shared,/usr \
 %endif
+       %{?with_mhash:--with-mhash=yes} \
        --with-mysql-sock=/var/lib/mysql/mysql.sock \
        --with-pdo-mysql=shared%{?with_mysqlnd:,mysqlnd} \
        %{?with_oci8:--with-pdo-oci=shared%{?with_instantclient:,instantclient,%{_libdir}}} \
        %{?with_odbc:--with-pdo-odbc=shared,unixODBC,/usr} \
        %{?with_pgsql:--with-pdo-pgsql=shared} \
-       %{?with_sqlite:--with-pdo-sqlite=shared,/usr} \
+       %{?with_pdo_sqlite:--with-pdo-sqlite=shared,/usr} \
        --without-libexpat-dir \
-       --enable-overload=shared \
        --enable-posix=shared \
        --enable-shared \
        --enable-session=shared \
        --enable-shmop=shared \
        --enable-simplexml=shared \
-       --enable-spl=shared \
        --enable-sysvmsg=shared \
        --enable-sysvsem=shared \
        --enable-sysvshm=shared \
@@ -2080,7 +2089,7 @@ for sapi in $sapis; do
        %{?with_mysqli:--with-mysqli=shared%{?with_mysqlnd:,mysqlnd}} \
        %{?with_oci8:--with-oci8=shared%{?with_instantclient:,instantclient,%{_libdir}}} \
        %{?with_openssl:--with-openssl=shared} \
-       --with-kerberos \
+       %{?with_kerberos5:--with-kerberos} \
        %{__with_without pcre pcre-regex /usr} \
        %{__enable_disable filter filter shared} \
        --with-pear=%{php_pear_dir} \
@@ -2093,7 +2102,8 @@ for sapi in $sapis; do
        --with-regex=system \
        %{?with_snmp:--with-snmp=shared} \
        %{?with_sybase_ct:--with-sybase-ct=shared,/usr} \
-       %{!?with_sqlite:--without-sqlite --without-pdo-sqlite}%{?with_sqlite:--with-sqlite=shared,/usr --enable-sqlite-utf8} \
+       %{!?with_sqlite2:--without-sqlite}%{?with_sqlite2:--with-sqlite=shared,/usr --enable-sqlite-utf8} \
+       %{!?with_pdo_sqlite:--without-pdo-sqlite} \
        %{__with_without sqlite3 sqlite3 shared,/usr} \
        --with-t1lib=shared \
        %{?with_tidy:--with-tidy=shared} \
@@ -2964,7 +2974,7 @@ fi
 %attr(755,root,root) %{php_extensiondir}/pdo_pgsql.so
 %endif
 
-%if %{with sqlite}
+%if %{with pdo_sqlite}
 %files pdo-sqlite
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/pdo_sqlite.ini
@@ -3051,7 +3061,7 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/SPL.ini
 %attr(755,root,root) %{php_extensiondir}/spl.so
 
-%if %{with sqlite}
+%if %{with sqlite2}
 %files sqlite
 %defattr(644,root,root,755)
 %doc ext/sqlite/{README,TODO,CREDITS}
This page took 0.058217 seconds and 4 git commands to generate.