]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- up to 5.3.8
[packages/php.git] / php.spec
index 2cc61821812825fc480e274bfdb969e518527d42..5be991ef8df270eb0091467d3bb05f118f6098af 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -1,15 +1,14 @@
-# TODO
-# - NOTE: mysqlnd does not support ssl or compression (see FAQ at http://dev.mysql.com/downloads/connector/php-mysqlnd/)
+# NOTE: mysqlnd does not support ssl or compression (see FAQ at http://dev.mysql.com/downloads/connector/php-mysqlnd/)
+# TODO:
+# - ttyname_r() misdetected http://bugs.php.net/bug.php?id=48820
 # - wddx: restore session support (not compiled in due DL extension check)
 # - deal with modules removed from php and not moved to PECL, still not obsoleted anywhere
 #   - removed from php 5.0 (currently in php4):
-#   db, hyperwave, java, mcal, overload, qtdom
+#   db [pecl-svn], hyperwave [pecl-svn], java [pecl-svn], mcal [pecl-svn], qtdom [pecl-svn]
 #   - removed from php 5.1:
-#   cpdf, fam, oracle
+#   oracle [pecl-svn]
 #   - removed from php 5.2:
-#   filepro, hw
-#   - removed from php 5.3:
-#   dbase, mime_magic, ming, ncurses, sybase
+#   filepro [pecl-svn], hwapi [pecl-svn]
 # - make additional headers and checking added by mail patch configurable
 # - modularize standard (output from pure php -m)?
 # - lib64 patch obsolete by $PHP_LIBDIR ?
 %bcond_with    oci8            # with Oracle oci8 extension module     (BR: proprietary libs)
 %bcond_with    instantclient   # build Oracle oci8 extension module against oracle-instantclient package
 %bcond_with    system_gd       # with system gd (we prefer internal since it enables few more features)
-%bcond_with    litespeed       # build litespeed module
 %bcond_without curl            # without CURL extension module
 %bcond_without filter          # without filter extension module
 %bcond_without imap            # without IMAP extension module
 %bcond_without interbase       # without InterBase extension module
+%bcond_without kerberos5       # without Kerberos5 support
+%bcond_without litespeed       # build litespeed module
 %bcond_without ldap            # without LDAP extension module
+%bcond_without mhash           # without mhash extension (supported by hash extension)
 %bcond_without mm              # without mm support for session storage
 %bcond_without mssql           # without MS SQL extension module
 # don't turn it on by default; see TODO item for mysqlnd in this spec
 %bcond_without odbc            # without ODBC extension module
 %bcond_without openssl         # without OpenSSL support and OpenSSL extension (module)
 %bcond_without pcre            # without PCRE extension module
+%bcond_without pdo_sqlite      # without PDO SQLite extension module
 %bcond_without pgsql           # without PostgreSQL extension module
 %bcond_without phar            # without phar extension module
 %bcond_without pspell          # without pspell extension module
 %bcond_without recode          # without recode extension module
 %bcond_without snmp            # without SNMP extension module
-%bcond_without sqlite          # without SQLite extension module
+%bcond_without sqlite2         # without SQLite extension module
 %bcond_without sqlite3         # without SQLite3 extension module
 %bcond_without sybase_ct       # without Sybase-CT extension module
 %bcond_without tidy            # without Tidy extension module
@@ -57,7 +59,7 @@
 %bcond_without xmlrpc          # without XML-RPC extension module
 %bcond_without apache1         # disable building Apache 1.3.x SAPI
 %bcond_without apache2         # disable building Apache 2.x SAPI
-%bcond_without zts             # disable Zend Thread Safety
+%bcond_with    zts             # Zend Thread Safety
 %bcond_without cgi             # disable CGI/FCGI SAPI
 %bcond_without fpm             # disable FPM
 %bcond_without suhosin         # with suhosin patch
@@ -67,7 +69,7 @@
 
 %define apxs1          /usr/sbin/apxs1
 %define        apxs2           /usr/sbin/apxs
-%define        litespeed_version       5.4
+%define        litespeed_version       5.5
 
 # disable all sapis
 %if %{with gcov}
@@ -103,7 +105,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel             9
+%define                rel     1
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
@@ -111,13 +113,13 @@ Summary(pt_BR.UTF-8):     A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          php
-Version:       5.3.3
-Release:       %{rel}%{?with_type_hints:th}
+Version:       5.3.8
+Release:       %{rel}%{?with_type_hints:.th}%{?with_oci8:.oci}
 Epoch:         4
 License:       PHP
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{name}-%{version}.tar.bz2
-# Source0-md5: 21ceeeb232813c10283a5ca1b4c87b48
+# Source0-md5: 704cd414a0565d905e1074ffdc1fadfb
 Source2:       %{name}-mod_%{name}.conf
 Source3:       %{name}-cgi-fcgi.ini
 Source4:       %{name}-apache.ini
@@ -130,7 +132,7 @@ Source12:   %{name}-branch.sh
 Source13:      dep-tests.sh
 Source14:      skip-tests.sh
 Source15:      http://litespeedtech.com/packages/lsapi/%{name}-litespeed-%{litespeed_version}.tgz
-# Source15-md5:        8738d9e3a232c2a0518c514802c66d73
+# Source15-md5:        9d58485d5fd6b5f5fefcec41b9ce283e
 Patch0:                %{name}-shared.patch
 Patch1:                %{name}-pldlogo.patch
 Patch2:                %{name}-mail.patch
@@ -160,7 +162,6 @@ Patch26:    %{name}-pear.patch
 Patch27:       %{name}-config-dir.patch
 Patch29:       %{name}-fcgi-graceful.patch
 Patch31:       %{name}-fcgi-error_log-no-newlines.patch
-Patch32:       %{name}-curl-limit-speed.patch
 Patch34:       %{name}-libtool.patch
 Patch35:       %{name}-tds.patch
 Patch36:       %{name}-mysql-charsetphpini.patch
@@ -181,12 +182,13 @@ Patch52:  pcre-shared.patch
 Patch53:       fix-test-run.patch
 Patch54:       mysqlnd-shared.patch
 Patch55:       bug-52078-fileinode.patch
-Patch56:       bug-51901.patch
 Patch57:       bug-52448.patch
-Patch58:       bug-52533.patch
 Patch59:       %{name}-systzdata.patch
 Patch60:       %{name}-oracle-instantclient.patch
 Patch61:       %{name}-krb5-ac.patch
+Patch62:       mcrypt-libs.patch
+Patch63:       %{name}-mysql-nowarning.patch
+Patch64:       %{name}-m4.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -200,6 +202,8 @@ BuildRequires:      db-devel >= 4.0
 BuildRequires: elfutils-devel
 #BuildRequires:        fcgi-devel
 #BuildRequires:        flex
+%{?with_kerberos5:BuildRequires:       heimdal-devel}
+BuildRequires: mysql-devel
 BuildRequires: pkgconfig
 BuildRequires: sed >= 4.0
 %if %{with mssql} || %{with sybase_ct}
@@ -237,7 +241,7 @@ BuildRequires:      openssl-devel >= 0.9.7d
 %{?with_snmp:BuildRequires:    net-snmp-devel >= 5.0.7}
 %{?with_instantclient:BuildRequires:   oracle-instantclient-devel}
 BuildRequires: pam-devel
-%{?with_pcre:BuildRequires:    pcre-devel >= 6.6}
+%{?with_pcre:BuildRequires:    pcre-devel >= 8.10}
 BuildRequires: pkgconfig
 %{?with_pgsql:BuildRequires:   postgresql-backend-devel >= 7.2}
 %{?with_pgsql:BuildRequires:   postgresql-devel}
@@ -246,12 +250,14 @@ BuildRequires:    readline-devel
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpm-build >= 4.4.0
 BuildRequires: rpmbuild(macros) >= 1.566
-%{?with_sqlite:BuildRequires:  sqlite-devel}
-%{?with_sqlite3:BuildRequires: sqlite3-devel >= 3.3.9}
+%{?with_sqlite2:BuildRequires: sqlite-devel}
+%if %{with sqlite3} || %{with pdo_sqlite}
+BuildRequires: sqlite3-devel >= 3.3.9
+%endif
 BuildRequires: t1lib-devel
 %{?with_tidy:BuildRequires:    tidy-devel}
 %{?with_odbc:BuildRequires:    unixODBC-devel}
-%{?with_xmlrpc:BuildRequires:  xmlrpc-epi-devel}
+%{?with_xmlrpc:BuildRequires:  xmlrpc-epi-devel >= 0.54.1}
 BuildRequires: zlib-devel >= 1.0.9
 %if %{with apache1}
 BuildRequires: apache1-devel
@@ -468,19 +474,18 @@ Provides: php(ereg)
 Provides:      php(hash)
 Provides:      php(libxml)
 Provides:      php(modules_api) = %{php_api_version}
-Provides:      php(overload)
 Provides:      php(reflection)
 Provides:      php(standard)
 Provides:      php(zend_extension_api) = %{zend_extension_api}
 Provides:      php(zend_module_api) = %{zend_module_api}
 Provides:      php-date
 Provides:      php-ereg
-Provides:      php-overload
 Provides:      php-reflection
 Provides:      php-standard
 Provides:      php5(debug) = %{php_debug}
 Provides:      php5(thread-safety) = %{zend_zts}
 %{!?with_mysqlnd:Obsoletes:    php-mysqlnd}
+%{?with_pcre:%requires_ge_to   pcre pcre-devel}
 Obsoletes:     php-pecl-domxml
 Conflicts:     php4-common < 3:4.4.4-8
 Conflicts:     rpm < 4.4.2-0.2
@@ -514,7 +519,7 @@ Requires:   libtool >= 2:2.2
 %else
 Requires:      libtool
 %endif
-%{?with_pcre:Requires: pcre-devel >= 6.6}
+%{?with_pcre:Requires: pcre-devel >= 8.10}
 Requires:      shtool
 Obsoletes:     php-pear-devel
 Obsoletes:     php4-devel
@@ -577,7 +582,7 @@ Requires:   %{name}-common = %{epoch}:%{version}-%{release}
 Provides:      php(bz2)
 Provides:      php(bzip2)
 Provides:      php-bzip2 = %{epoch}:%{version}-%{release}
-Obsoletes:     php-bzip2
+Obsoletes:     php-bzip2 < 4:5.2.14-3
 
 %description bz2
 This is a dynamic shared object (DSO) for PHP that will add bzip2
@@ -689,6 +694,7 @@ URL:                http://www.php.net/manual/en/book.fileinfo.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      %{name}-pcre = %{epoch}:%{version}-%{release}
 Provides:      php(fileinfo)
+Obsoletes:     php-mime_magic
 Obsoletes:     php-pecl-fileinfo
 
 %description fileinfo
@@ -804,9 +810,11 @@ Group:             Libraries
 URL:           http://www.php.net/manual/en/book.gmp.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Provides:      php(hash)
+%if %{with mhash}
 Provides:      php(mhash)
 Provides:      php-mhash = %{epoch}:%{version}-%{release}
-Obsoletes:     php-mhash
+Obsoletes:     php-mhash < 4:5.3.0
+%endif
 Obsoletes:     php-pecl-hash
 
 %description hash
@@ -973,43 +981,6 @@ databases support through FreeTDS library.
 Moduł PHP dodający obsługę baz danych MS SQL poprzez bibliotekę
 FreeTDS.
 
-%package mysqlnd
-Summary:       MySQL Native Client Driver for PHP
-Summary(pl.UTF-8):     Sterownik natywnego klienta MySQL dla PHP
-Group:         Libraries
-URL:           http://www.php.net/manual/en/book.mysqlnd.php
-Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-Provides:      php(mysqlnd)
-
-%description mysqlnd
-MySQL Native Driver is a replacement for the MySQL Client Library
-(libmysql).
-
-Because MySQL Native Driver is written as a PHP extension, it is
-tightly coupled to the workings of PHP. This leads to gains in
-efficiency, especially when it comes to memory usage, as the driver
-uses the PHP memory management system. It also supports the PHP memory
-limit. Using MySQL Native Driver leads to comparable or better
-performance than using MySQL Client Library, it always ensures the
-most efficient use of memory. One example of the memory efficiency is
-the fact that when using the MySQL Client Library, each row is stored
-in memory twice, whereas with the MySQL Native Driver each row is only
-stored once in memory.
-
-%description mysqlnd -l pl.UTF-8
-MySQL Native Driver (natywny sterownik MySQL) to zamiennik biblioteki
-klienckiej MySQL (libmysql).
-
-Ponieważ sterownik natywny jest napisany jako rozszerzenie PHP, jest
-ściśle powiązany z pracą PHP. Daje to większą wydajność, zwłaszcza
-jeśli chodzi o wykorzystanie pamięci, jako że sterownik wykorzystuje
-system zarządzania pamięcią PHP; obsługuje także ograniczenie pamięci
-z PHP. Niniejszy sterownik ma wydajność porównywalną lub lepszą niż
-biblioteka kliencka MySQL, a pamięć zawsze wykorzystuje efektywniej.
-Przykładem tego może być fakt, że w przypadku biblioteki klienckiej
-każdy wiersz jest przechowywany w pamięci dwukrotnie, natomiast przy
-tym sterowniku - tylko raz.
-
 %package mysql
 Summary:       MySQL database module for PHP
 Summary(pl.UTF-8):     Moduł bazy danych MySQL dla PHP
@@ -1050,6 +1021,43 @@ Moduł PHP umożliwiający udoskonalony dostęp do bazy danych MySQL.
 Różnicą między nim a modułem mysql jest dostęp do funkcjonalności
 MySQL w wersji 4.1 i nowszych.
 
+%package mysqlnd
+Summary:       MySQL Native Client Driver for PHP
+Summary(pl.UTF-8):     Sterownik natywnego klienta MySQL dla PHP
+Group:         Libraries
+URL:           http://www.php.net/manual/en/book.mysqlnd.php
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Provides:      php(mysqlnd)
+
+%description mysqlnd
+MySQL Native Driver is a replacement for the MySQL Client Library
+(libmysql).
+
+Because MySQL Native Driver is written as a PHP extension, it is
+tightly coupled to the workings of PHP. This leads to gains in
+efficiency, especially when it comes to memory usage, as the driver
+uses the PHP memory management system. It also supports the PHP memory
+limit. Using MySQL Native Driver leads to comparable or better
+performance than using MySQL Client Library, it always ensures the
+most efficient use of memory. One example of the memory efficiency is
+the fact that when using the MySQL Client Library, each row is stored
+in memory twice, whereas with the MySQL Native Driver each row is only
+stored once in memory.
+
+%description mysqlnd -l pl.UTF-8
+MySQL Native Driver (natywny sterownik MySQL) to zamiennik biblioteki
+klienckiej MySQL (libmysql).
+
+Ponieważ sterownik natywny jest napisany jako rozszerzenie PHP, jest
+ściśle powiązany z pracą PHP. Daje to większą wydajność, zwłaszcza
+jeśli chodzi o wykorzystanie pamięci, jako że sterownik wykorzystuje
+system zarządzania pamięcią PHP; obsługuje także ograniczenie pamięci
+z PHP. Niniejszy sterownik ma wydajność porównywalną lub lepszą niż
+biblioteka kliencka MySQL, a pamięć zawsze wykorzystuje efektywniej.
+Przykładem tego może być fakt, że w przypadku biblioteki klienckiej
+każdy wiersz jest przechowywany w pamięci dwukrotnie, natomiast przy
+tym sterowniku - tylko raz.
+
 %package oci8
 Summary:       Oracle 8+ database module for PHP
 Summary(pl.UTF-8):     Moduł bazy danych Oracle 8+ dla PHP
@@ -1250,7 +1258,7 @@ Requires: %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      %{name}-pdo = %{epoch}:%{version}-%{release}
 Provides:      php(pdo-pgsql)
 Provides:      php-pecl-PDO_PGSQL
-Obsoletes:     php-pecl-PDO_PGSQL
+Obsoletes:     php-pecl-PDO_PGSQL < 4:5.2.1-2
 
 %description pdo-pgsql
 This is a dynamic shared object (DSO) for PHP that will add PDO
@@ -1381,6 +1389,7 @@ Summary:  session extension module for PHP
 Summary(pl.UTF-8):     Moduł session dla PHP
 Group:         Libraries
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Requires:      %{name}-spl = %{epoch}:%{version}-%{release}
 Suggests:      %{name}-hash = %{epoch}:%{version}-%{release}
 Provides:      php(session)
 
@@ -1470,7 +1479,7 @@ Moduł PHP dodający obsługę gniazdek.
 
 %package spl
 Summary:       Standard PHP Library module for PHP
-Summary(pl.UTF-8):     Moduł SPL dla PHP
+Summary(pl.UTF-8):     Moduł biblioteki standardowej (Standard PHP Library) dla PHP
 Group:         Libraries
 URL:           http://php.net/manual/en/book.spl.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
@@ -1483,7 +1492,7 @@ This is a dynamic shared object (DSO) for PHP that will add Standard
 PHP Library support.
 
 %description spl -l pl.UTF-8
-Moduł PHP dodający obsługę gniazdek.
+Moduł PHP z biblioteką standardową PHP (SPL - Standard PHP Library).
 
 %package sqlite
 Summary:       SQLite extension module for PHP
@@ -1551,7 +1560,6 @@ URL:              http://www.php.net/manual/en/book.sybase.php
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Provides:      php(sybase-ct)
 Obsoletes:     php-sybase
-Conflicts:     php-sybase
 
 %description sybase-ct
 This is a dynamic shared object (DSO) for PHP that will add Sybase and
@@ -1829,7 +1837,6 @@ cp php.ini-production php.ini
 %patch27 -p1
 %patch29 -p1
 %patch31 -p1
-%patch32 -p1
 %if "%{pld_release}" != "ac"
 %patch34 -p1
 %endif
@@ -1857,12 +1864,15 @@ cp php.ini-production php.ini
 %patch54 -p1
 %undos ext/spl/tests/SplFileInfo_getInode_basic.phpt
 %patch55 -p1
-%patch56 -p0
 %patch57 -p1
-%patch58 -p1
 %patch59 -p1
 %patch60 -p1
 %patch61 -p1
+%patch62 -p1
+%patch63 -p1
+%patch64 -p1
+%{__rm} -r sapi/litespeed
+gzip -dc %{SOURCE15} | tar xf - -C sapi/
 
 %if "%{pld_release}" != "ac"
 sed -i -e '/PHP_ADD_LIBRARY_WITH_PATH/s#xmlrpc,#xmlrpc-epi,#' ext/xmlrpc/config.m4
@@ -1872,25 +1882,24 @@ sed -i -e '/PHP_ADD_LIBRARY_WITH_PATH/s#xmlrpc,#xmlrpc-epi,#' ext/xmlrpc/config.
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 
 # conflict seems to be resolved by recode patches
-rm -f ext/recode/config9.m4
+%{__rm} ext/recode/config9.m4
 
 # remove all bundled libraries not to link with them accidentally
-#rm -rf ext/sqlite/libsqlite
-rm -rf ext/sqlite3/libsqlite
-#rm -rf ext/bcmath/libbcmath
-#rm -rf ext/date/lib
-#rm -rf ext/fileinfo/libmagic
-#rm -rf ext/dba/libcdb
-#rm -rf ext/dba/libflatfile
-#rm -rf ext/dba/libinifile
-#rm -rf ext/gd/libgd
-#rm -rf ext/mbstring/libmbfl
-#rm -rf ext/mbstring/oniguruma
-rm -rf ext/pcre/pcrelib
-rm -rf ext/pdo_sqlite/libsqlite
-#rm -rf ext/soap/interop
-rm -r ext/xmlrpc/libxmlrpc
-#rm -rf ext/zip/lib
+#%{__rm} -r ext/sqlite/libsqlite
+%{__rm} -r ext/sqlite3/libsqlite
+#%{__rm} -r ext/bcmath/libbcmath
+#%{__rm} -r ext/date/lib
+#%{__rm} -r ext/fileinfo/libmagic
+#%{__rm} -r ext/dba/libcdb
+#%{__rm} -r ext/dba/libflatfile
+#%{__rm} -r ext/dba/libinifile
+#%{__rm} -r ext/gd/libgd
+#%{__rm} -r ext/mbstring/libmbfl
+#%{__rm} -r ext/mbstring/oniguruma
+%{__rm} -r ext/pcre/pcrelib
+#%{__rm} -r ext/soap/interop
+%{__rm} -r ext/xmlrpc/libxmlrpc
+#%{__rm} -r ext/zip/lib
 
 cp -af Zend/LICENSE{,.Zend}
 install -p %{SOURCE13} dep-tests.sh
@@ -1903,12 +1912,12 @@ sed -i -e 's#-fvisibility=hidden##g' configure*
 mv sapi/cli/tests/022.phpt{,.broken}
 
 # php-5.3.3/ext/standard/tests/file/statpage.phpt
-rm ext/standard/tests/file/statpage.phpt
+%{__rm} ext/standard/tests/file/statpage.phpt
 
 # idiotic test, it will fail if somebody else makes space on disk or if disk
 # space is not yet allocated (xfs). report upstream to advice bogus test is
 # probably pointless.
-rm ext/standard/tests/file/disk_free_space_basic.phpt
+%{__rm} ext/standard/tests/file/disk_free_space_basic.phpt
 
 sh -xe %{_sourcedir}/skip-tests.sh
 
@@ -1951,6 +1960,9 @@ cli
 %if %{with cgi}
 cgi-fcgi
 %endif
+%if %{with litespeed}
+litespeed
+%endif
 %if %{with fpm}
 fpm
 %endif
@@ -1960,9 +1972,6 @@ apxs1
 %if %{with apache2}
 apxs2
 %endif
-%if %{with litespeed}
-litespeed
-%endif
 "
 for sapi in $sapis; do
        : SAPI $sapi
@@ -2035,20 +2044,19 @@ for sapi in $sapis; do
 %if %{with interbase} && %{without interbase_inst}
        --with-pdo-firebird=shared,/usr \
 %endif
+       %{?with_mhash:--with-mhash=yes} \
        --with-mysql-sock=/var/lib/mysql/mysql.sock \
        --with-pdo-mysql=shared%{?with_mysqlnd:,mysqlnd} \
        %{?with_oci8:--with-pdo-oci=shared%{?with_instantclient:,instantclient,%{_libdir}}} \
        %{?with_odbc:--with-pdo-odbc=shared,unixODBC,/usr} \
        %{?with_pgsql:--with-pdo-pgsql=shared} \
-       %{?with_sqlite:--with-pdo-sqlite=shared,/usr} \
+       %{?with_pdo_sqlite:--with-pdo-sqlite=shared,/usr} \
        --without-libexpat-dir \
-       --enable-overload=shared \
        --enable-posix=shared \
        --enable-shared \
        --enable-session=shared \
        --enable-shmop=shared \
        --enable-simplexml=shared \
-       --enable-spl=shared \
        --enable-sysvmsg=shared \
        --enable-sysvsem=shared \
        --enable-sysvshm=shared \
@@ -2081,7 +2089,7 @@ for sapi in $sapis; do
        %{?with_mysqli:--with-mysqli=shared%{?with_mysqlnd:,mysqlnd}} \
        %{?with_oci8:--with-oci8=shared%{?with_instantclient:,instantclient,%{_libdir}}} \
        %{?with_openssl:--with-openssl=shared} \
-       --with-kerberos \
+       %{?with_kerberos5:--with-kerberos} \
        %{__with_without pcre pcre-regex /usr} \
        %{__enable_disable filter filter shared} \
        --with-pear=%{php_pear_dir} \
@@ -2094,7 +2102,8 @@ for sapi in $sapis; do
        --with-regex=system \
        %{?with_snmp:--with-snmp=shared} \
        %{?with_sybase_ct:--with-sybase-ct=shared,/usr} \
-       %{!?with_sqlite:--without-sqlite --without-pdo-sqlite}%{?with_sqlite:--with-sqlite=shared,/usr --enable-sqlite-utf8} \
+       %{!?with_sqlite2:--without-sqlite}%{?with_sqlite2:--with-sqlite=shared,/usr --enable-sqlite-utf8} \
+       %{!?with_pdo_sqlite:--without-pdo-sqlite} \
        %{__with_without sqlite3 sqlite3 shared,/usr} \
        --with-t1lib=shared \
        %{?with_tidy:--with-tidy=shared} \
@@ -2130,7 +2139,6 @@ cp -af Makefile.cli Makefile
 %endif
 
 %if %{with litespeed}
-gzip -dc %{SOURCE15} | tar xf - -C sapi/
 %{__make} -f Makefile.litespeed
 %endif
 
@@ -2169,6 +2177,8 @@ generate_inifiles() {
                [ "$mod" = "pcre" ] && conf="PCRE.ini"
                # spl needs to be loaded before mysqli
                [ "$mod" = "spl" ] && conf="SPL.ini"
+               # session needs to be loaded before php-pecl-http, php-pecl-memcache, php-pecl-session_mysql
+               [ "$mod" = "session" ] && conf="Session.ini"
                # mysqlnd needs to be loaded before mysql,mysqli,pdo_mysqli
                [ "$mod" = "mysqlnd" ] && conf="MySQLND.ini"
                echo "+ $conf"
@@ -2229,7 +2239,7 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_libdir}/{php,apache{,1}},%{_sysconfdir}/{apache,cgi}} \
        $RPM_BUILD_ROOT{%{_sbindir},%{_bindir}} \
        $RPM_BUILD_ROOT/etc/{apache/conf.d,httpd/conf.d} \
-       $RPM_BUILD_ROOT%{_mandir}/man1 \
+       $RPM_BUILD_ROOT%{_mandir}/man{1,8} \
 
 cp -af php_config.h.cli main/php_config.h
 cp -af Makefile.cli Makefile
@@ -2241,20 +2251,20 @@ ln -sfn phar.phar $RPM_BUILD_ROOT%{_bindir}/phar
 
 # install Apache1 DSO module
 %if %{with apache1}
-libtool --silent --mode=install install sapi/apache/libphp5.la $RPM_BUILD_ROOT%{_libdir}/apache1
+libtool --mode=install install sapi/apache/libphp5.la $RPM_BUILD_ROOT%{_libdir}/apache1
 %endif
 
 # install Apache2 DSO module
 %if %{with apache2}
-libtool --silent --mode=install install sapi/apache2handler/libphp5.la $RPM_BUILD_ROOT%{_libdir}/apache
+libtool --mode=install install sapi/apache2handler/libphp5.la $RPM_BUILD_ROOT%{_libdir}/apache
 %endif
 
 # install litespeed sapi
 %if %{with litespeed}
-libtool --silent --mode=install install sapi/litespeed/php $RPM_BUILD_ROOT%{_sbindir}/php.litespeed
+libtool --mode=install install sapi/litespeed/php $RPM_BUILD_ROOT%{_sbindir}/php.litespeed
 %endif
 
-libtool --silent --mode=install install libphp_common.la $RPM_BUILD_ROOT%{_libdir}
+libtool --mode=install install libphp_common.la $RPM_BUILD_ROOT%{_libdir}
 # fix install paths, avoid evil rpaths
 sed -i -e "s|^libdir=.*|libdir='%{_libdir}'|" $RPM_BUILD_ROOT%{_libdir}/libphp_common.la
 # better solution?
@@ -2262,7 +2272,7 @@ sed -i -e 's|libphp_common.la|$(libdir)/libphp_common.la|' $RPM_BUILD_ROOT%{_lib
 
 # install CGI/FCGI
 %if %{with cgi}
-libtool --silent --mode=install install sapi/cgi/php-cgi $RPM_BUILD_ROOT%{_bindir}/php.cgi
+libtool --mode=install install sapi/cgi/php-cgi $RPM_BUILD_ROOT%{_bindir}/php.cgi
 ln -sf php.cgi $RPM_BUILD_ROOT%{_bindir}/php.fcgi
 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/php-cgi-fcgi.ini
 %endif
@@ -2270,8 +2280,8 @@ cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/php-cgi-fcgi.ini
 # install FCGI PM
 %if %{with fpm}
 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/fpm.d,%{_sbindir}}
-libtool --silent --mode=install install sapi/fpm/php-fpm $RPM_BUILD_ROOT%{_sbindir}
-cp -a sapi/fpm/php-fpm.1 $RPM_BUILD_ROOT%{_mandir}/man1
+libtool --mode=install install sapi/fpm/php-fpm $RPM_BUILD_ROOT%{_sbindir}
+cp -a sapi/fpm/php-fpm.8 $RPM_BUILD_ROOT%{_mandir}/man8
 cp -a sapi/fpm/php-fpm.conf $RPM_BUILD_ROOT%{_sysconfdir}
 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/php-fpm
@@ -2280,7 +2290,7 @@ cp -a %{SOURCE11} $RPM_BUILD_ROOT/etc/logrotate.d/php-fpm
 %endif
 
 # install CLI
-libtool --silent --mode=install install sapi/cli/php $RPM_BUILD_ROOT%{_bindir}/php.cli
+libtool --mode=install install sapi/cli/php $RPM_BUILD_ROOT%{_bindir}/php.cli
 install sapi/cli/php.1 $RPM_BUILD_ROOT%{_mandir}/man1/php.1
 echo ".so php.1" >$RPM_BUILD_ROOT%{_mandir}/man1/php.cli.1
 ln -sf php.cli $RPM_BUILD_ROOT%{_bindir}/php
@@ -2454,9 +2464,9 @@ fi
 %extension_scripts mbstring
 %extension_scripts mcrypt
 %extension_scripts mssql
-%extension_scripts mysqlnd
 %extension_scripts mysql
 %extension_scripts mysqli
+%extension_scripts mysqlnd
 %extension_scripts oci8
 %extension_scripts odbc
 %extension_scripts openssl
@@ -2696,7 +2706,7 @@ fi
 %dir %{_sysconfdir}/fpm.d
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php-fpm.conf
 %attr(755,root,root) %{_sbindir}/php-fpm
-%{_mandir}/man1/php-fpm.1*
+%{_mandir}/man8/php-fpm.8*
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/php-fpm
 %attr(754,root,root) /etc/rc.d/init.d/php-fpm
 %endif
@@ -2770,6 +2780,11 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/dom.ini
 %attr(755,root,root) %{php_extensiondir}/dom.so
 
+%files exif
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/exif.ini
+%attr(755,root,root) %{php_extensiondir}/exif.so
+
 %files fileinfo
 %defattr(644,root,root,755)
 %doc README.input_filter
@@ -2784,11 +2799,6 @@ fi
 %attr(755,root,root) %{php_extensiondir}/filter.so
 %endif
 
-%files exif
-%defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/exif.ini
-%attr(755,root,root) %{php_extensiondir}/exif.so
-
 %files ftp
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/ftp.ini
@@ -2867,13 +2877,6 @@ fi
 %attr(755,root,root) %{php_extensiondir}/mssql.so
 %endif
 
-%if %{with mysqlnd}
-%files mysqlnd
-%defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/MySQLND.ini
-%attr(755,root,root) %{php_extensiondir}/mysqlnd.so
-%endif
-
 %files mysql
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/mysql.ini
@@ -2886,6 +2889,13 @@ fi
 %attr(755,root,root) %{php_extensiondir}/mysqli.so
 %endif
 
+%if %{with mysqlnd}
+%files mysqlnd
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/MySQLND.ini
+%attr(755,root,root) %{php_extensiondir}/mysqlnd.so
+%endif
+
 %if %{with oci8}
 %files oci8
 %defattr(644,root,root,755)
@@ -2964,7 +2974,7 @@ fi
 %attr(755,root,root) %{php_extensiondir}/pdo_pgsql.so
 %endif
 
-%if %{with sqlite}
+%if %{with pdo_sqlite}
 %files pdo-sqlite
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/pdo_sqlite.ini
@@ -3011,15 +3021,10 @@ fi
 %attr(755,root,root) %{php_extensiondir}/recode.so
 %endif
 
-%files simplexml
-%defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/simplexml.ini
-%attr(755,root,root) %{php_extensiondir}/simplexml.so
-
 %files session
 %defattr(644,root,root,755)
 %doc ext/session/mod_files.sh
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/session.ini
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/Session.ini
 %attr(755,root,root) %{php_extensiondir}/session.so
 
 %files shmop
@@ -3027,6 +3032,11 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/shmop.ini
 %attr(755,root,root) %{php_extensiondir}/shmop.so
 
+%files simplexml
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/simplexml.ini
+%attr(755,root,root) %{php_extensiondir}/simplexml.so
+
 %if %{with snmp}
 %files snmp
 %defattr(644,root,root,755)
@@ -3051,7 +3061,7 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/SPL.ini
 %attr(755,root,root) %{php_extensiondir}/spl.so
 
-%if %{with sqlite}
+%if %{with sqlite2}
 %files sqlite
 %defattr(644,root,root,755)
 %doc ext/sqlite/{README,TODO,CREDITS}
This page took 0.068344 seconds and 4 git commands to generate.