]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
add debug bcond to enable zend debug build, do not enable with rpm debug builds
[packages/php.git] / php.spec
index ece6480afe077cd13d7bbffbdc5cb88d5a5ddb90..1f0294817c2c0bf52cfc23c36a9763dd5a7ea480 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -37,6 +37,7 @@
 %bcond_with    systemtap       # systemtap/DTrace support
 %bcond_with    tests           # default off; test process very often hangs on builders, approx run time 45m; perform "make test"
 %bcond_with    zts             # Zend Thread Safety
+%bcond_with    debug           # Zend Debug Build
 # - SAPI
 %bcond_without apache1         # disable building Apache 1.3.x SAPI
 %bcond_without apache2         # disable building Apache 2.x SAPI
@@ -165,7 +166,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP Версии 5 - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP Версії 5 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       5.6.29
+Version:       5.6.34
 Release:       %{rel}
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -174,7 +175,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: 190bf5b52d1fc68d5500a8cdc7e33164
+# Source0-md5: dd28a659b88ad60797a7c102307f2edb
 Source2:       %{orgname}-mod_%{orgname}.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
@@ -236,6 +237,7 @@ Patch67:    mysql-lib-ver-mismatch.patch
 Patch69:       fpm-conf-split.patch
 Patch70:       mysqlnd-ssl.patch
 Patch72:       phar-hash-shared.patch
+Patch73:       php-pdo-ssl.patch
 URL:           http://php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -342,7 +344,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                phpdbgver       0.4.0
 
 %define                _zend_zts               %{!?with_zts:0}%{?with_zts:1}
-%define                php_debug               %{!?debug:0}%{?debug:1}
+%define                php_debug               %{!?with_debug:0}%{?with_debug:1}
 
 %if %{with gcov}
 %undefine      with_ccache
@@ -425,20 +427,33 @@ PHP as DSO module for Apache 1.3.x.
 PHP jako moduł DSO (Dynamic Shared Object) dla Apache 1.3.x.
 
 %package -n apache-mod_%{name}
-Summary:       PHP DSO module for Apache 2.x
-Summary(pl.UTF-8):     Moduł DSO (Dynamic Shared Object) PHP dla Apache 2.x
+Summary:       PHP support for Apache 2.x
+Summary(pl.UTF-8):     Wsparcie PHP dla Apache 2.x
 Group:         Development/Languages/PHP
+Requires:      apache-mod_%{name}-core = %{epoch}:%{version}-%{release}
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-Requires:      apache(modules-api) = %{apache_modules_api}
-Requires:      apache-mod_mime
 Provides:      webserver(php) = %{version}
 Obsoletes:     apache-mod_php < 4:5.3.28-7
 Obsoletes:     phpfi
 
 %description -n apache-mod_%{name}
-PHP as DSO module for Apache 2.x.
+PHP support for Apache 2.x.
 
 %description -n apache-mod_%{name} -l pl.UTF-8
+Wsparcie PHP dla Apache 2.x.
+
+%package -n apache-mod_%{name}-core
+Summary:       PHP DSO module for Apache 2.x
+Summary(pl.UTF-8):     Moduł DSO (Dynamic Shared Object) PHP dla Apache 2.x
+Group:         Development/Languages/PHP
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Requires:      apache(modules-api) = %{apache_modules_api}
+Requires:      apache-mod_mime
+
+%description -n apache-mod_%{name}-core
+PHP as DSO module for Apache 2.x.
+
+%description -n apache-mod_%{name}-core -l pl.UTF-8
 PHP jako moduł DSO (Dynamic Shared Object) dla Apache 2.x.
 
 %package litespeed
@@ -655,6 +670,7 @@ Obsoletes:  php54-devel
 Obsoletes:     php55-devel
 Obsoletes:     php70-devel
 Obsoletes:     php71-devel
+Obsoletes:     php72-devel
 
 %description devel
 The php-devel package lets you compile dynamic extensions to PHP.
@@ -1498,7 +1514,6 @@ Requires: %{name}-common = %{epoch}:%{version}-%{release}
 Requires:      %{name}-pdo = %{epoch}:%{version}-%{release}
 Provides:      php(pdo-pgsql)
 Provides:      php(pdo_pgsql)
-Provides:      php-pecl-PDO_PGSQL = 4:5.3.28-7
 Obsoletes:     php-pdo-pgsql < 4:5.3.28-7
 Obsoletes:     php-pecl-PDO_PGSQL < 4:5.2.1-2
 
@@ -2130,6 +2145,7 @@ exit 1
 
 %patch70 -p1
 %patch72 -p1
+%patch73 -p1
 
 %{__sed} -i -e '/PHP_ADD_LIBRARY_WITH_PATH/s#xmlrpc,#xmlrpc-epi,#' ext/xmlrpc/config.m4
 
@@ -2414,7 +2430,7 @@ for sapi in $sapis; do
        --with-config-file-path=%{_sysconfdir} \
        --with-config-file-scan-dir=%{_sysconfdir}/conf.d \
        --with-system-tzdata \
-       --%{!?debug:dis}%{?debug:en}able-debug \
+       --%{!?with_debug:dis}%{?with_debug:en}able-debug \
        %{?with_zts:--enable-maintainer-zts} \
        --enable-inline-optimization \
        %{__enable_disable bcmath bcmath shared} \
@@ -2757,8 +2773,8 @@ touch $RPM_BUILD_ROOT%{_sbindir}/php-fpm
 %endif
 
 %{__sed} -i -e '
-       s#/usr/lib/php#%{php_extensiondir}#
-       s#/etc/php/#%{_sysconfdir}/#
+       s#/usr/lib/php#%{php_extensiondir}#g
+       s#/etc/php/#%{_sysconfdir}/#g
        s#@processname@#%{name}-fpm#g
 ' $RPM_BUILD_ROOT{/etc/{rc.d/init.d/%{name}-fpm,logrotate.d/%{name}-fpm},%{_sysconfdir}/php-fpm.conf,%{_sysconfdir}/fpm.d/www.conf}
 %endif
@@ -2797,8 +2813,8 @@ cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/php-apache2handler.ini
 # ensure that paths are correct for current php version and arch
 grep -El '/etc/php/|/usr/lib/php/' $RPM_BUILD_ROOT%{_sysconfdir}/*.ini | xargs -r \
 %{__sed} -i -e '
-       s#/usr/lib/php#%{php_extensiondir}#
-       s#/etc/php#%{_sysconfdir}#
+       s#/usr/lib/php#%{php_extensiondir}#g
+       s#/etc/php/#%{_sysconfdir}/#g
 '
 
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/conf.d
@@ -3076,9 +3092,12 @@ fi
 %files -n apache-mod_%{name}
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/httpd/conf.d/*_mod_php.conf
+%attr(755,root,root) %{_libdir}/apache/mod_php.so
+
+%files -n apache-mod_%{name}-core
+%defattr(644,root,root,755)
 %dir %{_sysconfdir}/apache2handler.d
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php-apache2handler.ini
-%attr(755,root,root) %{_libdir}/apache/mod_php.so
 %attr(755,root,root) %{_libdir}/apache/libphp5-*.*.so
 %endif
 
This page took 0.04147 seconds and 4 git commands to generate.