]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
apxs1 cleanup from apache 1.3
[packages/php.git] / php.spec
index bbbde1108702b4b8cee28bf3f8305c120f16fcba..1b870a60e0394c96b0fc22b0e89d4c996c757f82 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -90,7 +90,6 @@
 %bcond_without system_gd       # system gd
 %bcond_without webp            # Without WebP support in GD extension (imagecreatefromwebp)
 
-%define apxs1          /usr/sbin/apxs1
 %define        apxs2           /usr/sbin/apxs
 
 # segfaults on x32
@@ -174,6 +173,7 @@ Source2:    %{orgname}-mod_php.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
 Source5:       %{orgname}-cli.ini
+Source6:       timezone.ini
 Source10:      %{orgname}-fpm.init
 Source11:      %{orgname}-fpm.logrotate
 Source12:      %{orgname}-branch.sh
@@ -2110,7 +2110,7 @@ export PEAR_INSTALLDIR=%{php_pear_dir}
 # configure once (for faster debugging purposes)
 if [ ! -f _built-conf ]; then
        # now remove Makefile copies
-       rm -f Makefile.{cgi-fcgi,fpm,cli,apxs1,apxs2,litespeed,phpdbg,milter}
+       rm -f Makefile.{cgi-fcgi,fpm,cli,apxs2,litespeed,phpdbg,milter}
 
        # Force use of system libtool:
        mv build/libtool.m4 build/libtool.m4.saved
@@ -2416,8 +2416,9 @@ exit $rc
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_libdir}/{php,apache},%{_sysconfdir}/cgi} \
-       $RPM_BUILD_ROOT%{_sysconfdir}/{cgi-fcgi,cli,apache2handler}.d \
+install -d \
+       $RPM_BUILD_ROOT%{_libdir}/{php,apache} \
+       $RPM_BUILD_ROOT%{_sysconfdir}/{conf,cgi-fcgi,cli,apache2handler}.d \
        $RPM_BUILD_ROOT{%{_sbindir},%{_bindir}} \
        $RPM_BUILD_ROOT/etc/httpd/conf.d \
        $RPM_BUILD_ROOT%{_mandir}/man{1,8} \
@@ -2526,6 +2527,7 @@ echo ".so php%{ver_suffix}.1" >$RPM_BUILD_ROOT%{_mandir}/man1/php.1
 ln -sf php%{ver_suffix} $RPM_BUILD_ROOT%{_bindir}/php
 
 cp -p php.ini $RPM_BUILD_ROOT%{_sysconfdir}/php.ini
+cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/timezone.ini
 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/php-cli.ini
 
 %if %{with apache2}
@@ -2610,7 +2612,7 @@ if ! grep -q '^date.timezone[[:space:]]*=' %{_sysconfdir}/php.ini && [ -f /etc/s
        TIMEZONE=
        . /etc/sysconfig/timezone
        if [ "$TIMEZONE" ]; then
-               %{__sed} -i -e "s,^;date.timezone[[:space:]]*=.*,date.timezone = $TIMEZONE," %{_sysconfdir}/php.ini
+               %{__sed} -i -e "s,^;date.timezone[[:space:]]*=.*,date.timezone = $TIMEZONE," %{_sysconfdir}/conf.d/timezone.ini
        fi
 fi
 
@@ -2838,6 +2840,7 @@ fi
 %dir %{_sysconfdir}
 %dir %{_sysconfdir}/conf.d
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/php.ini
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/timezone.ini
 %attr(755,root,root) %{_libdir}/libphp_common-*.so
 %dir %{php_extensiondir}
 
This page took 0.03138 seconds and 4 git commands to generate.