]> git.pld-linux.org Git - packages/php.git/blobdiff - php.spec
- removed dropped files, cleanups
[packages/php.git] / php.spec
index cdc8ce4b542e7d64db5eff2ee319bd542765dd74..1107a5fa6a88b5511cd7ca411fcbc13b63b9e530 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -9,6 +9,8 @@
 #   db, hyperwave, java, mcal, overload, qtdom
 #   and removed from php 5.1:
 #   cpdf, fam, yp, oracle
+#   and removed from php 5.2:
+#   filepro, hw
 # - mime_magic can't handle new "string/*" entries in magic.mime
 # - make additional headers added by mail patch configurable
 # - apply -hardened patch by default ?
@@ -18,7 +20,6 @@
 %bcond_with    db3             # use db3 packages instead of db (4.x) for Berkeley DB support
 %bcond_with    fdf             # with FDF (PDF forms) module           (BR: proprietary lib)
 %bcond_with    hardening       # build with hardening patch applied (http://www.hardened-php.net/)
-%bcond_with    hwapi           # with Hw API support                   (BR: proprietary libs)
 %bcond_with    interbase_inst  # use InterBase install., not Firebird  (BR: proprietary libs)
 %bcond_with    oci8            # with Oracle oci8 extension module     (BR: proprietary libs)
 %bcond_without curl            # without CURL extension module
@@ -66,7 +67,7 @@
 ERROR: You need to select at least one Apache SAPI to build shared modules.
 %endif
 
-%define        _rel 1
+%define        _rel 0.2
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr):   Le langage de script embarque-HTML PHP
 Summary(pl):   Jêzyk skryptowy PHP
@@ -74,14 +75,14 @@ Summary(pt_BR):     A linguagem de script PHP
 Summary(ru):   PHP ÷ÅÒÓÉÉ 5 - ÑÚÙË ÐÒÅÐÒÏÃÅÓÓÉÒÏ×ÁÎÉÑ HTML-ÆÁÊÌÏ×, ×ÙÐÏÌÎÑÅÍÙÊ ÎÁ ÓÅÒ×ÅÒÅ
 Summary(uk):   PHP ÷ÅÒÓ¦§ 5 - ÍÏ×Á ÐÒÅÐÒÏÃÅÓÕ×ÁÎÎÑ HTML-ÆÁÊ̦×, ×ÉËÏÎÕ×ÁÎÁ ÎÁ ÓÅÒ×ÅÒ¦
 Name:          php
-Version:       5.1.5
+Version:       5.2.0
 Release:       %{_rel}%{?with_hardening:hardened}
 Epoch:         4
 License:       PHP
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{name}-%{version}.tar.bz2
-# Source0-md5: b55e633bdc80ab30da7c92f760fc4b58
-Source1:       FAQ.%{name}
+# Source0-md5: e6029fafcee029edcfa2ceed7a005333
+
 Source2:       zend.gif
 Source3:       %{name}-mod_%{name}.conf
 Source4:       %{name}-cgi-fcgi.ini
@@ -111,18 +112,15 @@ Patch20:  %{name}-readline.patch
 Patch21:       %{name}-nohttpd.patch
 Patch23:       %{name}-gd_imagerotate_enable.patch
 Patch24:       %{name}-uint32_t.patch
-Patch25:       %{name}-hwapi-link.patch
 Patch26:       %{name}-dba-link.patch
 Patch30:       %{name}-hardening-fix.patch
 Patch31:       %{name}-both-apxs.patch
 Patch32:       %{name}-builddir.patch
 Patch33:       %{name}-zlib-for-getimagesize.patch
-Patch34:       %{name}-ini-search-path.patch
 Patch35:       %{name}-versioning.patch
 Patch36:       %{name}-linkflags-clean.patch
-Patch37:       %{name}-cli-segv-fixes.patch
 Patch38:       %{name}-amd64.patch
-Patch39:       %{name}-soap.patch
+Patch39:       %{name}-pear.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -157,7 +155,7 @@ BuildRequires:      libtiff-devel
 BuildRequires: libtool >= 1.4.3
 BuildRequires: libwrap-devel
 BuildRequires: libxml2-devel >= 2.5.10
-BuildRequires: libxslt-devel >= 1.0.18
+BuildRequires: libxslt-devel >= 1.1.0
 %{?with_mhash:BuildRequires:   mhash-devel}
 %{?with_ming:BuildRequires:    ming-devel >= 0.2a-11}
 %{?with_mm:BuildRequires:      mm-devel >= 1.3.0}
@@ -170,7 +168,7 @@ BuildRequires:      openssl-devel >= 0.9.7d
 %endif
 %{?with_snmp:BuildRequires:    net-snmp-devel >= 5.0.7}
 BuildRequires: pam-devel
-%{?with_pcre:BuildRequires:    pcre-devel}
+%{?with_pcre:BuildRequires:    pcre-devel >= 6.6}
 %{?with_pgsql:BuildRequires:   postgresql-backend-devel >= 7.2}
 %{?with_pgsql:BuildRequires:   postgresql-devel}
 BuildRequires: readline-devel
@@ -199,8 +197,8 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # must be in sync with source. extra check ensuring that it is so is done in %%build
 %define                php_api_version         20041225
-%define                zend_module_api         20050922
-%define                zend_extension_api      220051025
+%define                zend_module_api         20060613
+%define                zend_extension_api      220060519
 %define                zend_zts                        %{!?with_zts:0}%{?with_zts:1}
 %define                php_debug                       %{!?debug:0}%{?debug:1}
 
@@ -364,10 +362,12 @@ Group:            Libraries
 Requires:      glibc >= 6:2.3.5
 Requires:      php-dirs
 Provides:      %{name}-libxml = %{epoch}:%{version}-%{release}
+Provides:      %{name}-overload = %{epoch}:%{version}-%{release}
 Provides:      %{name}-session = %{epoch}:%{version}-%{release}
 Provides:      %{name}-simplexml = %{epoch}:%{version}-%{release}
 Provides:      %{name}-spl = %{epoch}:%{version}-%{release}
 Provides:      %{name}-standard = %{epoch}:%{version}-%{release}
+%{?with_pcre:Provides: %{name}-pcre = %{epoch}:%{version}-%{release}}
 Provides:      php(modules_api) = %{php_api_version}
 Provides:      php(zend_extension_api) = %{zend_extension_api}
 Provides:      php(zend_module_api) = %{zend_module_api}
@@ -375,6 +375,7 @@ Provides:   php5(debug) = %{php_debug}
 Provides:      php5(thread-safety) = %{zend_zts}
 Obsoletes:     php-pecl-domxml
 Obsoletes:     php-session < 3:4.2.1-2
+Obsoletes:     php-pcre < 4:5.2.0
 # for the posttrans scriptlet, conflicts because in vserver enviroinment rpm package is not installed.
 Conflicts:     rpm < 4.4.2-0.2
 
@@ -586,21 +587,6 @@ library.
 Modu³ PHP dodaj±cy obs³ugê formularzy PDF poprzez bibliotekê Adobe
 FDFTK.
 
-%package filepro
-Summary:       filePro extension module for PHP
-Summary(pl):   Modu³ filePro dla PHP
-Group:         Libraries
-Requires(post,preun):  %{name}-common = %{epoch}:%{version}-%{release}
-Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-
-%description filepro
-This is a dynamic shared object (DSO) for PHP that will add support
-for read-only access to filePro databases.
-
-%description filepro -l pl
-Modu³ PHP dodaj±cy mo¿liwo¶æ dostêpu (tylko do odczytu) do baz danych
-filePro.
-
 %package ftp
 Summary:       FTP extension module for PHP
 Summary(pl):   Modu³ FTP dla PHP
@@ -661,20 +647,6 @@ length number support with GNU MP library.
 Modu³ PHP umo¿liwiaj±cy korzystanie z biblioteki gmp do obliczeñ na
 liczbach o dowolnej d³ugo¶ci.
 
-%package hwapi
-Summary:       Hyperwave API extension module for PHP
-Summary(pl):   Modu³ API Hyperwave dla PHP
-Group:         Libraries
-Requires(post,preun):  %{name}-common = %{epoch}:%{version}-%{release}
-Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-
-%description hwapi
-This is a dynamic shared object (DSO) for PHP that will add official
-Hyperwave API support.
-
-%description hwapi -l pl
-Modu³ PHP dodaj±cy obs³ugê Hyperwave.
-
 %package iconv
 Summary:       iconv extension module for PHP
 Summary(pl):   Modu³ iconv dla PHP
@@ -953,21 +925,6 @@ Obs
 Uwaga: to jest modu³ eksperymentalny. Ponadto nie jest przeznaczony do
 u¿ywania z serwerem WWW - nie próbuj tego!
 
-%package pcre
-Summary:       PCRE extension module for PHP
-Summary(pl):   Modu³ PCRE dla PHP
-Group:         Libraries
-Requires(post,preun):  %{name}-common = %{epoch}:%{version}-%{release}
-Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-
-%description pcre
-This is a dynamic shared object (DSO) for PHP that will add Perl
-Compatible Regular Expression support.
-
-%description pcre -l pl
-Modu³ PHP umo¿liwiaj±cy korzystanie z perlowych wyra¿eñ regularnych
-(Perl Compatible Regular Expressions)
-
 %package pdo
 Summary:       PHP Data Objects (PDO)
 Summary(pl):   Obs³uga PHP Data Objects (PDO)
@@ -1518,7 +1475,7 @@ Modu
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
-%patch9 -p1
+#%patch9 -p1 # TEST OR UPGRADE
 cp php.ini-dist php.ini
 %patch10 -p1
 # for ac2.53b/am1.6b - AC_LANG_CXX has AM_CONDITIONAL, so cannot be invoked
@@ -1532,9 +1489,8 @@ cp php.ini-dist php.ini
 %patch19 -p1
 %patch20 -p1
 %patch21 -p1
-%patch23 -p1
+#%patch23 -p1 # UPDATE?
 %patch24 -p1
-%patch25 -p1
 %patch26 -p1
 
 %if %{with hardening}
@@ -1544,9 +1500,7 @@ patch -p1 < %{PATCH30} || exit 1
 %patch31 -p1
 %patch32 -p1
 %patch33 -p1
-%patch34 -p1
 %{?with_versioning:%patch35 -p1}
-%patch37 -p1
 %if "%{_lib}" == "lib64"
 %patch38 -p1
 %endif
@@ -1652,7 +1606,6 @@ for sapi in $sapis; do
        --with-flatfile \
        --enable-dom=shared \
        --enable-exif=shared \
-       --enable-filepro=shared \
        --enable-ftp=shared \
        --enable-gd-native-ttf \
        --enable-gd-jus-conf \
@@ -1703,13 +1656,11 @@ for sapi in $sapis; do
 %endif
        %{?with_fdf:--with-fdftk=shared} \
        --with-iconv=shared \
-       --with-filepro=shared \
        --with-freetype-dir=shared \
        --with-gettext=shared \
        --with-gd=shared,/usr \
        --with-gdbm \
        --with-gmp=shared \
-       %{?with_hwapi:--with-hwapi=shared} \
        %{?with_imap:--with-imap=shared --with-imap-ssl} \
        %{?with_interbase:--with-interbase=shared%{!?with_interbase_inst:,/usr}} \
        --with-jpeg-dir=/usr \
@@ -1727,7 +1678,7 @@ for sapi in $sapis; do
        %{?with_oci8:--with-oci8=shared} \
        %{?with_openssl:--with-openssl=shared} \
        --with-kerberos \
-       %{!?with_pcre:--without-pcre-regex}%{?with_pcre:--with-pcre-regex=shared,/usr} \
+       %{!?with_pcre:--without-pcre-regex --disable-filter}%{?with_pcre:--with-pcre-regex=/usr} \
        --with-pear=%{php_pear_dir} \
        %{!?with_pgsql:--without-pgsql}%{?with_pgsql:--with-pgsql=shared,/usr} \
        --with-png-dir=/usr \
@@ -1747,7 +1698,8 @@ for sapi in $sapis; do
        %{!?with_xmlrpc:--without-xmlrpc}%{?with_xmlrpc:--with-xmlrpc=shared,/usr} \
        --with-xsl=shared \
        --with-zlib=shared \
-       --with-zlib-dir=shared,/usr
+       --with-zlib-dir=shared,/usr \
+       --enable-zip=shared,/usr \
 
        cp -f Makefile Makefile.$sapi
        cp -f main/php_config.h php_config.h.$sapi
@@ -1755,12 +1707,8 @@ done
 
 # must make this first, so modules can link against it.
 %{__make} libphp_common.la
-
 %{__make} build-modules
 
-# fix install paths, avoid evil rpaths
-#sed -i -e "s|^libdir=.*|libdir='%{_libdir}'|" libphp_common.la
-
 %if %{with apache1}
 %{__make} libtool-sapi LIBTOOL_SAPI=sapi/apache/libphp5.la -f Makefile.apxs1
 %endif
@@ -1826,9 +1774,6 @@ libtool --silent --mode=install install sapi/cli/php $RPM_BUILD_ROOT%{_bindir}/p
 install sapi/cli/php.1 $RPM_BUILD_ROOT%{_mandir}/man1/php.1
 echo ".so php.1" >$RPM_BUILD_ROOT%{_mandir}/man1/php.cli.1
 
-# as of 5.0.5, phpextdist isn't installed by default
-install scripts/dev/phpextdist $RPM_BUILD_ROOT%{_bindir}
-
 ln -sf php.cli $RPM_BUILD_ROOT%{_bindir}/php
 
 sed -e 's#%{_prefix}/lib/php#%{_libdir}/php#g' php.ini > $RPM_BUILD_ROOT%{_sysconfdir}/php.ini
@@ -1837,7 +1782,6 @@ install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/php-cgi-fcgi.ini
 %endif
 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/php-cgi.ini
 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/php-cli.ini
-install %{SOURCE1} .
 
 %if %{with apache1}
 install %{SOURCE2} php.gif $RPM_BUILD_ROOT/home/services/apache/icons
@@ -1880,6 +1824,11 @@ ln -snf %{_aclocaldir}/libtool.m4 $RPM_BUILD_ROOT%{_libdir}/php/build
 ln -snf %{_datadir}/libtool/ltmain.sh $RPM_BUILD_ROOT%{_libdir}/php/build
 ln -snf %{_bindir}/shtool $RPM_BUILD_ROOT%{_libdir}/php/build
 
+# as a result of ext/pcre/pcrelib removal in %%prep, ext/pcre/php_pcre.h
+# isn't installed by install-headers make target, we do it manually here.
+# this header file is required by e.g. filter PECL extension
+install -D ext/pcre/php_pcre.h $RPM_BUILD_ROOT%{_includedir}/php/ext/pcre/php_pcre.h
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -2033,12 +1982,6 @@ fi
 %postun fdf
 %extension_postun
 
-%post filepro
-%extension_post
-
-%postun filepro
-%extension_postun
-
 %post ftp
 %extension_post
 
@@ -2063,12 +2006,6 @@ fi
 %postun gmp
 %extension_postun
 
-%post hwapi
-%extension_post
-
-%postun hwapi
-%extension_postun
-
 %post iconv
 %extension_post
 
@@ -2159,12 +2096,6 @@ fi
 %postun openssl
 %extension_postun
 
-%post pcre
-%extension_post
-
-%postun pcre
-%extension_postun
-
 %post pdo-dblib
 %extension_post
 
@@ -2369,9 +2300,6 @@ fi
 %triggerun fdf -- %{name}-fdf < 4:5.0.4-9.1
 %{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*fdf\.so/d' %{_sysconfdir}/php.ini
 
-%triggerun filepro -- %{name}-filepro < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*filepro\.so/d' %{_sysconfdir}/php.ini
-
 %triggerun ftp -- %{name}-ftp < 4:5.0.4-9.1
 %{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*ftp\.so/d' %{_sysconfdir}/php.ini
 
@@ -2384,9 +2312,6 @@ fi
 %triggerun gmp -- %{name}-gmp < 4:5.0.4-9.1
 %{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*gmp\.so/d' %{_sysconfdir}/php.ini
 
-%triggerun hwapi -- %{name}-hwapi < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*hwapi\.so/d' %{_sysconfdir}/php.ini
-
 %triggerun iconv -- %{name}-iconv < 4:5.0.4-9.1
 %{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*iconv\.so/d' %{_sysconfdir}/php.ini
 
@@ -2448,9 +2373,6 @@ if [ -f %{_sysconfdir}/php-cli.ini ]; then
        %{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*pcntl\.so/d' %{_sysconfdir}/php-cli.ini
 fi
 
-%triggerun pcre -- %{name}-pcre < 4:5.0.4-9.1
-%{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*pcre\.so/d' %{_sysconfdir}/php.ini
-
 %triggerun pgsql -- %{name}-pgsql < 4:5.0.4-9.1
 %{__sed} -i -e '/^extension[[:space:]]*=[[:space:]]*pgsql\.so/d' %{_sysconfdir}/php.ini
 
@@ -2581,10 +2503,6 @@ fi
 %attr(755,root,root) %{_libdir}/libphp_common-*.so
 %dir %{extensionsdir}
 
-# session_mm doesn't work with shared session
-#%files session
-#%defattr(644,root,root,755)
-#%attr(755,root,root) %{extensionsdir}/session.so
 %doc ext/session/mod_files.sh
 
 %files devel
@@ -2592,7 +2510,6 @@ fi
 %doc README.UNIX-BUILD-SYSTEM
 %doc README.EXT_SKEL README.SELF-CONTAINED-EXTENSIONS
 %doc CODING_STANDARDS
-%attr(755,root,root) %{_bindir}/phpextdist
 %attr(755,root,root) %{_bindir}/phpize
 %attr(755,root,root) %{_bindir}/php-config
 %attr(755,root,root) %{_libdir}/libphp_common.so
@@ -2655,11 +2572,6 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/exif.ini
 %attr(755,root,root) %{extensionsdir}/exif.so
 
-%files filepro
-%defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/filepro.ini
-%attr(755,root,root) %{extensionsdir}/filepro.so
-
 %files ftp
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/ftp.ini
@@ -2680,13 +2592,6 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/gmp.ini
 %attr(755,root,root) %{extensionsdir}/gmp.so
 
-%if %{with hwapi}
-%files hwapi
-%defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/hwapi.ini
-%attr(755,root,root) %{extensionsdir}/hwapi.so
-%endif
-
 %files iconv
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/iconv.ini
@@ -2794,13 +2699,6 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cli.d/pcntl.ini
 %attr(755,root,root) %{extensionsdir}/pcntl.so
 
-%if %{with pcre}
-%files pcre
-%defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/pcre.ini
-%attr(755,root,root) %{extensionsdir}/pcre.so
-%endif
-
 %files pdo
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/pdo.ini
This page took 0.048811 seconds and 4 git commands to generate.