]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - php-pecl.spec
lib: fortify source example
[projects/template-specs.git] / php-pecl.spec
index d4f68d22f914483a21191a6618b2137392abd85a..9cc894ebf273446da239ec56f0796aa70c060c37 100644 (file)
@@ -3,7 +3,7 @@
 %bcond_without tests           # build without tests
 
 %define                php_name        php%{?php_suffix}
-%define                modname -
+%define                modname MODULE_NAME
 Summary:       %{modname} -
 Summary(pl.UTF-8):     %{modname} -
 Name:          %{php_name}-pecl-%{modname}
@@ -13,10 +13,16 @@ License:    PHP 3.01
 Group:         Development/Languages/PHP
 Source0:       http://pecl.php.net/get/%{modname}-%{version}.tgz
 # Source0-md5: -
-URL:           http://pecl.php.net/package/modname/
+URL:           http://pecl.php.net/package/MODULE_NAME/
+%{?with_tests:BuildRequires:    %{php_name}-cli}
 BuildRequires: %{php_name}-devel
 BuildRequires: rpmbuild(macros) >= 1.666
+%if %{with tests}
+BuildRequires: %{php_name}-cli
+BuildRequires: %{php_name}-pcre
+%endif
 %{?requires_php_extension}
+Provides:      php(%{modname}) = %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -32,6 +38,35 @@ phpize
 %configure
 %{__make}
 
+%if %{with tests}
+# simple module load test
+%{__php} -n -q \
+       -d extension_dir=modules \
+       -d extension=%{php_extensiondir}/spl.so \
+       -d extension=%{modname}.so \
+       -m > modules.log
+grep %{modname} modules.log
+
+export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
+%{__make} test \
+       PHP_EXECUTABLE=%{__php} \
+       PHP_TEST_SHARED_SYSTEM_EXTENSIONS="spl" \
+
+# or:
+cat <<'EOF' > run-tests.sh
+#!/bin/sh
+export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
+%{__make} test \
+       PHP_EXECUTABLE=%{__php} \
+       PHP_TEST_SHARED_SYSTEM_EXTENSIONS="spl pdo session" \
+       RUN_TESTS_SETTINGS="-q $*"
+EOF
+
+chmod +x run-tests.sh
+./run-tests.sh -w failed.log
+test -f failed.log -a ! -s failed.log
+%endif
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
This page took 0.056535 seconds and 4 git commands to generate.