]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - php-pecl.spec
lib: fortify source example
[projects/template-specs.git] / php-pecl.spec
index b20bba4f47676922dec9283e1f94b7bb4bc2ead8..9cc894ebf273446da239ec56f0796aa70c060c37 100644 (file)
@@ -17,8 +17,12 @@ URL:         http://pecl.php.net/package/MODULE_NAME/
 %{?with_tests:BuildRequires:    %{php_name}-cli}
 BuildRequires: %{php_name}-devel
 BuildRequires: rpmbuild(macros) >= 1.666
+%if %{with tests}
+BuildRequires: %{php_name}-cli
+BuildRequires: %{php_name}-pcre
+%endif
 %{?requires_php_extension}
-Provides:      php(MODULE_NAME) = %{version}
+Provides:      php(%{modname}) = %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -38,13 +42,29 @@ phpize
 # simple module load test
 %{__php} -n -q \
        -d extension_dir=modules \
+       -d extension=%{php_extensiondir}/spl.so \
        -d extension=%{modname}.so \
        -m > modules.log
 grep %{modname} modules.log
 
 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
 %{__make} test \
-       PHP_EXECUTABLE=%{__php}
+       PHP_EXECUTABLE=%{__php} \
+       PHP_TEST_SHARED_SYSTEM_EXTENSIONS="spl" \
+
+# or:
+cat <<'EOF' > run-tests.sh
+#!/bin/sh
+export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
+%{__make} test \
+       PHP_EXECUTABLE=%{__php} \
+       PHP_TEST_SHARED_SYSTEM_EXTENSIONS="spl pdo session" \
+       RUN_TESTS_SETTINGS="-q $*"
+EOF
+
+chmod +x run-tests.sh
+./run-tests.sh -w failed.log
+test -f failed.log -a ! -s failed.log
 %endif
 
 %install
This page took 0.086694 seconds and 4 git commands to generate.