]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - php-package.spec
Python template cleanup and update
[projects/template-specs.git] / php-package.spec
index 6b4becfd893103b4e8649aa438c42a0fcb7f4c98..886464a35c9abc74509ea499fe60b9ad2a3d0bb0 100644 (file)
@@ -1,10 +1,10 @@
+%define                pkgname PACKAGE_NAME
+%define                php_min_version 5.0.0
 %if %{with phpdeps}
-%include       /usr/lib/rpm/macros.php
-%endif
 # new php based depsolver will look into this macro, however it works in static
 # manner too.
-%define                php_min_version 5.0.0
-%define                pkgname PACKAGE_NAME
+%include       /usr/lib/rpm/macros.php
+%endif
 Summary:       -
 Name:          php-%{pkgname}
 Version:       _
@@ -19,7 +19,9 @@ BuildRequires:        /usr/bin/php
 BuildRequires: rpm-php-pearprov >= 4.4.2-11
 %endif
 BuildRequires: rpmbuild(macros) >= 1.461
-Requires:      php-common >= 4:%{php_min_version}
+# for %%undos macro
+BuildRequires: rpmbuild(macros) >= 1.553
+Requires:      php(core) >= %{php_min_version}
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -29,10 +31,10 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _phpdocdir              %{_docdir}/phpdoc
 
 # bad depsolver
-%define                _noautopear     pear(class.template.php) pear(/etc/webapps/template/config.php)
+%define                _noautopear     pear
 
 # exclude optional php dependencies
-%define                _noautophp      php-bzip2 php-bcmath php-zip php-date php-ftp php-hash php-ldap php-mbstring php-mysql php-pgsql php-tokenizer
+%define                _noautophp      php-curl
 
 # put it together for rpmbuild
 %define                _noautoreq      %{?_noautophp} %{?_noautopear}
@@ -40,20 +42,6 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %description
 ...
 
-%package tests
-Summary:       Tests for ...
-Summary(pl.UTF-8):     Testy dla ...
-Group:         Development/Languages/PHP
-Requires:      %{name} = %{version}-%{release}
-AutoProv:      no
-AutoReq:       no
-
-%description tests
-Tests for ...
-
-%description tests -l pl.UTF-8
-Testy dla ...
-
 %package phpdoc
 Summary:       Online manual for %{name}
 Summary(pl.UTF-8):     Dokumentacja online do %{name}
@@ -73,6 +61,7 @@ Dokumentacja do %{name}.
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_appdir}
+install -d $RPM_BUILD_ROOT%{php_data_dir}
 
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
@@ -88,9 +77,6 @@ rm -rf $RPM_BUILD_ROOT
 
 %{_examplesdir}/%{name}-%{version}
 
-%files tests
-%defattr(644,root,root,755)
-
 %files phpdoc
 %defattr(644,root,root,755)
-%{_phpdocdir}/%{name}
+%{_phpdocdir}/%{pkgname}
This page took 0.02589 seconds and 4 git commands to generate.