]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - perl.spec
py_comp/py_ocomp must be before py_postclean
[projects/template-specs.git] / perl.spec
index c30544b3a0b3347392951d209b4fd4b92c414b0b..9113daefaff0b0cf19cf76fd0d1a5a89dd963cba 100644 (file)
--- a/perl.spec
+++ b/perl.spec
@@ -1,25 +1,35 @@
+#
+############################################################
+#
 # NOTE
-# - you should consider using pldcpan for new perl packages
+# - use the SOURCES/pldcpan.pl script for new perl packages
+#   also available in pldcpan package.
+#
+############################################################
 #
 # Conditional build:
 %bcond_without autodeps        # don't BR packages needed only for resolving deps
 %bcond_without tests   # do not perform "make test"
 #
-%include       /usr/lib/rpm/macros.perl
 %define                pdir    PDIR
 %define                pnam    PNAM
+%include       /usr/lib/rpm/macros.perl
 Summary:       -
-Summary(pl):   -
+Summary(pl.UTF-8):     -
 Name:          perl-PDIR-PNAM
 Version:       -
 Release:       -
 # note if it is "same as perl"
+#License:      GPL v1+ or Artistic
 License:       (enter GPL/LGPL/BSD/BSD-like/Artistic/other license name here)
 Group:         Development/Languages/Perl
-Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
+Source0:       http://www.cpan.org/modules/by-module/PDIR/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 
 Patch0:                %{name}-foo.patch
 # most of CPAN modules have generic URL (substitute pdir and pnam here)
 URL:           http://search.cpan.org/dist/PDIR-PNAM/
+# macros BR if _noautoreq_perl is used
+#BuildRequires:        rpmbuild(macros) >= 1.654
 BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
 BuildRequires: -
@@ -33,34 +43,52 @@ Obsoletes:  -
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreq      'perl(anything_fake_or_conditional)'
+%define                _noautoreq_perl anything_fake_or_conditional
 
 %description
 
-%description -l pl
+%description -l pl.UTF-8
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
 %patch0 -p1
 
+# fix #!/usr/bin/env perl -w -> #!/usr/bin/perl:
+%{__sed} -i -e '1s,^#!.*perl,#!%{__perl},' tofu
+
 %build
 # Don't use pipes here: they generally don't work. Apply a patch.
 %{__perl} Makefile.PL \
        INSTALLDIRS=vendor
 
+# Build.PL based packages
+%{__perl} Build.PL \
+       perl=%{__perl} \
+       installdirs=vendor
+./Build
+
 %{__make}
 # if module isn't noarch, use:
 # %{__make} \
+#      CC="%{__cc}"
+#      OPTIMIZE="%{rpmcflags}"
+
+# for C++ programs, use also CC but specify __cxx:
+# NOTE: (this) Perl build system doesn't have CXX, but CC is used
+#%{__make} \
+#      CC="%{__cxx}" \
 #      OPTIMIZE="%{rpmcflags}"
 
 %{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
 %{__make} pure_install \
        DESTDIR=$RPM_BUILD_ROOT
 
+./Build install \
+       destdir=$RPM_BUILD_ROOT
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -69,6 +97,6 @@ rm -rf $RPM_BUILD_ROOT
 %doc Changes README
 # NOTE it's mostly easier to copy unpackaged filelist here, and run adapter over the spec.
 # use macros:
-#%%{perl_vendorlib}/...
-#%%{perl_vendorarch}/...
+#%%{perl_vendorlib}/PDIR...
+#%%{perl_vendorarch}/PDIR...
 %{_mandir}/man3/*
This page took 0.094813 seconds and 4 git commands to generate.