]> git.pld-linux.org Git - packages/perl.git/blobdiff - perl.spec
- fix @INC (and other) paths in microperl, add archlib to @INC
[packages/perl.git] / perl.spec
index 179bf4ea372656aebe1a384b81592462cce8a898..81739931aeb127cdd0339f15888288d24d94ccbe 100644 (file)
--- a/perl.spec
+++ b/perl.spec
@@ -16,6 +16,7 @@
 # - fix perl.prov's handling in rpm -- it should use the __perl macro
 # - include gdbm-dependent modules, they aren't distributed standalone
 #   anymore
+# - fix some duplicate files
 # - *TESTING*
 #
 
@@ -24,9 +25,9 @@
 
 %define                perl_privlib    %{_datadir}/perl5/%{version}
 %define                perl_archlib    %{_libdir}/perl5/%{version}/%{_target_platform}%{perlthread}
-%define                perl_sitelib    %{_usr}/local/share/perl5/
+%define                perl_sitelib    %{_usr}/local/share/perl5
 %define                perl_sitearch   %{_usr}/local/lib/perl5/%{version}/%{_target_platform}%{perlthread}
-%define                perl_vendorlib  %{_datadir}/perl5/vendor_perl/
+%define                perl_vendorlib  %{_datadir}/perl5/vendor_perl
 %define                perl_vendorarch %{_libdir}/perl5/vendor_perl/%{version}/%{_target_platform}%{perlthread}
 
 Summary:       Practical Extraction and Report Language (Perl)
@@ -52,15 +53,16 @@ Summary(tr):        Kabuk yorumlama dili
 Summary(zh_CN):        Perl ±à³ÌÓïÑÔ¡£
 Name:          perl
 Version:       5.8.0
-Release:       0.20%{?_without_threads:_nothr}%{?_without_largefiles:_nolfs}
+Release:       0.23%{?_without_threads:_nothr}%{?_without_largefiles:_nolfs}
 Epoch:         1
 License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Source0:       ftp://ftp.cpan.org/pub/CPAN/src/%{name}-%{version}.tar.gz
+Source0:       http://www.cpan.org/src/%{name}-%{version}.tar.gz
 Source1:       %{name}-non-english-man-pages.tar.bz2
 Source2:       %{name}.prov
 Source3:       find-perl-provides.sh
 Patch0:                %{name}_580-noroot_install.patch
+Patch1:                %{name}_580-INC.patch
 Patch2:                %{name}_580-MakeMaker.patch
 # failed
 #Patch5:       %{name}-syslog.patch
@@ -195,8 +197,6 @@ sistema e programa
 são escritos em Perl. Você precisa do pacote perl instalado no seu
 sistema de maneira a que este possa tratar de 'scripts' de Perl.
 
-%description -l no
-
 %description -l pt_BR
 Perl é uma linguagem interpretada, otimizada para tratar arquivos
 texto, extraindo informação desses arquivos e mostrando relatórios
@@ -274,6 +274,11 @@ Base components, files, core modules, etc. -- a minimal usable perl
 installation.  You are encouraged to install a full perl (the perl
 package) whenever possible.
 
+%description base -l pl
+Podstawowe sk³adniki, pliki, g³ówne modu³y itp. - minimalna u¿ywalna
+instalacja Perla. Zaleca siê instalacjê pe³nego Perla (pakietu perl)
+je¶li to tylko mo¿liwe.
+
 %package devel
 Summary:       Perl development files
 Summary(pl):   Pliki potrzebne przy tworzeniu w³asnych aplikacji w perlu
@@ -291,9 +296,13 @@ Provides:  perl-ExtUtils-Embed = 1.250601
 Obsoletes:     perl-lib-devel
 
 %description devel
-Components, required for developing applications which embed a Perl
+Components required for developing applications which embed a Perl
 interpreter and compiling perl modules.
 
+%description devel -l pl
+Sk³adniki potrzebne do tworzenia aplikacji osadzaj±cych interpreter
+Perla oraz kompilowania modu³ów Perla.
+
 %package doc-pod
 Summary:       Perl documentation in POD format
 Summary(pl):   Dokumentacja Perla w formacie POD
@@ -304,7 +313,8 @@ Obsoletes:  perl-pod
 Practical Extraction and Report Language - POD docs.
 
 %description doc-pod -l pl
-Practical Extraction and Report Language - dokumentacja w formacie POD.
+Practical Extraction and Report Language - dokumentacja w formacie
+POD.
 
 %package doc-reference
 Summary:       Perl reference documentation
@@ -374,16 +384,22 @@ dystrybucji.
 
 %package perldoc
 Summary:       perldoc - Look up Perl documentation in pod format
+Summary(pl):   perldoc - przeszukiwanie dokumentacji Perla w formacie pod
 Provides:      perldoc = 2.03@%{version}
 Requires:      %{name}-base
 Group:         Development/Tools
 
 %description perldoc
-perldoc perldoc looks up a piece of documentation in .pod format
-that is embedded in the perl installation tree or in a perl script,
-and displays it via "pod2man | nroff -man | $PAGER". (In addition, if
-running under HP-UX, "col -x" will be used.) This is primarily used for
-the documentation for the perl library modules.
+perldoc looks up a piece of documentation in .pod format that is
+embedded in the perl installation tree or in a perl script, and
+displays it via "pod2man | nroff -man | $PAGER". This is primarily
+used for the documentation for the perl library modules.
+
+%description perldoc -l pl
+perldoc wyszukuje fragment dokumentacji w formacie .pod osadzony w
+drzewie instalacji perla lub w skypcie perlowym i wy¶wietla go przez
+"pod2man | nroff -man | $PAGER". Program ten u¿ywany jest g³ównie do
+dokumentacji modu³ów z bibliotek Perla.
 
 %package -n sperl
 Summary:       Perl setuid root binaries for use with setuid Perl scripts
@@ -466,12 +482,12 @@ Various tools from the core perl distribution:
  psed, s2p - a stream editor
 
 %description modules -l pl
-Ró¿ne narzêdzia z podstawowej dystrybucji perla:
+Ró¿ne narzêdzia z podstawowej dystrybucji Perla:
 
- a2p       - Awk to Perl translator
- find2perl - translate find command lines to Perl code
- piconv    - iconv(1), reinvented in perl
- psed, s2p - a stream editor
+ a2p       - translator skryptów Awka do Perla
+ find2perl - t³umaczenie linii poleceñ programu find na kod w Perlu
+ piconv    - iconv(1) napisany w Perlu
+ psed, s2p - edytor strumieniowy
 
 %package tools-devel
 Summary:       Developer's tools from the core perl distribution
@@ -493,6 +509,23 @@ Various tools from the core perl distribution:
  pl2pm         - Rough tool to translate Perl4 .pl files to Perl5 .pm modules.
  splain        - force verbose warning diagnostics
 
+%description tools-devel -l pl
+Ró¿ne narzêdzia z podstawowej dystrybucji Perla:
+
+ c2ph, pstruct - zrzucanie struktur C w postaci generowanej z tablic
+                 symboli z cc -g -S
+ dprofpp       - wy¶wietlanie perlowych danych profiluj±cych
+ enc2xs        - generator modu³ów koduj±cych w Perlu
+ h2ph          - konwerter plików nag³ówkowych .h z C na perlowe pliki
+                 nag³ówkowe .ph
+ h2xs          - konwerter plików nag³ówkowych .h z C na rozszerzenia
+                 Perla
+ perlcc        - generator binarek z programów w Perlu
+ perlivp       - procedura weryfikacji instalacji Perla
+ pl2pm         - zgrubne narzêdzie do t³umaczenia plików pl Perla 4 na
+                 modu³y .pm Perla 5
+ splain        - wymuszenie obszernych ostrze¿eñ diagnostycznych
+
 %package tools-pod
 Summary:       Tools for manipulating files in the POD format
 Summary(pl):   Narzêdzia do przetwarzania plików w formacie POD
@@ -500,34 +533,59 @@ Group:            Applications
 Requires:      %{name}-base = %{version}
 
 %description tools-pod
-Tools for manipulating files in the POD (Plain Old Documentation) format:
+Tools for manipulating files in the POD (Plain Old Documentation)
+format:
 
  pod2html   - convert .pod files to .html files
- pod2latex  - convert pod documentation to latex format
- pod2man    - Convert POD data to formatted *roff input
- pod2text   - Convert POD data to formatted ASCII text
+ pod2latex  - convert pod documentation to LaTeX format
+ pod2man    - convert POD data to formatted *roff input
+ pod2text   - convert POD data to formatted ASCII text
  pod2usage  - print usage messages from embedded pod docs in files
  podchecker - check the syntax of POD format documentation files
- podselect  - print selected sections of pod documentation on standard output
+ podselect  - print selected sections of pod documentation
+
+%description tools-pod
+Narzêdzia do przetwarzania plików w formacie POD (Plain Old
+Documentation):
+
+ pod2html   - konwerter plików .pod do plików .html
+ pod2latex  - konwerter dokumentacji pod do formatu LaTeX
+ pod2man    - konwerter danych POD na wej¶cie sformatowane dla *roffa
+ pod2text   - konwerter danych POD na sformatowany tekst ASCII
+ pod2usage  - wypisanie informacji o u¿ywaniu programu z dokumentacji
+              osadzonej w plikach
+ podchecker - kontrola sk³adni dokumentacji w formacie POD
+ podselect  - wypisanie wybranych sekcji z dokumentacji POD
 
 %package -n microperl
 Summary:       A really minimal perl, even more minimal than miniperl
+Summary(pl):   Naprawdê minimalny Perl, nawet bardziej minimalny ni¿ miniperl
 # XXX: is there a more appropiate group?
 Group:         Applications
 
 %description -n microperl
-microperl is supposed to be able a really minimal perl, even more minimal
-than miniperl.  No Configure is needed to build microperl, on the other
-hand this means that interfaces between Perl and your operating system
-are left very -- minimal.
+microperl is supposed to be able a really minimal perl, even more
+minimal than miniperl.  No Configure is needed to build microperl, on
+the other hand this means that interfaces between Perl and your
+operating system are left very -- minimal.
 
 All this is experimental.  If you don't know what to do with microperl
 you probably shouldn't.  Do not report bugs in microperl; fix the bugs.
 
+%description -n microperl -l pl
+microperl ma byæ naprawdê minimalnym Perlem, nawet bardziej minimalnym
+od miniperla. Uruchamianie Configure nie jest potrzebne do zbudowania
+microperla, z drugiej strony oznacza to, ¿e interfejs miêdzy Perlem a
+systemem operacyjnym pozostaje bardzo minimalny.
+
+Ca³o¶æ jest eksperymentalna. Je¶li nie wiesz co zrobiæ z microperlem,
+prawdopodobnie nie powiniene¶ tego robiæ. Nie zg³aszaj b³êdów w
+microperlu - popraw je.
 
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p0
 %patch2 -p0
 %patch8 -p1
 %patch9 -p1
@@ -560,7 +618,7 @@ sh Configure \
        -Dvendorlib=%{perl_vendorlib} -Dvendorarch=%{perl_vendorarch} \
        -Dinstallprefix=$RPM_BUILD_ROOT%{_prefix} \
        -Ui_dbm -Ui_gdbm -Ui_ndbm -Ui_db \
-       -Dlibswanted="nsl dl m c crypt util" \
+       -Dlibswanted="dl m c crypt" \
        -%{?_without_threads:U}%{?!_without_threads:D}usethreads \
        -%{?_without_largefiles:U}%{?!_without_largefiles:D}uselargefiles
 
@@ -573,7 +631,8 @@ sh Configure \
 # %endif
 
 %{__make}
-%{__make} -f Makefile.micro
+%{__make} -f Makefile.micro \
+       OPTIMIZE="%{rpmcflags}"
 
 %{?!_without_tests:%{__make} test}
 #%{?!_without_tests:%{__make} minitest}
@@ -642,9 +701,8 @@ rm -f $RPM_BUILD_ROOT%{perl_privlib}/{Encode,Test,Net,Locale{,/Maketext}}/*.pod
 rm -f $RPM_BUILD_ROOT%{perl_privlib}/*.pod
 rm -f $RPM_BUILD_ROOT%{perl_archlib}/*.pod
 
-
-## directories for modules installed using CPAN.pm
-install -d $RPM_BUILD_ROOT{%{perl_sitelib},%{perl_sitearch}/auto}
+## this object file looks unused; why is it there?
+rm -f $RPM_BUILD_ROOT%{perl_archlib}/CORE/sperl.o
 
 ## dir tree for other perl modules
 install -d $RPM_BUILD_ROOT{%{perl_vendorlib},%{perl_vendorarch},%{perl_vendorarch}/auto}
@@ -652,14 +710,14 @@ install -d $RPM_BUILD_ROOT{%{perl_vendorlib},%{perl_vendorarch},%{perl_vendorarc
 cd $RPM_BUILD_ROOT%{perl_vendorlib}
 install -d AI/NeuralNet Algorithm Apache Archive Array Astro Attribute \
        Audio Authen B Bundle Business CGI Cache Chart Class Config \
-       Convert Crypt DBD Data Date Devel Digest Error ExtUtils File \
+       Convert Crypt DBD Data Date Devel Device Digest Error ExtUtils File \
        Filesys Font Games Getopt GnuPG Graph HTML HTTP I18N IO/Socket IPC \
-       Image Inline Language Lingua/EN List Locale Log MIME Mail Math \
-       Module Net/SMTP NetServer Netscape News Number OLE Parse Pod \
+       Image Inline Language Lingua/EN List Locale LockFile Log MIME Mail \
+       Math Module Net/SMTP NetServer Netscape News Number OLE Parse Pod \
        PostScript Proc RADIUS RPC RPM Regexp SOAP/Transport SQL Schedule \
        Set Sort Speech Spreadsheet Statistics String Sub Sys TeX Test \
        Text/Query Tie Time Tree Unicode WWW XML/{Filter,Handler,Parser} \
-       auto/{AI,Array,Crypt,Data,Mail,Net,Schedule,Statistics,Text,WWW}
+       auto/{AI,Array,Config,Crypt,Data,Mail,Net,Schedule,Statistics,Text,WWW}
 
 cd $RPM_BUILD_ROOT%{perl_vendorarch}
 install -d Astro Audio Authen B BSD Bit Compress Crypt/OpenSSL Data Devel \
@@ -680,7 +738,6 @@ rm -rf $RPM_BUILD_ROOT
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
-
 %files
 %defattr(644,root,root,755)
 %doc README AUTHORS
@@ -689,12 +746,11 @@ rm -rf $RPM_BUILD_ROOT
 %lang(ko) %doc README.ko
 %lang(tw) %doc README.tw
 
-%dir %{perl_sitelib}
-%dir %{perl_sitearch}
-%dir %{perl_sitearch}/auto
-%dir %{perl_vendorlib}
-%dir %{perl_vendorarch}
-%dir %{perl_vendorarch}/auto
+%{perl_vendorlib}
+%dir %{_libdir}/perl5/vendor_perl
+%dir %{_libdir}/perl5/vendor_perl/%{version}
+%{perl_vendorarch}
+#%dir %{perl_vendorarch}/auto
 
 
 %files base
@@ -705,7 +761,10 @@ rm -rf $RPM_BUILD_ROOT
 %lang(fi) %{_mandir}/fi/man1/perl*
 %lang(pl) %{_mandir}/pl/man1/perl*
 
+%dir %{_datadir}/perl5
 %dir %{perl_privlib}
+%dir %{_libdir}/perl5
+%dir %{_libdir}/perl5/%{version}
 %dir %{perl_archlib}
 %dir %{perl_archlib}/auto
 
@@ -788,7 +847,9 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{perl_archlib}/auto/PerlIO/*/
 %attr(755,root,root) %{perl_archlib}/auto/PerlIO/*/*.so
 %{perl_archlib}/auto/PerlIO/*/*.bs
-%{_mandir}/man3/PerlIO*
+%{_mandir}/man3/PerlIO.*
+%{_mandir}/man3/PerlIO::[es]*
+%{_mandir}/man3/PerlIO::via.*
 
 %{perl_archlib}/POSIX*
 %dir %{perl_archlib}/auto/POSIX
@@ -803,17 +864,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/[acdefh]*
-%attr(755,root,root) %{_bindir}/perlcc
-%attr(755,root,root) %{_bindir}/pl2pm
-%attr(755,root,root) %{_bindir}/pstruct
-%attr(755,root,root) %{_bindir}/[sx]*
-%{_mandir}/man1/[acdefh]*
-%{_mandir}/man1/perlcc.*
 %{_mandir}/man1/perldebguts.*
-%{_mandir}/man1/pl2pm.*
-%{_mandir}/man1/pstruct.*
-%{_mandir}/man1/[sx]*
 
 %attr(755,root,root) %{_libdir}/lib*.so
 %{perl_archlib}/CORE
@@ -1142,6 +1193,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/pl2pm.*
 %attr(755,root,root) %{_bindir}/splain
 %{_mandir}/man1/splain.*
+%attr(755,root,root) %{_bindir}/xsubpp
+%{_mandir}/man1/xsubpp.*
 
 %files tools-pod
 %defattr(644,root,root,755)
This page took 0.048258 seconds and 4 git commands to generate.