]> git.pld-linux.org Git - packages/perl.git/blobdiff - perl.spec
- Release: 1
[packages/perl.git] / perl.spec
index bb81e5760856bc1a5eb58f35e6c042fd07f8d4d2..6ca8f01aa9df610131899428e31eaa9d56802cb4 100644 (file)
--- a/perl.spec
+++ b/perl.spec
@@ -1,5 +1,5 @@
 %define                perlver 5.005
-%define                perlrel 03
+%define                perlrel 61
 %define                perlthread -thread
 
 Summary:       Practical Extraction and Report Language
@@ -9,12 +9,13 @@ Summary(pl):  Practical Extraction and Report Language (Perl)
 Summary(tr):   Kabuk yorumlama dili
 Name:          perl
 Version:       %{perlver}_%{perlrel}
-Release:       2
+Release:       1
 Copyright:     GPL
 Group:         Utilities/Text
 Group(pl):     Narzêdzia/Tekst
 Source:                ftp://ftp.perl.org/pub/perl/CPAN/src/5.0/%{name}%{version}.tar.gz
 Patch0:                perl-noroot_install.patch
+Patch1:                perl-DESTDIR.patch
 URL:           http://www.perl.org/
 Requires:      csh
 Buildroot:     /tmp/%{name}-%{version}-root
@@ -57,7 +58,7 @@ dildir. Ayr
 vardýr. Perl, güzel (ufak, zarif, minimum) olmaktan çok, pratik olmaya
 yönelik (kullanýmý kolay, verimli, eksiksiz) olarak tasarlanmýþtýr.
 
-%package -n    sperl
+%package -n sperl
 Summary:       Practical Extraction and Report Language (SUID root binary)
 Summary(pl):   Practical Extraction and Report Language (SUID root binaria)
 Group:         Utilities/Text
@@ -71,13 +72,14 @@ Practical Extraction and Report Language (SUID root binary).
 Practical Extraction and Report Language (SUID root binaria).
 
 %prep
-%setup -q -n %{name}%{version}
-%patch -p1
+%setup  -q -n %{name}%{version}
+%patch0 -p1
+%patch1 -p1
 
 %build
 # this is gross
 cat > config.over <<EOF
-installprefix=$RPM_BUILD_ROOT/usr
+installprefix=$RPM_BUILD_ROOT%{_prefix}
 test -d \$installprefix || mkdir \$installprefix
 test -d \$installprefix/bin || mkdir \$installprefix/bin
 installarchlib=\`echo \$installarchlib | sed "s!\$prefix!\$installprefix!"\`
@@ -91,13 +93,16 @@ installsitearch=\`echo \$installsitearch | sed "s!\$prefix!\$installprefix!"\`
 EOF
 
 sh Configure \
-       -Darchname=${RPM_ARCH}-linux \
-       -Dprefix=/usr \
-       -Dman3dir=/usr/man/man3 \
+       -des \
+       -Dcc=gcc \
+       -Darchname=%{_target_platform} \
+       -Dprefix=%{_prefix} \
+       -Dman1dir=%{_mandir}/man1 \
+       -Dman3dir=%{_mandir}/man3 \
        -Dman3ext=3pm \
        -Doptimize="$RPM_OPT_FLAGS" \
+       -Duseshrplib \
        -Dusethreads \
-       -des \
        -Dd_dosuid \
        -Ud_setresuid \
        -Ud_setresgid 
@@ -113,30 +118,30 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT
 
 make install
-install utils/pl2pm $RPM_BUILD_ROOT/usr/bin/pl2pm
-
-
-(cd /usr/include ;
-PERL5LIB=$RPM_BUILD_ROOT/usr/lib/perl5 $RPM_BUILD_ROOT/usr/bin/perl \
-$RPM_BUILD_ROOT/usr/lib/perl5/%{perlver}%{perlrel}/${RPM_ARCH}-linux%{perlthread} \
-$RPM_BUILD_ROOT/usr/bin/h2ph \
--d $RPM_BUILD_ROOT/usr/lib/perl5/${RPM_ARCH}-linux/%{perlver}%{perlrel}/ \
+install utils/pl2pm $RPM_BUILD_ROOT%{_bindir}/pl2pm
+
+(cd %{_includedir} ;
+LD_LIBRARY_PATH="%{_builddir}/%{name}%{perlver}_%{perlrel}" \
+PERL5LIB=$RPM_BUILD_ROOT%{_libdir}/perl5 $RPM_BUILD_ROOT%{_bindir}/perl \
+$RPM_BUILD_ROOT%{_libdir}/perl5/%{perlver}%{perlrel}/%{_target_platform}%{perlthread} \
+$RPM_BUILD_ROOT%{_bindir}/h2ph \
+-d $RPM_BUILD_ROOT%{_libdir}/perl5/%{_target_platform}/%{perlver}%{perlrel}/ \
 *.h sys/*.h linux/*.h asm/*.h net/*.h netinet/*.h arpa/*.h )
 
-( cd $RPM_BUILD_ROOT/usr/lib/perl5/%{perlver}%{perlrel}/${RPM_ARCH}-linux%{perlthread}/
+( cd $RPM_BUILD_ROOT%{_libdir}/perl5/%{perlver}%{perlrel}/%{_target_platform}%{perlthread}/
 
 mv .packlist .packlist.old
-sed "s|$RPM_BUILD_ROOT||" < .packlist.old > .packlist
+sed "s|$RPM_BUILD_ROOT||g" < .packlist.old > .packlist
 rm -f .packlist.old
 
 mv Config.pm Config.pm.old
-sed "s|$RPM_BUILD_ROOT||" < Config.pm.old > Config.pm
+sed "s|$RPM_BUILD_ROOT||g" < Config.pm.old > Config.pm
 rm -f Config.pm.old )
 
-gzip -9fn $RPM_BUILD_ROOT/usr/man/man*/* \
+gzip -9fn $RPM_BUILD_ROOT%{_mandir}/man*/* \
        README Change*
 
-find $RPM_BUILD_ROOT/usr/lib/perl5 -name \*.so -exec strip --strip-unneeded {} \;
+find $RPM_BUILD_ROOT%{_libdir}/perl5 -name \*.so -exec strip --strip-unneeded {} \;
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -145,63 +150,35 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README.gz Change*
 
-%attr(755,root,root) /usr/bin/a2p
-%attr(755,root,root) /usr/bin/c2ph
-%attr(755,root,root) /usr/bin/find2perl
-%attr(755,root,root) /usr/bin/h2ph
-%attr(755,root,root) /usr/bin/h2xs
-%attr(755,root,root) /usr/bin/perl
-%attr(755,root,root) /usr/bin/perl%{perlver}%{perlrel}
-%attr(755,root,root) /usr/bin/perlbug
-%attr(755,root,root) /usr/bin/perlcc
-%attr(755,root,root) /usr/bin/perldoc
-%attr(755,root,root) /usr/bin/pl2pm
-%attr(755,root,root) /usr/bin/pod2html
-%attr(755,root,root) /usr/bin/pod2latex
-%attr(755,root,root) /usr/bin/pod2man
-%attr(755,root,root) /usr/bin/pod2text
-%attr(755,root,root) /usr/bin/pstruct
-%attr(755,root,root) /usr/bin/s2p
-%attr(755,root,root) /usr/bin/splain
-
-%dir /usr/lib/perl5
-%attr(-,root,root) /usr/lib/perl5/*
-/usr/man/man[13]/*
+%attr(755,root,root) %{_bindir}/a2p
+%attr(755,root,root) %{_bindir}/c2ph
+%attr(755,root,root) %{_bindir}/dprofpp
+%attr(755,root,root) %{_bindir}/find2perl
+%attr(755,root,root) %{_bindir}/h2ph
+%attr(755,root,root) %{_bindir}/h2xs
+%attr(755,root,root) %{_bindir}/perl
+%attr(755,root,root) %{_bindir}/perl%{perlver}%{perlrel}
+%attr(755,root,root) %{_bindir}/perlbug
+%attr(755,root,root) %{_bindir}/perlcc
+%attr(755,root,root) %{_bindir}/perldoc
+%attr(755,root,root) %{_bindir}/pl2pm
+%attr(755,root,root) %{_bindir}/pod2html
+%attr(755,root,root) %{_bindir}/pod2latex
+%attr(755,root,root) %{_bindir}/pod2man
+%attr(755,root,root) %{_bindir}/pod2text
+%attr(755,root,root) %{_bindir}/pod2usage
+%attr(755,root,root) %{_bindir}/podchecker
+%attr(755,root,root) %{_bindir}/podselect
+%attr(755,root,root) %{_bindir}/pstruct
+%attr(755,root,root) %{_bindir}/s2p
+%attr(755,root,root) %{_bindir}/splain
+
+%dir %{_libdir}/perl5
+%attr( - ,root,root) %{_libdir}/perl5/*
+%dir %{_libdir}/site_perl
+%attr( - ,root,root) %{_libdir}/site_perl/*
+%{_mandir}/man[13]/*
 
 %files -n sperl
-%attr(4711,root,root) /usr/bin/sperl%{perlver}%{perlrel}
-%attr(4711,root,root) /usr/bin/suidperl
-
-%changelog
-* Tue Apr 20 1999 Artur Frysiak <wiget@pld.org.pl>
-  [5.005_03-2]
-- updated to 5.005_03
-- changed source URL
-- added -Dman3dir=/usr/man/man3 -Dman3ext=3pm to Configure
-- corrected .packlist
-- changed --strip-debug to --strip-unneeded
-- gzipped %doc (instead bzipping2)
-- commpiled on rpm 3
-
-* Mon Oct 26 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
-  [5.005_02-2]
-- added using $RPM_OPT_FLAGS during compile,
-- added stripping modules,
-- added URL,
-- added sperl subpackage with suid perl binaries.
-
-* Tue Sep 15 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
-  [5.005_02-1]
-- updated to 5.005_02
-  (based on Ian Macdonald <ianmacd@xs4all.nl> spec files),
-- install -d instead mkdir -p,
-- added %defattr, but It's still unable to build from non root's account,
-- man3 subdirectory moved to /usr/man/man3,
-- minor modifications of spec file.   
-
-* Mon Jun 15 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
-  [5.005_01-1]
-- added pl translation,
-- moved %changelog to end of spec,
-- removed all old patches. 
-- start at RH spec file.
+%attr(4755,root,root) %{_bindir}/sperl%{perlver}%{perlrel}
+%attr(4755,root,root) %{_bindir}/suidperl
This page took 0.03507 seconds and 4 git commands to generate.