]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - perl.spec
Add .tar.xz deps
[projects/template-specs.git] / perl.spec
index b7804d4dbad16f3bee19f3ebc3b7fbbecf4397a5..32b9c04b96886a5bd79de301207c5ae81d6b0082 100644 (file)
--- a/perl.spec
+++ b/perl.spec
@@ -8,12 +8,10 @@
 ############################################################
 #
 # Conditional build:
-%bcond_without autodeps        # don't BR packages needed only for resolving deps
 %bcond_without tests   # do not perform "make test"
 #
 %define                pdir    PDIR
 %define                pnam    PNAM
-%include       /usr/lib/rpm/macros.perl
 Summary:       -
 Summary(pl.UTF-8):     -
 Name:          perl-PDIR-PNAM
@@ -27,13 +25,12 @@ Source0:    http://www.cpan.org/modules/by-module/PDIR/%{pdir}-%{pnam}-%{version}.t
 # Source0-md5: 
 Patch0:                %{name}-foo.patch
 # most of CPAN modules have generic URL (substitute pdir and pnam here)
-URL:           http://search.cpan.org/dist/PDIR-PNAM/
-# macros BR if _noautoreq_perl is used
-#BuildRequires:        rpmbuild(macros) >= 1.654
+URL:           https://metacpan.org/release/PDIR-PNAM
 BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: rpmbuild(macros) >= 1.745
 BuildRequires: -
-%if %{with autodeps} || %{with tests}
+%if %{with tests}
 BuildRequires: perl-
 BuildRequires: perl-
 %endif
@@ -63,7 +60,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # Build.PL based packages
 %{__perl} Build.PL \
-       destdir=$RPM_BUILD_ROOT \
+       perl=%{__perl} \
        installdirs=vendor
 ./Build
 
@@ -87,6 +84,9 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} pure_install \
        DESTDIR=$RPM_BUILD_ROOT
 
+./Build install \
+       destdir=$RPM_BUILD_ROOT
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
This page took 0.045912 seconds and 4 git commands to generate.