]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - perl.spec
Add .tar.xz deps
[projects/template-specs.git] / perl.spec
index 37cac77c9ff1f326474c92b09d246650bed86b0a..32b9c04b96886a5bd79de301207c5ae81d6b0082 100644 (file)
--- a/perl.spec
+++ b/perl.spec
@@ -1,29 +1,36 @@
+#
+############################################################
+#
 # NOTE
-# - you should consider using pldcpan for new perl packages
+# - use the SOURCES/pldcpan.pl script for new perl packages
+#   also available in pldcpan package.
+#
+############################################################
 #
 # Conditional build:
-%bcond_without autodeps        # don't BR packages needed only for resolving deps
 %bcond_without tests   # do not perform "make test"
 #
-%include       /usr/lib/rpm/macros.perl
 %define                pdir    PDIR
 %define                pnam    PNAM
 Summary:       -
-Summary(pl.UTF-8):   -
+Summary(pl.UTF-8):     -
 Name:          perl-PDIR-PNAM
 Version:       -
 Release:       -
 # note if it is "same as perl"
+#License:      GPL v1+ or Artistic
 License:       (enter GPL/LGPL/BSD/BSD-like/Artistic/other license name here)
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/modules/by-module/PDIR/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 
 Patch0:                %{name}-foo.patch
 # most of CPAN modules have generic URL (substitute pdir and pnam here)
-URL:           http://search.cpan.org/dist/PDIR-PNAM/
+URL:           https://metacpan.org/release/PDIR-PNAM
 BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: rpmbuild(macros) >= 1.745
 BuildRequires: -
-%if %{with autodeps} || %{with tests}
+%if %{with tests}
 BuildRequires: perl-
 BuildRequires: perl-
 %endif
@@ -33,7 +40,7 @@ Obsoletes:    -
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreq      'perl(anything_fake_or_conditional)'
+%define                _noautoreq_perl anything_fake_or_conditional
 
 %description
 
@@ -43,14 +50,30 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %setup -q -n %{pdir}-%{pnam}-%{version}
 %patch0 -p1
 
+# fix #!/usr/bin/env perl -w -> #!/usr/bin/perl:
+%{__sed} -i -e '1s,^#!.*perl,#!%{__perl},' tofu
+
 %build
 # Don't use pipes here: they generally don't work. Apply a patch.
 %{__perl} Makefile.PL \
        INSTALLDIRS=vendor
 
+# Build.PL based packages
+%{__perl} Build.PL \
+       perl=%{__perl} \
+       installdirs=vendor
+./Build
+
 %{__make}
 # if module isn't noarch, use:
 # %{__make} \
+#      CC="%{__cc}"
+#      OPTIMIZE="%{rpmcflags}"
+
+# for C++ programs, use also CC but specify __cxx:
+# NOTE: (this) Perl build system doesn't have CXX, but CC is used
+#%{__make} \
+#      CC="%{__cxx}" \
 #      OPTIMIZE="%{rpmcflags}"
 
 %{?with_tests:%{__make} test}
@@ -61,6 +84,9 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} pure_install \
        DESTDIR=$RPM_BUILD_ROOT
 
+./Build install \
+       destdir=$RPM_BUILD_ROOT
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
This page took 0.036459 seconds and 4 git commands to generate.