]> git.pld-linux.org Git - packages/perl.git/blobdiff - perl.spec
- release 11,
[packages/perl.git] / perl.spec
index edae29e51214508abb4da928ab28022293f0b103..0cd7f70f732fbf803934405afb7f52d0b068148c 100644 (file)
--- a/perl.spec
+++ b/perl.spec
@@ -1,28 +1,35 @@
-%define                perlver 5.005
-%define                perlrel 03
-%define                perlthread -thread
-%define        __find_provides %{_builddir}/%{name}%{version}/find-perl-provides
+%define        __find_provides %{_builddir}/%{name}-%{version}/find-perl-provides
+%define                perlthread      -thread-multi
 Summary:       Practical Extraction and Report Language
 Summary(de):   Praktische Extraktions- und Berichtsprache 
 Summary(fr):   Practical Extraction and Report Language (Perl)
 Summary(pl):   Practical Extraction and Report Language (Perl)
 Summary(tr):   Kabuk yorumlama dili
 Name:          perl
-Version:       %{perlver}_%{perlrel}
-Release:       15
+Version:       5.6.0
+Release:       11
+Epoch:         1
 License:       GPL
 Group:         Utilities/Text
 Group(fr):     Utilitaires/Texte
 Group(pl):     Narzêdzia/Tekst
-Epoch:         1
-Source0:       ftp://ftp.perl.org/pub/perl/CPAN/src/5.0/%{name}%{version}.tar.gz
+Source:                ftp://ftp.perl.org/pub/perl/CPAN/src/%{name}-%{version}.tar.gz
 Patch0:                perl-noroot_install.patch
-Patch1:                perl-DESTDIR.patch
-Patch2:                perl-File-Spec-0.7.patch
-Patch3:                perl-CPAN-1.50.patch
+Patch1:                perl-nodb.patch
+Patch2:                perl-DESTDIR.patch
+Patch3:                perl-CPAN-1.58.patch
 Patch4:                perl-find-provides.patch
+Patch5:                perl-prereq.patch
+Patch6:                perl-syslog.patch
+Patch7:                perl-CGI-upload-tmpdir.patch
+Patch8:                perl-LD_RUN_PATH.patch
+Patch9:                perl-errno_h-parsing.patch
 URL:           http://www.perl.org/
-Requires:      csh
+#Requires:     csh
+Obsoletes:     perl-ANSIColor
+Obsoletes:     perl-Devel-Peek
+Obsoletes:     perl-DProf
+Obsoletes:     perl-PodParser
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -83,16 +90,21 @@ Practical Extraction and Report Language (SUID root binary).
 Practical Extraction and Report Language (SUID root binaria).
 
 %prep
-%setup  -q -n %{name}%{version}
+%setup  -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
+%patch9 -p1
 
 for i in find-* ; do
        mv $i $i.old
-       sed "s|FPPATH|%{_builddir}/%{name}%{version}|g" < $i.old > $i
+       sed "s|FPPATH|%{_builddir}/%{name}-%{version}|g" < $i.old > $i
        chmod 755 $i; rm -f $i.old
 done
 
@@ -114,25 +126,23 @@ EOF
 
 sh Configure \
        -des \
-       -Dcc=gcc \
+       -Dcc=%{__cc} \
        -Darchname=%{_target_platform} \
+       -Dcccdlflags='-fPIC' \
        -Dprefix=%{_prefix} \
        -Dscriptdir=%{_bindir} \
        -Dman1dir=%{_mandir}/man1 \
        -Dman3dir=%{_mandir}/man3 \
        -Dman3ext=3pm \
        -Doptimize="$RPM_OPT_FLAGS" \
-       -Duseshrplib \
        -Dusethreads \
-       -Dd_dosuid \
-       -Ud_setresuid \
-       -Ud_setresgid 
-
-make
+       -Uuselargefiles \
+%ifarch sparc sparc64
+       -Ud_longdbl \
+%endif
+       -Dd_dosuid
 
-# Strip binaries (done now rather than at install)
-
-strip {perl,suidperl,x2p/a2p}
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -142,7 +152,7 @@ install -d $RPM_BUILD_ROOT
 install utils/pl2pm $RPM_BUILD_ROOT%{_bindir}/pl2pm
 
 ## Generate *.ph files with a trick (based on RH).
-# Everybody else is using it so why can't we? ;)
+
 %{__make} all -f - <<EOF
 PKGS   = glibc-devel gdbm-devel gpm-devel libgr-devel libjpeg-devel \
        libpng-devel libtiff-devel ncurses-devel popt-devel \
@@ -153,8 +163,8 @@ STDH        += \$(wildcard /usr/include/linux/*.h) \$(wildcard /usr/include/asm/*.h) \$
 GCCDIR = \$(shell gcc --print-file-name include)
 GCCH    = \$(filter \$(GCCDIR)/%%, \$(shell rpm -q --queryformat '[%%{FILENAMES}\n]' gcc))
 
-LIBPATH = %{_builddir}/%{name}%{perlver}_%{perlrel}
-PERLLIB = $RPM_BUILD_ROOT%{_libdir}/perl5/%{perlver}%{perlrel}
+LIBPATH = %{_builddir}/%{name}-%{version}
+PERLLIB = $RPM_BUILD_ROOT%{_libdir}/perl5/%{version}
 PERLBIN = $RPM_BUILD_ROOT%{_bindir}/perl
 PERL   = LD_LIBRARY_PATH=\$(LIBPATH) PERL5LIB=\$(PERLLIB) \$(PERLBIN)
 PHDIR  = \$(PERLLIB)/%{_target_platform}%{perlthread}
@@ -171,25 +181,20 @@ gcc-headers: \$(GCCH)
 
 EOF
 
-( cd $RPM_BUILD_ROOT%{_libdir}/perl5/%{perlver}%{perlrel}/%{_target_platform}%{perlthread}/
-
-## Fix permissions
-find . -name \*.ph -exec chmod 644 {} \;
-find . -type d -exec chmod 755 {} \;
-
 ## Fix paths
-mv .packlist .packlist.old
-sed "s|$RPM_BUILD_ROOT||g" < .packlist.old > .packlist
-rm -f .packlist.old
+(
+cd $RPM_BUILD_ROOT%{_libdir}/perl5/%{version}/%{_target_platform}%{perlthread}
+sed -e "s|$RPM_BUILD_ROOT||g" < Config.pm > Config.pm.new
+mv -f Config.pm.new Config.pm
+sed -e "s|$RPM_BUILD_ROOT||g" < .packlist > .packlist.new
+mv -f .packlist.new .packlist
+)
 
-mv Config.pm Config.pm.old
-sed "s|$RPM_BUILD_ROOT||g" < Config.pm.old > Config.pm
-rm -f Config.pm.old )
-
-gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/* \
-       README Change*
+## Fix permissions
+find $RPM_BUILD_ROOT%{_libdir}/perl5 -name \*.ph -exec chmod 444 {} \;
+find $RPM_BUILD_ROOT%{_libdir}/perl5 -type d -exec chmod 755 {} \;
 
-find $RPM_BUILD_ROOT%{_libdir}/perl5 -name \*.so -exec strip --strip-unneeded {} \;
+gzip -9nf README Change*
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -204,7 +209,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/h2ph
 %attr(755,root,root) %{_bindir}/h2xs
 %attr(755,root,root) %{_bindir}/perl
-%attr(755,root,root) %{_bindir}/perl%{perlver}%{perlrel}
+%attr(755,root,root) %{_bindir}/perl%{version}
 %attr(755,root,root) %{_bindir}/perlbug
 %attr(755,root,root) %{_bindir}/perlcc
 %attr(755,root,root) %{_bindir}/perldoc
@@ -213,6 +218,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/pod2latex
 %attr(755,root,root) %{_bindir}/pod2man
 %attr(755,root,root) %{_bindir}/pod2text
+%attr(755,root,root) %{_bindir}/podselect
 %attr(755,root,root) %{_bindir}/pstruct
 %attr(755,root,root) %{_bindir}/s2p
 %attr(755,root,root) %{_bindir}/splain
@@ -225,5 +231,5 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n sperl
 %defattr(644,root,root,755)
-%attr(4755,root,root) %{_bindir}/sperl%{perlver}%{perlrel}
+%attr(4755,root,root) %{_bindir}/sperl%{version}
 %attr(4755,root,root) %{_bindir}/suidperl
This page took 0.033269 seconds and 4 git commands to generate.