]> git.pld-linux.org Git - packages/perl.git/blobdiff - perl.spec
- release 11,
[packages/perl.git] / perl.spec
index 3e4b9774c35fb242092cb26c1fd7a83ae9595039..0cd7f70f732fbf803934405afb7f52d0b068148c 100644 (file)
--- a/perl.spec
+++ b/perl.spec
@@ -7,20 +7,23 @@ Summary(pl):  Practical Extraction and Report Language (Perl)
 Summary(tr):   Kabuk yorumlama dili
 Name:          perl
 Version:       5.6.0
-Release:       1
-Serial:                1
+Release:       11
+Epoch:         1
 License:       GPL
 Group:         Utilities/Text
 Group(fr):     Utilitaires/Texte
 Group(pl):     Narzêdzia/Tekst
 Source:                ftp://ftp.perl.org/pub/perl/CPAN/src/%{name}-%{version}.tar.gz
 Patch0:                perl-noroot_install.patch
-Patch1:                perl-installman.patch
-Patch2:                perl-nodb.patch
-Patch3:                perl-DESTDIR.patch
-Patch4:                perl-CPAN-1.54.patch
-Patch5:                perl-find-provides.patch
-Patch6:                perl-prereq.patch
+Patch1:                perl-nodb.patch
+Patch2:                perl-DESTDIR.patch
+Patch3:                perl-CPAN-1.58.patch
+Patch4:                perl-find-provides.patch
+Patch5:                perl-prereq.patch
+Patch6:                perl-syslog.patch
+Patch7:                perl-CGI-upload-tmpdir.patch
+Patch8:                perl-LD_RUN_PATH.patch
+Patch9:                perl-errno_h-parsing.patch
 URL:           http://www.perl.org/
 #Requires:     csh
 Obsoletes:     perl-ANSIColor
@@ -95,6 +98,9 @@ Practical Extraction and Report Language (SUID root binaria).
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
+%patch8 -p1
+%patch9 -p1
 
 for i in find-* ; do
        mv $i $i.old
@@ -120,26 +126,24 @@ EOF
 
 sh Configure \
        -des \
-       -Dcc=gcc \
+       -Dcc=%{__cc} \
        -Darchname=%{_target_platform} \
+       -Dcccdlflags='-fPIC' \
        -Dprefix=%{_prefix} \
        -Dscriptdir=%{_bindir} \
        -Dman1dir=%{_mandir}/man1 \
        -Dman3dir=%{_mandir}/man3 \
        -Dman3ext=3pm \
        -Doptimize="$RPM_OPT_FLAGS" \
-       -Duseshrplib \
        -Dusethreads \
-       -Dd_dosuid \
-       -Ud_setresuid \
-       -Ud_setresgid 
+       -Uuselargefiles \
+%ifarch sparc sparc64
+       -Ud_longdbl \
+%endif
+       -Dd_dosuid
 
 %{__make}
 
-## Strip binaries (done now rather than at install)
-
-strip {perl,suidperl,x2p/a2p}
-
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT
@@ -177,26 +181,20 @@ gcc-headers: \$(GCCH)
 
 EOF
 
+## Fix paths
 (
 cd $RPM_BUILD_ROOT%{_libdir}/perl5/%{version}/%{_target_platform}%{perlthread}
-
-## Fix permissions
-find . -name \*.ph -exec chmod 644 {} \;
-find . -type d -exec chmod 755 {} \;
-
-## Fix paths
-sed -e "s|\$(RPM_BUILD_ROOT)||g" < Config.pm > Config.pm.new
+sed -e "s|$RPM_BUILD_ROOT||g" < Config.pm > Config.pm.new
 mv -f Config.pm.new Config.pm
-
-sed -e "s|\$(RPM_BUILD_ROOT)||g" < .packlist > .packlist.new
+sed -e "s|$RPM_BUILD_ROOT||g" < .packlist > .packlist.new
 mv -f .packlist.new .packlist
 )
 
-gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man*/* \
-       README Change*
+## Fix permissions
+find $RPM_BUILD_ROOT%{_libdir}/perl5 -name \*.ph -exec chmod 444 {} \;
+find $RPM_BUILD_ROOT%{_libdir}/perl5 -type d -exec chmod 755 {} \;
 
-find $RPM_BUILD_ROOT%{_libdir}/perl5 -name \*.so \
-       -exec strip --strip-unneeded {} \;
+gzip -9nf README Change*
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -220,6 +218,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/pod2latex
 %attr(755,root,root) %{_bindir}/pod2man
 %attr(755,root,root) %{_bindir}/pod2text
+%attr(755,root,root) %{_bindir}/podselect
 %attr(755,root,root) %{_bindir}/pstruct
 %attr(755,root,root) %{_bindir}/s2p
 %attr(755,root,root) %{_bindir}/splain
This page took 0.057164 seconds and 4 git commands to generate.