]> git.pld-linux.org Git - packages/perl-libwww.git/blobdiff - perl-libwww.spec
- updated to 5.800, added generic URL
[packages/perl-libwww.git] / perl-libwww.spec
index 644ac6e7d22f120a5ccfea8f00713311666028dd..fd9a877ae986f57b4a39459ea85e037457f27e6a 100644 (file)
@@ -1,68 +1,80 @@
-%define        perl_sitelib    %(eval "`perl -V:installsitelib`"; echo $installsitelib)
-
+#
+# Conditional build:
+%bcond_with    tests   # perform "make test"
+#
+%include       /usr/lib/rpm/macros.perl
+%define        pdir    WWW
+%define        pnam    libwww-perl
+Summary:       libwww-perl - a simple and consistent API to the World-Wide Web
+Summary(pl):   libwww-perl - prosty i logiczny API do WWW
 Name:          perl-libwww
-Version:       5.44
-Release:       2
-Vendor:                Mailing List <libwww-perl@ics.uci.edu>
-Source:         libwww-perl-%{version}.tar.gz
-Group:         Utilities/Text
-Copyright:     Free
-Summary:       Perl LIBWWW module
-Summary(pl):   Modu³ perla LIBWWW
-BuildRoot:     /tmp/%{name}-%{version}-root
-BuildRequires: perl >= 5.005_61
+Version:       5.800
+Release:       1
+# same as perl
+License:       GPL v1+ or Artistic
+Group:         Development/Languages/Perl
+Source0:       http://www.cpan.org/modules/by-module/WWW/%{pnam}-%{version}.tar.gz
+# Source0-md5: 8e3361f5682e0deea59f349b17c5ec1c
+URL:           http://search.cpan.org/dist/libwww-perl/
+BuildRequires: perl(Net::FTP) >= 2.58
 BuildRequires: perl-Digest-MD5
-BuildRequires: perl-HTML-Parser
-Requires:      perl
-Requires:      %{perl_sitelib}
-Requires:      perl-HTML-Parser 
-Requires:      perl-MIME-Base64
-Requires:      perl-Digest-MD5 
-Requires:      perl-libnet 
+BuildRequires: perl-HTML-Parser >= 3.33
+BuildRequires: perl-MIME-Base64 >= 2.1
+BuildRequires: perl-URI >= 1.10
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: perl-libnet
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+Obsoletes:     perl-libwww-perl
+
+# modules not always required
+%define        _noautoreq 'perl(HTML::Parse)' 'perl(HTML::FormatPS)' 'perl(HTML::FormatText)' 'perl(HTTP::GHTTP)' 'perl(IO::Socket::SSL)' 'perl(Mail::Internet)' 'perl(Authen::NTLM)'
 
 %description
-Libwww-perl is a collection of Perl modules which provides a simple
-and consistent programming interface (API) to the World-Wide Web.
+The libwww-perl collection is a set of Perl modules which provides a
+simple and consistent application programming interface to the World-Wide
+Web. The main focus of the library is to provide classes and functions
+that allow you to write WWW clients. The library also contain modules
+that are of more general use and even classes that help you implement
+simple HTTP servers.
 
 %description -l pl
-Libwww-perl jest kolekcj± modu³ów Perla, które dostaczaj± proste
-API do WWW (World-Wide Web).
+libwww-perl jest zbiorem modu³ów Perla, dostarczaj±cych prostego API
+do WWW (World-Wide Web). G³ównym zadaniem biblioteki jest udostêpnianie
+klas i funkcji, pozwalaj±cych na pisanie klientów WWW. Biblioteka zawiera
+tak¿e modu³y bardziej ogólnego przeznaczenia, a nawet klasy, pozwalaj±ce
+na implementacjê prostego serwera HTTP.
 
 %prep
 %setup -q -n libwww-perl-%{version}
 
 %build
-perl Makefile.PL
-make OPTIMIZE="$RPM_OPT_FLAGS"
+%{__perl} Makefile.PL </dev/null \
+       INSTALLDIRS=vendor
+%{__make}
+
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{perl_archlib}
 
-make install \
+%{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-(  cd $RPM_BUILD_ROOT%{perl_sitearch}/auto/libwww-perl/
-   sed -e "s#$RPM_BUILD_ROOT##" .packlist >.packlist.new
-   mv .packlist.new .packlist
-)
-      
-gzip -9nf README TODO $RPM_BUILD_ROOT%{_mandir}/man{1,3}/*
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README.gz TODO.gz
-%{perl_sitelib}/*.pm
-%{perl_sitelib}/*.pod
-%{perl_sitelib}/Bundle/*
-%{perl_sitelib}/File/*
-%{perl_sitelib}/HTTP/*
-%{perl_sitelib}/LWP
-%{perl_sitelib}/WWW
-%{perl_sitearch}/auto/libwww-perl
+%doc README*
+%{perl_vendorlib}/*.pm
+%{perl_vendorlib}/File/*
+%{perl_vendorlib}/HTML/*
+%{perl_vendorlib}/HTTP/*
+%{perl_vendorlib}/Net/*
+%{perl_vendorlib}/LWP
+%{perl_vendorlib}/WWW/*
 %attr(755,root,root) %{_bindir}/*
-
-%{_mandir}/man*/*
+%{_mandir}/man1/*
+%{_mandir}/man3/[!B]*
This page took 0.03492 seconds and 4 git commands to generate.