]> git.pld-linux.org Git - packages/perl-XML-LibXML.git/blobdiff - perl-XML-LibXML.spec
- license unification, cosmetics
[packages/perl-XML-LibXML.git] / perl-XML-LibXML.spec
index 418a59bfb035ac0da3532d507975ae7f7995e079..aefbab5c3dd102dbc8892d1ae44b8ef8348c8b80 100644 (file)
@@ -1,58 +1,47 @@
 #
 # Conditional build:
-# _with_tests - perform "make test"
+%bcond_without tests   # do not perform "make test"
+#
+# TODO:
+# - add pod files to spec
 #
 %include       /usr/lib/rpm/macros.perl
 %define                pdir    XML
 %define                pnam    LibXML
-Summary:       XML::LibXML Perl module
-Summary(cs):   Modul XML::LibXML pro Perl
-Summary(da):   Perlmodul XML::LibXML
-Summary(de):   XML::LibXML Perl Modul
-Summary(es):   Módulo de Perl XML::LibXML
-Summary(fr):   Module Perl XML::LibXML
-Summary(it):   Modulo di Perl XML::LibXML
-Summary(ja):   XML::LibXML Perl ¥â¥¸¥å¡¼¥ë
-Summary(ko):   XML::LibXML ÆÞ ¸ðÁÙ
-Summary(no):   Perlmodul XML::LibXML
-Summary(pl):   Modu³ Perla XML::LibXML
-Summary(pt):   Módulo de Perl XML::LibXML
-Summary(pt_BR):        Módulo Perl XML::LibXML
-Summary(ru):   íÏÄÕÌØ ÄÌÑ Perl XML::LibXML
-Summary(sv):   XML::LibXML Perlmodul
-Summary(uk):   íÏÄÕÌØ ÄÌÑ Perl XML::LibXML
-Summary(zh_CN):        XML::LibXML Perl Ä£¿é
+Summary:       XML::LibXML - interface to the GNOME libxml2 library
+Summary(pl):   XML::LibXML - interfejs do biblioteki libxml2 z GNOME
 Name:          perl-%{pdir}-%{pnam}
-%define                _ver    1.54_3
-Version:       %(echo %{_ver} | sed 's:_:\.:')
-Release:       3
-License:       GPL
+Version:       1.58
+Release:       1
+# same as perl
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-#Source0:      http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
-Source0:       http://www.cpan.org/authors/id/P/PH/PHISH/%{pdir}-%{pnam}-%{_ver}.tar.gz
-Patch0:                %{name}-Makefile.patch
-BuildRequires: libxml2-devel >= 2.4.8
+Source0:       http://www.cpan.org/authors/id/P/PH/PHISH/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 4691fc436e5c0f22787f5b4a54fc56b0
+BuildRequires: gdome2-devel >= 0.7.3
+BuildRequires: libxml2-devel >= 2.5.10
 BuildRequires: perl-XML-LibXML-Common
 BuildRequires: perl-XML-NamespaceSupport >= 1.07
 BuildRequires: perl-XML-SAX >= 0.11
-BuildRequires: perl-devel >= 5.6.1
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: pkgconfig
 BuildRequires: rpm-perlprov >= 4.1-13
-Requires:      libxml2 >= 2.4.8
+Requires:      libxml2 >= 2.5.10
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 This module implements much of the DOM Level 2 API as an interface to
-the Gnome libxml2 library. This makes it a fast and highly capable
+the GNOME libxml2 library. This makes it a fast and highly capable
 validating XML parser library, as well as a high performance DOM.
 
 %description -l pl
 Ten modu³ to implementacja wiêkszo¶ci API DOM Level 2 jako interfejsu
-do biblioteki Gnome libxml2. Daje to szybki i o du¿ych mo¿liwo¶ciach
-parser sprawdzaj±cy poprawno¶æ XML, a tak¿e wysoko wydajny DOM.
+do biblioteki GNOME libxml2. Daje to szybki i o du¿ych mo¿liwo¶ciach
+parser sprawdzaj±cy poprawno¶æ XML-a, a tak¿e wysoko wydajny DOM.
 
 %package SAX
-Summary:       XML::LibXML::SAX perl module
-Summary(pl):   Modu³ perla XML::LibXML::SAX
+Summary:       XML::LibXML::SAX Perl module - XML::LibXML direct SAX parser
+Summary(pl):   Modu³ Perla XML::LibXML::SAX - bezpo¶redni parser SAX z XML::LibXML
 Group:         Development/Languages/Perl
 Requires:      %{name} = %{version}
 
@@ -71,23 +60,25 @@ parsowanie oparte na strumieniach jest bardzo prymitywne i wymaga
 wiele pracy, aby umo¿liwiæ strumieniowe parsowanie SAX2.
 
 %prep
-%setup -q -n %{pdir}-%{pnam}-%{_ver}
-%patch0 -p1
+%setup -q -n %{pdir}-%{pnam}-%{version}
 
 %build
+SKIP_SAX_INSTALL=true;
+export SKIP_SAX_INSTALL
+
 %{__perl} Makefile.PL \
-       INSTALLDIRS=vendor 
-%{__make} OPTIMIZE="%{rpmcflags}"
+       INSTALLDIRS=vendor
+%{__make} \
+       OPTIMIZE="%{rpmcflags}"
 
-# dtd test fails for unknown reason
-%{?_with_tests:%{__make} test}
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
-
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 install example/{*.pl,*.xml,*.dtd,*.xhtml} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
@@ -101,24 +92,26 @@ rm -rf $RPM_BUILD_ROOT
 
 %post SAX
 umask 022
-perl -MXML::SAX -e "XML::SAX->add_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
+%{__perl} -MXML::SAX -e "XML::SAX->add_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
 
 %preun SAX
-umask 022
-perl -MXML::SAX -e "XML::SAX->remove_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
+if [ "$1" = "0" ]; then
+       umask 022
+       %{__perl} -MXML::SAX -e "XML::SAX->remove_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
+fi
 
 %files
 %defattr(644,root,root,755)
 %doc Changes README
 %{perl_vendorarch}/XML/LibXML.pm
-%{perl_vendorarch}/XML/LibXML/[^S]*.pm
+%{perl_vendorarch}/XML/LibXML/[!S]*.pm
 %{perl_vendorarch}/auto/XML/LibXML/LibXML.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/XML/LibXML/LibXML.so
 %{_mandir}/man3/XML::LibXML.3pm*
-%{_mandir}/man3/XML::LibXML::[^S]*
+%{_mandir}/man3/XML::LibXML::[!S]*
 %dir %{_examplesdir}/%{name}-%{version}
 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/x*.pl
-%{_examplesdir}/%{name}-%{version}/[^x]*
+%{_examplesdir}/%{name}-%{version}/[!x]*
 
 %files SAX
 %defattr(644,root,root,755)
This page took 0.031465 seconds and 4 git commands to generate.