]> git.pld-linux.org Git - packages/perl-Tk.git/blobdiff - perl-Tk.spec
- fixed bcond
[packages/perl-Tk.git] / perl-Tk.spec
index 94ae23e80996ab27f2c47f78ad9557d7c0cabb45..bbc414395ed6ed39c91883b482c689ea53050ac4 100644 (file)
@@ -1,46 +1,37 @@
-# 
+#
 # TODO:
 # - move *license* files to %%docdir
 # - better summaries / descriptions
 # - do something with the demos (AAArgh!)
 #
+# Conditional build:
+%bcond_with    tests   # perform "make test"
+                       # require valid DISPLAY
+#
 %include       /usr/lib/rpm/macros.perl
 %define        pdir    Tk
 %define        pnam    Tk
-Summary:       Tk Perl module
-Summary(cs):   Modul Tk pro Perl
-Summary(da):   Perlmodul Tk
-Summary(de):   Tk Perl Modul
-Summary(es):   Módulo de Perl Tk
-Summary(fr):   Module Perl Tk
-Summary(it):   Modulo di Perl Tk
-Summary(ja):   Tk Perl ¥â¥¸¥å¡¼¥ë
-Summary(ko):   Tk ÆÞ ¸ðÁÙ
-Summary(no):   Perlmodul Tk
-Summary(pl):   Modu³ Perla Tk
-Summary(pt):   Módulo de Perl Tk
-Summary(pt_BR):        Módulo Perl Tk
-Summary(ru):   íÏÄÕÌØ ÄÌÑ Perl Tk
-Summary(sv):   Tk Perlmodul
-Summary(uk):   íÏÄÕÌØ ÄÌÑ Perl Tk
-Summary(zh_CN):        Tk Perl Ä£¿é
+Summary:       Tk - a graphical user interface toolkit for Perl
+Summary(pl):   Tk - toolkit graficznego interfejsu u¿ytkownika dla Perla
 Name:          perl-Tk
-Version:       800.024
-Release:       2
-License:       GPL
+Version:       800.025
+Release:       3
+# same as perl (except pTk dir - BSD-like)
+License:       GPL v1+ or Artistic, parts BSD-like
 Group:         Development/Languages/Perl
-Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
+Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}%{version}.tar.gz
+# Source0-md5: 9907e608addd2e3f004d45f13dfb181e
 Patch0:                %{name}-paths.patch
 Patch1:                %{name}-misc.patch
 Patch2:                %{name}-man_section.patch
 BuildRequires: XFree86-devel
 BuildRequires: perl-Tie-Watch
-BuildRequires: perl-devel >= 5.6.1
+BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
 Provides:      perl(Tk::LabRadio)
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreq      'perl(Plot)'
+%define                _noautoreq      'perl(Plot)' 'perl(WidgetDemo)'
 
 %description
 This package gives you the ability to develop perl applications using
@@ -58,16 +49,20 @@ wykorzystaniem GUI Tk.
 
 %build
 %{__perl} Makefile.PL \
-       INSTALLDIRS=vendor 
+       INSTALLDIRS=vendor \
+       X11LIB=/usr/X11R6/%{_lib}
 %{__perl} -pi -e 's/<default.h>/"default.h"/g' pTk/tixDef.h
-%{__make} OPTIMIZE="%{rpmcflags}"
+%{__make} \
+       OPTIMIZE="%{rpmcflags}"
+
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/Tk
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
-
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 rm -f  $RPM_BUILD_ROOT%{perl_vendorarch}/{auto/Tk/.packlist,Tk/reindex.pl} \
        $RPM_BUILD_ROOT%{_mandir}/man3/Tie::Watch.3pm \
        $RPM_BUILD_ROOT%{perl_vendorarch}/Tk/*.pod
This page took 0.031671 seconds and 4 git commands to generate.