]> git.pld-linux.org Git - packages/perl-Socket6.git/blobdiff - perl-Socket6.spec
- updated URL
[packages/perl-Socket6.git] / perl-Socket6.spec
index e9936257c0713fb5094eb345297da530b74145de..81415067dc82514bae80c111b2e5f20a22ce4b2d 100644 (file)
@@ -1,47 +1,57 @@
-%include       /usr/lib/rpm/macros.perl
-Summary:       perl-Socket6 perl module
-Summary(pl):   Modu³ perla perl-Socket6
+#
+# Conditional build:
+%bcond_without tests   # unit tests
+#
+%define                pdir    Socket6
+%define                pnam    Socket6
+Summary:       Socket6 Perl module - IPv6-related part of the C socket.h defines and structure manipulators
+Summary(pl.UTF-8):     Moduł Perla Socket6 - definicje i operacje na strukturach socket.h związanych z IPv6
 Name:          perl-Socket6
-Version:       0.10
-Release:       1
-License:       GPL
+Version:       0.29
+Release:       6
+License:       BSD-like
 Group:         Development/Languages/Perl
-Group(de):     Entwicklung/Sprachen/Perl
-Group(pl):     Programowanie/Jêzyki/Perl
-Source0:       ftp://ftp.perl.org/pub/CPAN/modules/by-module/Socket6/Socket6-%{version}.tar.gz
-BuildRequires: rpm-perlprov >= 3.0.3-16
-BuildRequires: perl >= 5.6
-%requires_eq   perl
-Requires:      %{perl_sitearch}
+Source0:       http://www.cpan.org/modules/by-module/Socket6/%{pnam}-%{version}.tar.gz
+# Source0-md5: dab4b2dcc76f81b8bedea72d8fd1bc28
+URL:           https://metacpan.org/dist/Socket6
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: rpmbuild(macros) >= 1.745
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-perl-Socket6 is a module that implements a IPv6 API for Perl programs.
+The Socket6 module provides glue routines to the various IPv6
+functions.
 
-%description -l pl
-perl-Socket6 jest modu³em umo¿liwiaj±cych dostêp do us³ug IPv6 z
-poziomu programów perla.
+%description -l pl.UTF-8
+Moduł Socket6 udostępnia perlowy interfejs do różnych funkcji IPv6.
 
 %prep
-%setup -q -n Socket6-%{version}
+%setup -q -n %{pnam}-%{version}
 
 %build
-perl Makefile.PL
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
 %{__make}
+pod2man --section=3pm Socket6.pm >Socket6.3pm
+
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_mandir}/man3
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
-
-gzip -9nf ChangeLog README 
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+install Socket6.3pm $RPM_BUILD_ROOT%{_mandir}/man3
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz
-%{perl_sitearch}/Socket6.pm
-%{perl_sitearch}/auto/Socket6/Socket6.so
-%{perl_sitearch}/auto/Socket6/Socket6.bs
+%doc ChangeLog README
+%{perl_vendorarch}/Socket6.pm
+%dir %{perl_vendorarch}/auto/Socket6
+%attr(755,root,root) %{perl_vendorarch}/auto/Socket6/Socket6.so
+%{_mandir}/man3/Socket6.3pm*
This page took 0.078029 seconds and 4 git commands to generate.