]> git.pld-linux.org Git - packages/perl-PerlIO-utf8_strict.git/blobdiff - perl-PerlIO-utf8_strict.spec
perl 5.38.0 rebuild
[packages/perl-PerlIO-utf8_strict.git] / perl-PerlIO-utf8_strict.spec
index 4e9f82e494611df3c874ad04834f47b54234ebd6..7da8506503ca71abd74b3177d90c81ae227e0a1e 100644 (file)
@@ -1,54 +1,61 @@
 #
 # Conditional build:
-%bcond_without tests   # do not perform "make test"
+%bcond_without tests   # unit tests
 #
-%include       /usr/lib/rpm/macros.perl
 %define                pdir    PerlIO
 %define                pnam    utf8_strict
-Summary:       PerlIO::utf8_strict - Fast and correct UTF-8 IO
+Summary:       PerlIO::utf8_strict - fast and correct UTF-8 I/O
+Summary(pl.UTF-8):     PerlIO::utf8_strict - szybkie i poprawne we/wy UTF-8
 Name:          perl-%{pdir}-%{pnam}
-Version:       0.005
-Release:       4
+Version:       0.010
+Release:       2
 # same as perl
 License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Source0:       http://www.cpan.org/modules/by-module/PerlIO/%{pdir}-%{pnam}-%{version}.tar.gz
-# Source0-md5: 6b971926fa3dbd2af494753004a279a0
-URL:           http://search.cpan.org/dist/PerlIO-utf8_strict/
+Source0:       https://www.cpan.org/modules/by-module/PerlIO/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: d90ca967f66e05ad9221c79060868346
+URL:           https://metacpan.org/dist/PerlIO-utf8_strict
+%if %{with tests}
+BuildRequires: perl-Test-Exception
+BuildRequires: perl-Test-Simple >= 0.88
+%endif
 BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
+BuildRequires: rpmbuild(macros) >= 1.745
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-This module provides a fast and correct UTF-8 PerlIO layer.
-Unlike perl's default :utf8 layer it checks the input for correctness.
+This module provides a fast and correct UTF-8 PerlIO layer. Unlike
+Perl's default :utf8 layer it checks the input for correctness.
+
+%description -l pl.UTF-8
+Ten moduł zapewnia warstwę PerlIO do szybkiego i poprawnego UTF-8. W
+przeciwieństwie do domyślnej warstwy :utf8 Perla, sprawdza wejście pod
+kątem poprawności.
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
 
 %build
-%{__perl} Build.PL \
-       destdir=$RPM_BUILD_ROOT \
-       installdirs=vendor
-
-./Build \
-       CC="%{__cc}" \
-       OPTIMIZE="%{rpmcflags}"
+%{__perl} Makefile.PL \
+        INSTALLDIRS=vendor
+%{__make}
 
-%{?with_tests:./Build test}
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-./Build install
+%{__make} install \
+        DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc Changes
+%doc Changes README
 %{perl_vendorarch}/PerlIO/utf8_strict.pm
 %dir %{perl_vendorarch}/auto/PerlIO/utf8_strict
-%attr(755,root,root) %{perl_vendorarch}/auto/PerlIO/utf8_strict/*.so
-%{_mandir}/man3/*
+%attr(755,root,root) %{perl_vendorarch}/auto/PerlIO/utf8_strict/utf8_strict.so
+%{_mandir}/man3/PerlIO::utf8_strict.3pm*
This page took 0.156039 seconds and 4 git commands to generate.