]> git.pld-linux.org Git - packages/perl-Parse-RecDescent.git/blobdiff - perl-Parse-RecDescent.spec
- up to 1.967009
[packages/perl-Parse-RecDescent.git] / perl-Parse-RecDescent.spec
index 50fb6b4e09ee7f4d4e0d0103f13ae7a67e83bca2..52138d38ddf1db8f4bed30b42ff0e59e1fe9dfca 100644 (file)
@@ -1,60 +1,90 @@
-%define        pdir    Parse
-%define        pnam    RecDescent
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
+#
 %include       /usr/lib/rpm/macros.perl
-Summary:       Perl Parse::RecDescent module
-Summary(pl):   Modu³ Perla Parse::RecDescent
+%define                pdir    Parse
+%define                pnam    RecDescent
+Summary:       Parse::RecDescent - generate recursive-descent parsers
+Summary(pl.UTF-8):     Parse::RecDescent - generowanie zmniejszających rekurencyjnie analizatorów
 Name:          perl-Parse-RecDescent
-Version:       1.80
-Release:       5
-
-License:       Perl Artistic License
+Version:       1.967009
+Release:       1
+License:       Artistic
 Group:         Development/Languages/Perl
-Group(cs):     Vývojové prostøedky/Programovací jazyky/Perl
-Group(de):     Entwicklung/Sprachen/Perl
-Group(es):     Desarrollo/Lenguajes/Perl
-Group(fr):     Development/Langues/Perl
-Group(ja):     ³«È¯/¸À¸ì/Perl
-Group(pl):     Programowanie/Jêzyki/Perl
-Group(pt):     Desenvolvimento/Linguagens/Perl
-Group(ru):     òÁÚÒÁÂÏÔËÁ/ñÚÙËÉ/Perl
-Source0:       ftp://ftp.perl.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
-Patch0:                %{name}-paths.patch
-BuildRequires: rpm-perlprov >= 3.0.3-18
-BuildRequires: perl-devel >= 5.6.1
-Requires:      perl
+Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 6dab60d44451a9f57a261d1b5358753c
+URL:           http://search.cpan.org/dist/Parse-RecDescent/
+BuildRequires: perl-Text-Balanced
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
+# these versions included own copy of Text::Balanced
+BuildConflicts:        perl-Parse-RecDescent < 1.92
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-Obsoletes:     perl-Text-Balanced
 
-%define                _noautoreq      "perl(Calc)"
+%define                _noautoreq      'perl(Calc)'
 
 %description
-Perl Parse::RecDescent module.
+RecDescent incrementally generates top-down recursive-descent text
+parsers from simple yacc-like grammar specifications. It provides:
+- Regular expressions or literal strings as terminals (tokens),
+- Multiple (non-contiguous) productions for any rule,
+- Repeated, optional and alternate subrules within productions,
+- Late-bound (run-time dispatched) subrules,
+- Full access to Perl within actions specified as part of the grammar,
+- Simple automated error reporting during parser generation and
+  parsing,
+- The ability to commit to, uncommit to, or reject particular
+  productions during a parse,
+- Incremental extension of the parsing grammar (even during a parse),
+- Precompilation of parser objects,
+- User-definable reduce-reduce conflict resolution via "scoring" of
+  matching productions.
 
-%description -l pl
-Modu³ Perla Parse::RecDescent.
+%description -l pl.UTF-8
+RecDescent generuje przyrostowo zstępujące, zmniejszające
+rekurencyjnie analizatory tekstu w oparciu o prostą specyfikację
+gramatyki, podobną do używanej przez yacca. Udostępnia on:
+- Wyrażenia regularne i łańcuchy literałów jako terminale (tokeny),
+- Wielokrotną (nieciągłą) produkcję dla każdej reguły,
+- Powtarzane, opcjonalne i alternatywne podreguły w obrębie produkcji,
+- Podreguły późnego wiązania (wysyłane w chwili uruchomienia),
+- Pełen dostęp do Perla w obrębie akcji określonych jako część
+  gramatyki,
+- Proste, zautomatyzowane sygnalizowanie błędów podczas generacji
+  analizatora i podczas analizy,
+- Możliwość zatwierdzenia, cofnięcia oraz odrzucania poszczególnych
+  produkcji podczas analizy,
+- Przyrostowe rozszerzanie gramatyki podlegającej analizie (nawet
+  podczas samej analizy),
+- Prekompilację obiektów analizatora,
+- Definiowalne przez użytkownika rozpoznawanie konfliktów
+  "reduce-reduce" poprzez ocenianie dopasowania produkcji.
 
 %prep
-%setup -q -n Parse-RecDescent-%{version}
-%patch0 -p1
+%setup -q -n %{pdir}-%{pnam}-%{version}
 
 %build
-perl Makefile.PL
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
 %{__make}
 
+%{?with_tests:%{__make} test}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} pure_install \
+       DESTDIR=$RPM_BUILD_ROOT
 
-gzip -9nf README Changes
+rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Parse/RecDescent/.packlist
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz
-%{perl_sitelib}/Parse/*
-%{perl_sitelib}/Text/*
+%doc README Changes
+%{perl_vendorlib}/Parse/*.pm
 %{_mandir}/man3/*
This page took 0.027812 seconds and 4 git commands to generate.