]> git.pld-linux.org Git - packages/perl-Net-DNS.git/blobdiff - perl-Net-DNS.spec
- missing dir, missing br for test
[packages/perl-Net-DNS.git] / perl-Net-DNS.spec
index a4d10298443127b5d8124f4e4dcab476eb81b7fb..654d1827d36829e3ddef19496cc750a756e0523c 100644 (file)
@@ -1,64 +1,91 @@
 #
 # Conditional build:
-# _without_tests - do not perform "make test"
+%bcond_without tests           # do not perform "make test"
+%bcond_without libresolv       # link against libresolv (creates architecture-dependent package)
+#
 %include       /usr/lib/rpm/macros.perl
-%define        pdir    Net
-%define        pnam    DNS
-Summary:       Net::DNS - Perl interface to the DNS resolver.
-Summary(pl):   Net::DNS - interfejs do resolvera DNS.
+%define                pdir    Net
+%define                pnam    DNS
+Summary:       Net::DNS - Perl interface to the DNS resolver
+Summary(pl):   Net::DNS - interfejs perlowy do resolvera DNS
 Name:          perl-Net-DNS
-Version:       0.28
-Release:       2
-License:       GPL/Artistic
+Version:       0.53
+Release:       2.1
+# same as perl
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Source0:       ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
-Patch0:                %{name}-unreachable_ns.patch
-BuildRequires: perl >= 5.6
-%if %{?_without_tests:0}%{!?_without_tests:1}
-BuildRequires: perl-Digest-MD5 >= 2.12
+Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 404797359373d4df1a025458ab1415f7
+BuildRequires: perl-devel >= 1:5.8.0
+%if %{with tests}
+BuildRequires: perl-Digest-BubbleBabble
 BuildRequires: perl-Digest-HMAC >= 1.00
+BuildRequires: perl-Digest-MD5 >= 2.12
+BuildRequires: perl-IO-Socket-INET6 >= 2.51
 BuildRequires: perl-MIME-Base64 >= 2.11
-BuildRequires: perl-Test-Simple >= 0.18
+BuildRequires: perl-Net-IP >= 1.20
+BuildRequires: perl-Test-Pod
 %endif
-BuildRequires: rpm-perlprov >= 3.0.3-16
+BuildRequires: rpm-perlprov >= 4.1-13
+%if %{without libresolv}
 BuildArch:     noarch
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Net::DNS is a DNS resolver implemented in Perl.  It allows the programmer
-to perform nearly any type of DNS query from a Perl script.
+Net::DNS is a DNS resolver implemented in Perl. It allows the
+programmer to perform nearly any type of DNS query from a Perl script.
 
 %description -l pl
-Net::DNS jest resolverem DNS, zaimplementowanym w Perlu.  Pozwala
+Net::DNS jest resolverem DNS, zaimplementowanym w Perlu. Pozwala
 programi¶cie na wykonanie niemal ka¿dego typu zapytania DNS ze skryptu
 Perla.
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
-%patch0 -p1
 
 %build
-perl Makefile.PL
-%{__make}
+%{__perl} Makefile.PL </dev/null \
+       --%{!?with_libresolv:no-}xs \
+       --no-online-tests \
+       INSTALLDIRS=vendor
+%{__make} \
+       %{?with_libresolv: OPTIMIZE="%{rpmcflags}"}
 
-%{!?_without_tests:%{__make} test}
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
-
+%{__make} pure_install \
+       DESTDIR=$RPM_BUILD_ROOT
 install demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -a contrib $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
+# get rid of pod documentation
+%if %{with libresolv}
+rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/Net/DNS/*.pod
+%else
+rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/Net/DNS/*.pod
+%endif
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
 %doc Changes README TODO
-%{perl_sitelib}/Net/DNS.pm
-%{perl_sitelib}/Net/DNS
+%if %{with libresolv}
+%{perl_vendorarch}/Net/DNS.pm
+%{perl_vendorarch}/Net/DNS
+%{perl_vendorarch}/auto/Net/DNS/DNS.bs
+%dir %{perl_vendorarch}/auto/Net/DNS
+%attr(755,root,root) %{perl_vendorarch}/auto/Net/DNS/DNS.so
+%else
+%{perl_vendorlib}/Net/DNS.pm
+%{perl_vendorlib}/Net/DNS
+%endif
+
 %{_mandir}/man3/*
 %{_examplesdir}/%{name}-%{version}
This page took 0.058459 seconds and 4 git commands to generate.