]> git.pld-linux.org Git - packages/perl-Net-DNS.git/blobdiff - perl-Net-DNS.spec
- tabs in preamble
[packages/perl-Net-DNS.git] / perl-Net-DNS.spec
index fb63667b1129bed3a34d6e2ef06b1fff2929f704..4b78c98dbef0843582a65b174dc054a861ac86a1 100644 (file)
@@ -1,3 +1,5 @@
+# TODO
+# - pass CC
 #
 # Conditional build:
 %bcond_without tests           # do not perform "make test"
@@ -7,16 +9,18 @@
 %define                pdir    Net
 %define                pnam    DNS
 Summary:       Net::DNS - Perl interface to the DNS resolver
-Summary(pl):   Net::DNS - interfejs perlowy do resolvera DNS
+Summary(pl.UTF-8):     Net::DNS - interfejs perlowy do resolvera DNS
 Name:          perl-Net-DNS
 Version:       0.53
-Release:       2
+Release:       3
 # same as perl
 License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
 # Source0-md5: 404797359373d4df1a025458ab1415f7
+URL:           http://search.cpan.org/dist/Net-DNS/
 BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: sed >= 4.0
 %if %{with tests}
 BuildRequires: perl-Digest-BubbleBabble
 BuildRequires: perl-Digest-HMAC >= 1.00
@@ -25,10 +29,9 @@ BuildRequires:       perl-IO-Socket-INET6 >= 2.51
 BuildRequires: perl-MIME-Base64 >= 2.11
 BuildRequires: perl-Net-IP >= 1.20
 BuildRequires: perl-Test-Pod >= 0.95
-BuildRequires: perl-Test-Simple >= 0.18
 %endif
 BuildRequires: rpm-perlprov >= 4.1-13
-%if %{without libresolv}
+%if !%{with libresolv}
 BuildArch:     noarch
 %endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -37,21 +40,23 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Net::DNS is a DNS resolver implemented in Perl. It allows the
 programmer to perform nearly any type of DNS query from a Perl script.
 
-%description -l pl
+%description -l pl.UTF-8
 Net::DNS jest resolverem DNS, zaimplementowanym w Perlu. Pozwala
-programi¶cie na wykonanie niemal ka¿dego typu zapytania DNS ze skryptu
+programiście na wykonanie niemal każdego typu zapytania DNS ze skryptu
 Perla.
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
 
+%{__sed} -i -e 's#/''usr/local/bin/perl#/''usr/bin/perl#' demo/* contrib/*
+
 %build
 %{__perl} Makefile.PL </dev/null \
-       --%{!?with_libresolv:no-}xs \
+       %{!?with_libresolv:--no-xs} \
        --no-online-tests \
        INSTALLDIRS=vendor
 %{__make} \
-       %{?with_libresolv: OPTIMIZE="%{rpmcflags}"}
+       %{?with_libresolv:OPTIMIZE="%{rpmcflags}"}
 
 %{?with_tests:%{__make} test}
 
@@ -61,7 +66,7 @@ install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %{__make} pure_install \
        DESTDIR=$RPM_BUILD_ROOT
-install demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+cp -a demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -a contrib $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 # get rid of pod documentation
@@ -81,6 +86,7 @@ rm -rf $RPM_BUILD_ROOT
 %{perl_vendorarch}/Net/DNS.pm
 %{perl_vendorarch}/Net/DNS
 %{perl_vendorarch}/auto/Net/DNS/DNS.bs
+%dir %{perl_vendorarch}/auto/Net/DNS
 %attr(755,root,root) %{perl_vendorarch}/auto/Net/DNS/DNS.so
 %else
 %{perl_vendorlib}/Net/DNS.pm
This page took 0.077138 seconds and 4 git commands to generate.