]> git.pld-linux.org Git - packages/perl-Net-DNS.git/blobdiff - perl-Net-DNS.spec
- tabs in preamble
[packages/perl-Net-DNS.git] / perl-Net-DNS.spec
index 6f831c818e439e5d4cdbdc89d22f1821444a9c71..4b78c98dbef0843582a65b174dc054a861ac86a1 100644 (file)
@@ -1,50 +1,97 @@
+# TODO
+# - pass CC
+#
+# Conditional build:
+%bcond_without tests           # do not perform "make test"
+%bcond_without libresolv       # link against libresolv (creates architecture-dependent package)
+#
 %include       /usr/lib/rpm/macros.perl
-Summary:       Net-DNS perl module
-Summary(pl):   Modu³ perla Net-DNS
+%define                pdir    Net
+%define                pnam    DNS
+Summary:       Net::DNS - Perl interface to the DNS resolver
+Summary(pl.UTF-8):     Net::DNS - interfejs perlowy do resolvera DNS
 Name:          perl-Net-DNS
-Version:       0.12
-Release:       6
-License:       GPL
+Version:       0.53
+Release:       3
+# same as perl
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Group(de):     Entwicklung/Sprachen/Perl
-Group(pl):     Programowanie/Jêzyki/Perl
-Source0:       ftp://ftp.perl.org/pub/CPAN/modules/by-module/Net/Net-DNS-%{version}.tar.gz
-BuildRequires: rpm-perlprov >= 3.0.3-16
-BuildRequires: perl >= 5.6
+Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 404797359373d4df1a025458ab1415f7
+URL:           http://search.cpan.org/dist/Net-DNS/
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: sed >= 4.0
+%if %{with tests}
+BuildRequires: perl-Digest-BubbleBabble
+BuildRequires: perl-Digest-HMAC >= 1.00
+BuildRequires: perl-Digest-MD5 >= 2.12
+BuildRequires: perl-IO-Socket-INET6 >= 2.51
+BuildRequires: perl-MIME-Base64 >= 2.11
+BuildRequires: perl-Net-IP >= 1.20
+BuildRequires: perl-Test-Pod >= 0.95
+%endif
+BuildRequires: rpm-perlprov >= 4.1-13
+%if !%{with libresolv}
 BuildArch:     noarch
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Net-DNS - Perl interface to the DNS resolver.
+Net::DNS is a DNS resolver implemented in Perl. It allows the
+programmer to perform nearly any type of DNS query from a Perl script.
 
-%description -l pl
-Net-DNS - interfejs do resolvera DNS.
+%description -l pl.UTF-8
+Net::DNS jest resolverem DNS, zaimplementowanym w Perlu. Pozwala
+programiście na wykonanie niemal każdego typu zapytania DNS ze skryptu
+Perla.
 
 %prep
-%setup -q -n Net-DNS-%{version}
+%setup -q -n %{pdir}-%{pnam}-%{version}
+
+%{__sed} -i -e 's#/''usr/local/bin/perl#/''usr/bin/perl#' demo/* contrib/*
 
 %build
-perl Makefile.PL
-%{__make}
+%{__perl} Makefile.PL </dev/null \
+       %{!?with_libresolv:--no-xs} \
+       --no-online-tests \
+       INSTALLDIRS=vendor
+%{__make} \
+       %{?with_libresolv:OPTIMIZE="%{rpmcflags}"}
+
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
-
-install demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+%{__make} pure_install \
+       DESTDIR=$RPM_BUILD_ROOT
+cp -a demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -a contrib $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
-gzip -9nf Changes README TODO
+# get rid of pod documentation
+%if %{with libresolv}
+rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/Net/DNS/*.pod
+%else
+rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/Net/DNS/*.pod
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc *.gz
-%{perl_sitelib}/Net/DNS.pm
-%{perl_sitelib}/Net/DNS
+%doc Changes README TODO
+%if %{with libresolv}
+%{perl_vendorarch}/Net/DNS.pm
+%{perl_vendorarch}/Net/DNS
+%{perl_vendorarch}/auto/Net/DNS/DNS.bs
+%dir %{perl_vendorarch}/auto/Net/DNS
+%attr(755,root,root) %{perl_vendorarch}/auto/Net/DNS/DNS.so
+%else
+%{perl_vendorlib}/Net/DNS.pm
+%{perl_vendorlib}/Net/DNS
+%endif
+
 %{_mandir}/man3/*
 %{_examplesdir}/%{name}-%{version}
This page took 0.077359 seconds and 4 git commands to generate.