]> git.pld-linux.org Git - packages/perl-Net-DNS.git/blobdiff - perl-Net-DNS.spec
- tabs in preamble
[packages/perl-Net-DNS.git] / perl-Net-DNS.spec
index 31619b099556f9d8c508ac2bcd54b63572434e42..4b78c98dbef0843582a65b174dc054a861ac86a1 100644 (file)
@@ -1,27 +1,33 @@
+# TODO
+# - pass CC
 #
 # Conditional build:
 %bcond_without tests           # do not perform "make test"
-%bcond_with    libresolv       # link against libresolv (creates architecture-dependent package)
+%bcond_without libresolv       # link against libresolv (creates architecture-dependent package)
 #
 %include       /usr/lib/rpm/macros.perl
-%define        pdir    Net
-%define        pnam    DNS
+%define                pdir    Net
+%define                pnam    DNS
 Summary:       Net::DNS - Perl interface to the DNS resolver
-Summary(pl):   Net::DNS - interfejs perlowy do resolvera DNS
+Summary(pl.UTF-8):     Net::DNS - interfejs perlowy do resolvera DNS
 Name:          perl-Net-DNS
-Version:       0.47
-Release:       1
+Version:       0.53
+Release:       3
 # same as perl
 License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
-# Source0-md5: 749a04eb4377e889ed58d004536a9117
+# Source0-md5: 404797359373d4df1a025458ab1415f7
+URL:           http://search.cpan.org/dist/Net-DNS/
 BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: sed >= 4.0
 %if %{with tests}
-BuildRequires: perl-Digest-MD5 >= 2.12
+BuildRequires: perl-Digest-BubbleBabble
 BuildRequires: perl-Digest-HMAC >= 1.00
+BuildRequires: perl-Digest-MD5 >= 2.12
+BuildRequires: perl-IO-Socket-INET6 >= 2.51
 BuildRequires: perl-MIME-Base64 >= 2.11
-BuildRequires: perl-Test-Simple >= 0.18
+BuildRequires: perl-Net-IP >= 1.20
 BuildRequires: perl-Test-Pod >= 0.95
 %endif
 BuildRequires: rpm-perlprov >= 4.1-13
@@ -34,21 +40,23 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Net::DNS is a DNS resolver implemented in Perl. It allows the
 programmer to perform nearly any type of DNS query from a Perl script.
 
-%description -l pl
+%description -l pl.UTF-8
 Net::DNS jest resolverem DNS, zaimplementowanym w Perlu. Pozwala
-programi¶cie na wykonanie niemal ka¿dego typu zapytania DNS ze skryptu
+programiście na wykonanie niemal każdego typu zapytania DNS ze skryptu
 Perla.
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
 
+%{__sed} -i -e 's#/''usr/local/bin/perl#/''usr/bin/perl#' demo/* contrib/*
+
 %build
 %{__perl} Makefile.PL </dev/null \
-       %{?with_libresolv:      --xs} \
-       %{!?with_libresolv:     --no-xs} \
+       %{!?with_libresolv:--no-xs} \
+       --no-online-tests \
        INSTALLDIRS=vendor
 %{__make} \
-       %{?with_libresolv: OPTIMIZE="%{rpmcflags}"}
+       %{?with_libresolv:OPTIMIZE="%{rpmcflags}"}
 
 %{?with_tests:%{__make} test}
 
@@ -56,11 +64,18 @@ Perla.
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
-%{__make} install \
+%{__make} pure_install \
        DESTDIR=$RPM_BUILD_ROOT
-install demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+cp -a demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -a contrib $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
+# get rid of pod documentation
+%if %{with libresolv}
+rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/Net/DNS/*.pod
+%else
+rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/Net/DNS/*.pod
+%endif
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -68,13 +83,14 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc Changes README TODO
 %if %{with libresolv}
-%{perl_vendorarch}/%{pdir}/%{pnam}.pm
-%{perl_vendorarch}/%{pdir}/%{pnam}
-%{perl_vendorarch}/auto/%{pdir}/%{pnam}/%{pnam}.bs
-%attr(755,root,root) %{perl_vendorarch}/auto/%{pdir}/%{pnam}/%{pnam}.so
+%{perl_vendorarch}/Net/DNS.pm
+%{perl_vendorarch}/Net/DNS
+%{perl_vendorarch}/auto/Net/DNS/DNS.bs
+%dir %{perl_vendorarch}/auto/Net/DNS
+%attr(755,root,root) %{perl_vendorarch}/auto/Net/DNS/DNS.so
 %else
-%{perl_vendorlib}/%{pdir}/%{pnam}.pm
-%{perl_vendorlib}/%{pdir}/%{pnam}
+%{perl_vendorlib}/Net/DNS.pm
+%{perl_vendorlib}/Net/DNS
 %endif
 
 %{_mandir}/man3/*
This page took 0.090985 seconds and 4 git commands to generate.