]> git.pld-linux.org Git - packages/perl-Math-VecStat.git/blobdiff - perl-Math-VecStat.spec
use generic url
[packages/perl-Math-VecStat.git] / perl-Math-VecStat.spec
index d07d03ede2add6b5ea9ec96dfeaedc4c3701e3c3..9bb61feea06df46719d48abe8d84cce6fd901218 100644 (file)
@@ -1,36 +1,53 @@
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
+
+%define                pdir    Math
+%define                pnam    VecStat
 %include       /usr/lib/rpm/macros.perl
-%define        pdir    Math
-%define        pnam    VecStat
-Summary:       Math::VecStat perl module
-Summary(pl):   Modu³ perla Math::VecStat
+Summary:       Math::VecStat - some basic statistics on vectors (min,max,average,...)
+Summary(pl.UTF-8):     Math::VecStat - podstawowe statystyki na wektorach (min,max,średnia,...)
 Name:          perl-Math-VecStat
-Version:       0.06
-Release:       1
-License:       GPL
+Version:       0.08
+Release:       2
+# same as perl
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Source0:       ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
-BuildRequires: perl >= 5.6
-BuildRequires: rpm-perlprov >= 3.0.3-16
+Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 3df23fb451f73bb49fd4ea344ba94020
+URL:           http://search.cpan.org/dist/Math-VecStat/
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Math::VecStat perl module.
+This package provides some basic statistics on numerical vectors. All
+the subroutines can take a reference to the vector to be operated on.
+In some cases a copy of the vector is acceptable, but is not
+recommended for efficiency.
 
-%description -l pl
-Modu³ perla Math::VecStat.
+%description -l pl.UTF-8
+Ten pakiet dostarcza kilku podstawowych statystyk na wektorach
+liczbowych. Wszystkie funkcje mogą przyjąć referencję do wektora, na
+którym mają operować. W niektóych przypadkach kopia wektora jest
+akceptowalna, ale nie jest to zalecane ze względu na wydajność.
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
 
 %build
-perl Makefile.PL
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
 %{__make}
 
+%{?with_tests:%{__make} test}
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -38,5 +55,5 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc README
-%{perl_sitelib}/Math/VecStat.pm
+%{perl_vendorlib}/Math/VecStat.pm
 %{_mandir}/man3/*
This page took 0.094116 seconds and 4 git commands to generate.