]> git.pld-linux.org Git - packages/perl-Math-Random.git/blobdiff - perl-Math-Random.spec
- updated to 0.71
[packages/perl-Math-Random.git] / perl-Math-Random.spec
index 7f8fa8df8220435158183946f0d2720f418deb33..30571eb1656fae56df2f174392865a170fe55679 100644 (file)
@@ -1,51 +1,54 @@
 #
 # Conditional build:
-# _without_tests - do not perform "make test"
+%bcond_without tests   # do not perform "make test"
 #
 %include       /usr/lib/rpm/macros.perl
-%define        pdir    Math
-%define        pnam    Random
-Summary:       Math::Random - useful routines and packages with Math::Random/Random
-Summary(pl):   Math::Random - przydatne funkcje i pakiety oparte o Math::Random/Random
+%define                pdir    Math
+%define                pnam    Random
+Summary:       Math::Random - random number generators
+Summary(pl.UTF-8):     Math::Random - generatory liczb losowych
 Name:          perl-Math-Random
-Version:       0.67
+Version:       0.71
 Release:       1
+# same as perl except some C code
 License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
-Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
-# Source0-md5: 021006f39529940ae318c7c105d01a44
-BuildRequires: perl-devel >= 5.8.0
+Source0:       http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 55d7579c670ecd180f71fd157a2d2070
+URL:           http://search.cpan.org/dist/Math-Random/
+BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
-Requires:      perl
-BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Math::Random module contains some routines that may come in handy when
-you want to get some random numbers.
+Math::Random is a Perl port of the C version of randlib, which is
+a suite of routines for generating random deviates.
 
-%description -l pl
-Modu³ Math::Random zawiera trochê procedur, które mog± okazaæ siê pomocne
-przy pracy z liczbami losowymi.
+%description -l pl.UTF-8
+Math::Random jest perlowym portem napisanej w C biblioteki randlib,
+będącej zbiorem procedur do generowania liczb losowych.
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
+mkdir examples
+mv example.pl examples
 
 %build
-%{__perl} Makefile.PL SITEPREFIX=/usr          INSTALLDIR=%{perl_vendorlib} 
-
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
 %{__make}
 
-%{!?_without_tests:%{__make} test}
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-#install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+       DESTDIR=$RPM_BUILD_ROOT \
+       INSTALLDIRS=vendor
 
-#install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+install -d $RPM_BUILD_ROOT%{_examplesdir}
+cp -r examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -53,9 +56,11 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc Changes README MANIFEST
-%{perl_archlib}/Math/Random.pm
-%{perl_archlib}/Math/example.pl
+%{perl_vendorarch}/Math/*.pm
+%dir %{perl_vendorarch}/auto/Math/Random
+%attr(755,root,root) %{perl_vendorarch}/auto/Math/Random/*.so
+%{perl_vendorarch}/auto/Math/Random/*.ix
+%{perl_vendorarch}/auto/Math/Random/*.bs
+%dir %{_examplesdir}/%{name}-%{version}
+%attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
 %{_mandir}/man3/*
-#%dir %{_examplesdir}/%{name}-%{version}
-#%{_examplesdir}/%{name}-%{version}/*.txt
-#%attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
This page took 0.055147 seconds and 4 git commands to generate.