]> git.pld-linux.org Git - packages/perl-Inline.git/blobdiff - perl-Inline.spec
- updated test dependencies
[packages/perl-Inline.git] / perl-Inline.spec
index e9a5994696784b9718f295ee41573b47a35846ab..a9ca7d9f3991a8ebfe174f9862fff8271b0ab8c0 100644 (file)
@@ -1,18 +1,22 @@
 %include       /usr/lib/rpm/macros.perl
-%define        pdir    Inline
-Summary:       Inline perl module
-Summary(pl):   Modu³ perla Inline
+%define                pdir    Inline
+Summary:       Inline Perl module - write Perl subroutines in other programming languages
+Summary(pl.UTF-8):     Moduł Perla Inline - tworzenie funkcji perlowych w innych językach programowania
 Name:          perl-Inline
-Version:       0.42
+Version:       0.50
 Release:       1
 Epoch:         1
-License:       Artistic
+# same as perl (but C-Cookbook is Artistic-only)
+License:       GPL v1+ (except C-Cookbook) or Artistic
 Group:         Development/Languages/Perl
-Source0:       ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
-BuildRequires: perl >= 5.6
+Source0:       http://www.cpan.org/modules/by-module/Inline/%{pdir}-%{version}.tar.gz
+# Source0-md5: cb9377b494819924bddf2de20c90f3ab
+URL:           http://search.cpan.org/dist/Inline/
+BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: perl-Digest-MD5 >= 2.09
-BuildRequires: perl-Parse-RecDescent >= 1.78
-BuildRequires: rpm-perlprov >= 3.0.3-16
+BuildRequires: perl-Parse-RecDescent >= 1.80
+BuildRequires: perl-Test-Warn >= 0.21
+BuildRequires: rpm-perlprov >= 4.1-13
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -20,30 +24,37 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _noautoreq      'perl(of)'
 
 %description
-Inline.pm - Write Perl subroutines in other programming languages.
+The Inline module allows you to put source code from other programming
+languages directly "inline" in a Perl script or module. The code is
+automatically compiled as needed, and then loaded for immediate access
+from Perl.
 
-%description -l pl
-Modu³ Inline.pm - pozwala tworzyæ procedury Perla w innych jêzykach
-programowania.
+%description -l pl.UTF-8
+Moduł Inline pozwala umieszczać kod źródłowy w innych językach
+programowania bezpośrednio wewnątrz skryptu lub modułu perlowego. Kod
+jest w razie potrzeby automatycznie kompilowany, a następnie ładowany
+w celu bezpośredniego dostępu z poziomu Perla.
 
 %package C
-Summary:       Inline::C perl module
-Summary(pl):   Modu³ perla Inline::C
+Summary:       Inline::C Perl module - write Perl subroutines in C
+Summary(pl.UTF-8):     Moduł Perla Inline::C - tworzenie funkcji Perla w C
 Group:         Development/Languages/Perl
-Requires:      %{name} = %{version}
+License:       Artistic
+Requires:      %{name} = %{epoch}:%{version}
 Requires:      gcc
 
 %description C
-Inline::C - Write Perl subroutines in C.
+Inline::C is a module that allows you to write Perl subroutines in C.
 
-%description C -l pl
-Modu³ Inline::C - pozwalaj±cy pisaæ funkcje Perla w C.
+%description C -l pl.UTF-8
+Inline::C to moduł pozwalający pisać funkcje Perla w C.
 
 %prep
 %setup -q -n %{pdir}-%{version}
 
 %build
-echo "y" | perl Makefile.PL
+echo "y" | perl Makefile.PL \
+       INSTALLDIRS=vendor
 %{__make}
 
 %install
@@ -52,23 +63,26 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/*.pod \
+       $RPM_BUILD_ROOT%{perl_vendorlib}/Inline/*.pod
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
 %doc Changes README
-%{perl_sitelib}/Inline.pm
-%{perl_sitelib}/Inline/denter.pm
-%{perl_sitelib}/Inline/Foo.pm
-%{perl_sitelib}/Inline/MakeMaker.pm
-%{perl_sitelib}/auto/Inline
+%{perl_vendorlib}/Inline.pm
+%{perl_vendorlib}/Inline/denter.pm
+%{perl_vendorlib}/Inline/Foo.pm
+%{perl_vendorlib}/Inline/MakeMaker.pm
+%{perl_vendorlib}/auto/Inline
 %{_mandir}/man3/Inline.3pm*
 %{_mandir}/man3/Inline-*.3pm*
 
 %files C
 %defattr(644,root,root,755)
 %doc C/Changes C/README
-%{perl_sitelib}/Inline/C.pm
-%{perl_sitelib}/Inline/C
+%{perl_vendorlib}/Inline/C.pm
+%{perl_vendorlib}/Inline/C
 %{_mandir}/man3/Inline::C*.3pm*
This page took 0.156127 seconds and 4 git commands to generate.