]> git.pld-linux.org Git - packages/perl-IPC-SharedCache.git/blobdiff - perl-IPC-SharedCache.spec
- converted to UTF-8
[packages/perl-IPC-SharedCache.git] / perl-IPC-SharedCache.spec
index 346b04590e20d838a763925c42b7b0f2199c9a8e..c58a8175df90131a12637e7f8204636c4ea72bd2 100644 (file)
@@ -1,39 +1,49 @@
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
+#
 %include       /usr/lib/rpm/macros.perl
-%define        pdir    IPC
-%define        pnam    SharedCache
-Summary:       %{pdir}::%{pnam} perl module
-Summary(pl):   Modu³ perla %{pdir}::%{pnam}
-Name:          perl-%{pdir}-%{pnam}
+%define                pdir    IPC
+%define                pnam    SharedCache
+Summary:       IPC::SharedCache - manage a cache in SysV IPC shared memory
+Summary(pl.UTF-8):   IPC::SharedCache - zarządzanie pamięcią podręczną w pamięci dzielonej SysV
+Name:          perl-IPC-SharedCache
 Version:       1.3
-Release:       1
-License:       GPL
+Release:       6
+License:       GPL v2+
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
-BuildRequires: rpm-perlprov >= 3.0.3-16
-BuildRequires: perl >= 5.005
-BuildRequires: perl(IPC::ShareLite) >= 0.06 perl(Storable) perl(Carp) perl(IPC::SysV)
+# Source0-md5: 4d5d159a6b41d42918b7c1fceafb43ae
+BuildRequires: perl-Carp-Assert
+BuildRequires: perl-IPC-ShareLite >= 0.06
+BuildRequires: perl-IPC-SysV
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 This module provides a shared memory cache accessed as a tied hash.
 
-%description -l pl
-Ten modu³ udostêpnia cache pamiêci dzielonej, dostêpny jako
-dowi±zany hash.
+%description -l pl.UTF-8
+Ten moduł udostępnia cache pamięci dzielonej, dostępny jako
+dowiązany hash.
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
 
 %build
-%{__perl} Makefile.PL
+%{__perl} Makefile.PL \
+       INSTALLDIRS=vendor
 %{__make}
-%{__make} test
+
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -41,5 +51,5 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc Changes ANNOUNCE
-%{perl_sitelib}/%{pdir}/%{pnam}.pm
+%{perl_vendorlib}/IPC/SharedCache.pm
 %{_mandir}/man3/*.3pm*
This page took 0.067303 seconds and 4 git commands to generate.