]> git.pld-linux.org Git - packages/perl-IPC-SharedCache.git/blobdiff - perl-IPC-SharedCache.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-IPC-SharedCache.git] / perl-IPC-SharedCache.spec
index fc6641c6783805afcf53d329d1559ddb7fbe493d..63be5bb785b303054217f852f89653d057f1a411 100644 (file)
@@ -1,40 +1,51 @@
-%include       /usr/lib/rpm/macros.perl
-%define        pdir    IPC
-%define        pnam    SharedCache
-Summary:       %{pdir}::%{pnam} perl module
-Summary(pl):   Modu³ perla %{pdir}::%{pnam}
-Name:          perl-%{pdir}-%{pnam}
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
+
+%define                pdir    IPC
+%define                pnam    SharedCache
+Summary:       IPC::SharedCache - manage a cache in SysV IPC shared memory
+Summary(pl.UTF-8):     IPC::SharedCache - zarządzanie pamięcią podręczną w pamięci dzielonej SysV
+Name:          perl-IPC-SharedCache
 Version:       1.3
-Release:       2
-License:       GPL
+Release:       8
+License:       GPL v2+
 Group:         Development/Languages/Perl
-Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
+Source0:       http://www.cpan.org/modules/by-module/IPC/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 4d5d159a6b41d42918b7c1fceafb43ae
+Patch0:                %{name}-wrap-IPC-ShareLite-new-calls-inside-eval-block.patch
+URL:           http://search.cpan.org/dist/IPC-SharedCache/
+BuildRequires: perl-Carp-Assert
+BuildRequires: perl-IPC-ShareLite >= 0.06
+BuildRequires: perl-IPC-SysV
+BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
-BuildRequires: perl >= 5.005
-BuildRequires: perl(IPC::ShareLite) >= 0.06 perl(Storable) perl(Carp) perl(IPC::SysV)
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 This module provides a shared memory cache accessed as a tied hash.
 
-%description -l pl
-Ten modu³ udostêpnia cache pamiêci dzielonej, dostêpny jako
-dowi±zany hash.
+%description -l pl.UTF-8
+Ten moduł udostępnia cache pamięci dzielonej, dostępny jako dowiązany
+hash.
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
+%patch0 -p1
 
 %build
 %{__perl} Makefile.PL \
-       INSTALLDIRS=vendor 
+       INSTALLDIRS=vendor
 %{__make}
-%{__make} test
+
+%{?with_tests:%{__make} test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -42,5 +53,5 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc Changes ANNOUNCE
-%{perl_vendorlib}/%{pdir}/%{pnam}.pm
-%{_mandir}/man3/*.3pm*
+%{perl_vendorlib}/IPC/SharedCache.pm
+%{_mandir}/man3/IPC::SharedCache.3pm*
This page took 0.065062 seconds and 4 git commands to generate.