]> git.pld-linux.org Git - packages/perl-IO-Interface.git/blobdiff - perl-IO-Interface.spec
rebuild with perl 5.32
[packages/perl-IO-Interface.git] / perl-IO-Interface.spec
index 122bb882f7aa6022aee93f2aceddd599c3eb1d10..84b406f2da8a3279f5956b5f6d51c8fb1005e88c 100644 (file)
@@ -1,60 +1,67 @@
 #
 # Conditional build:
-%bcond_without autodeps        # don't BR packages needed only for resolving deps
-%bcond_without tests   # do not perform "make test"
+%bcond_without tests   # unit tests
 #
-%include       /usr/lib/rpm/macros.perl
 %define                pdir    IO
 %define                pnam    Interface
-Summary:       perl(IO::Interface) perl extension to access interface information
+Summary:       IO::Interface - Perl extension to access interface information
+Summary(pl.UTF-8):     IO::Interface - rozszerzenie Perla do dostępu do informacji o interfejsach
 Name:          perl-IO-Interface
-Version:       0.98
-Release:       0.1
-License:       GPL v2/Artistic (same as perl)
+Version:       1.09
+Release:       2
+License:       Artistic v2.0
 Group:         Development/Languages/Perl
-Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
-# Source0-md5: 91d5029a32302aa02414c9c8e3353cec
-URL:           http://search.cpan.org/dist/IO-Interface
+Source0:       http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
+# Source0-md5: 806f97aff5a7361b6f54cd494f4cc9fd
+URL:           https://metacpan.org/release/IO-Interface
+BuildRequires: perl-ExtUtils-CBuilder
+BuildRequires: perl-Module-Build
 BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
-#%%if %%{with autodeps} || %%{with tests}
-#%%endif
+BuildRequires: rpmbuild(macros) >= 1.745
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-#%%define              _noautoreq      'perl(anything_fake_or_conditional)'
-
 %description
 IO::Interface adds methods to IO::Socket objects that allows them to
 be used to retrieve and change information about the network
 interfaces on your system.  In addition to the object-oriented access
 methods, you can use a function-oriented style.
 
+%description -l pl.UTF-8
+IO::Interface dodaje do obiektów IO::Socket metody pozwalające na
+używanie ich do pobierania i zmiany informacji o interfejsach
+sieciowych w systemie. Oprócz metod zorientowanych obiektowo można
+używać także wywołań zorientowanych na funkce.
+
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
 
 %build
-%{__perl} Makefile.PL \
-       INSTALLDIRS=vendor
+%{__perl} Build.PL \
+       --config optimize='%{rpmcflags}' \
+       --installdirs=vendor
 
-%{__make} \
-       OPTIMIZE="%{rpmcflags}"
+./Build
 
-%{?with_tests:%{__make} test}
+%{?with_tests:./Build test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} pure_install \
-       DESTDIR=$RPM_BUILD_ROOT
+./Build install \
+       --destdir $RPM_BUILD_ROOT
+
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/IO/Interface/*.bs
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc Changes README
+%doc Changes README.md
 %{perl_vendorarch}/IO/Interface.pm
+%dir %{perl_vendorarch}/IO/Interface
+%{perl_vendorarch}/IO/Interface/Simple.pm
 %dir %{perl_vendorarch}/auto/IO/Interface
-%attr(755,root,root) %{perl_vendorarch}/auto/IO/Interface/*so
-%{perl_vendorarch}/auto/IO/Interface/*bs
-%{_mandir}/man3/*
+%attr(755,root,root) %{perl_vendorarch}/auto/IO/Interface/Interface.so
+%{_mandir}/man3/IO::Interface*.3pm*
This page took 0.033559 seconds and 4 git commands to generate.