]> git.pld-linux.org Git - packages/perl-Devel-Caller-Perl.git/blobdiff - perl-Devel-Caller-Perl.spec
use generic url
[packages/perl-Devel-Caller-Perl.git] / perl-Devel-Caller-Perl.spec
index 8c9979e10bc8b579a9628ee9d7f62144ba55847e..6b501a2f790df3bbe84081157d652ef33ed704eb 100644 (file)
@@ -1,29 +1,37 @@
-
+#
 # Conditional build:
 %bcond_without tests   # do perform "make test"
 
+%define                pdir    Devel
+%define                pnam    Caller-Perl
 %include       /usr/lib/rpm/macros.perl
-%define        pdir    Devel
-%define        pnam    Caller-Perl
-Summary:       Devel::Caller::Perl
+Summary:       Devel::Caller::Perl - allow method to get arguments passed to higher subroutines
+Summary(pl.UTF-8):     Devel::Caller::Perl - umożliwienie metodzie pobranie argumentów z wyższych funkcji
 Name:          perl-Devel-Caller-Perl
 Version:       1.4
-Release:       0.1
+Release:       2
 # same as perl
-License:       GPL/Artistic
+License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
-# Source0-md5: b510d88edf40e368cbc4d659fc6c7bd0
-BuildRequires: perl-devel >= 5.6
-BuildRequires: rpm-perlprov >= 4.1-13
+# Source0-md5: ef4407ab5c506e4daa63ee1496b5872f
+URL:           http://search.cpan.org/dist/Devel-Caller-Perl/
 BuildRequires: perl-Module-Build >= 0.21-2
+BuildRequires: perl-devel >= 1:5.8.0
+BuildRequires: rpm-perlprov >= 4.1-13
 %if %{with tests}
-BuildRequires: perl(Test::More)
+BuildRequires: perl-Test-Simple
 %endif
+BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Devel::Caller::Perl Perl module
+Devel::Caller::Perl Perl module allows a method to get arguments
+passed to subroutines higher up in the call stack.
+
+%description -l pl.UTF-8
+Moduł Perla Devel::Caller::Perl pozwala metodzie odczytać argumenty
+przekazane do funkcji wyżej w stosie wywołań.
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
@@ -31,14 +39,14 @@ Devel::Caller::Perl Perl module
 %build
 %{__perl} Build.PL \
        installdirs=vendor \
-       destdir=$RPM_BUILD_ROOT \
-       config='optimize=%{rpmcflags}'
+       destdir=$RPM_BUILD_ROOT
 ./Build
 
 %{?with_tests:./Build test}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+
 ./Build install
 
 %clean
@@ -46,5 +54,6 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%{perl_vendorlib}
+%dir %{perl_vendorlib}/Devel/Caller
+%{perl_vendorlib}/Devel/Caller/Perl.pm
 %{_mandir}/man3/*
This page took 0.084157 seconds and 4 git commands to generate.