]> git.pld-linux.org Git - packages/perl-DBI.git/blobdiff - perl-DBI.spec
- rebuild with perl 5.18.0
[packages/perl-DBI.git] / perl-DBI.spec
index 3953a7850679a2a291d051a63005377c17b58c2d..abda425b04a1f7310d715015671130232ffc7af1 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Conditional build:
 %bcond_without autodeps        # don't BR packages needed only for resolving deps
 %bcond_without tests           # perform "make test"
@@ -22,13 +23,13 @@ Summary(ru.UTF-8):  Библиотека для доступа к базам да
 Summary(sv.UTF-8):     Ett databasåtkomst-API för Perl
 Summary(zh_CN.UTF-8):  Perl 的数据库访问 API。
 Name:          perl-DBI
-Version:       1.601
+Version:       1.624
 Release:       2
 License:       GPL or Artistic
 Group:         Development/Languages/Perl
-Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
-# Source0-md5: d80677bd8113ec8cb0438b8703f3c418
-Patch0:                %{name}-changes.patch
+Source0:       http://www.cpan.org/modules/by-module/DBI/%{pnam}-%{version}.tar.gz
+# Source0-md5: fa88da46496455c1536f997850d8d420
+URL:           http://search.cpan.org/dist/DBI/
 BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
 %if %{with autodeps} || %{with tests}
@@ -39,7 +40,7 @@ Obsoletes:    perl-DBI-FAQ
 Conflicts:     perl-DBD-CSV < 1:0.21
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _noautoreq      'perl(DBD::<foo>)' 'perl(DBI)' 'perl(DBI::.*)'
+%define                _noautoreq      'perl(DBD::<foo>)' 'perl(DBI)' 'perl(DBI::.*)' 'perl(DBD::File::.*)'
 %define                _noautoreqdep   'perl(UNIVERSAL)'
 
 %description
@@ -131,12 +132,13 @@ DBI 是用于 Perl 编程语言的数据库访问程序编写界面 (API)。 DBI
 明细表定义了一组函数、变量和定规,它们提供了一个独立于实际被使用的数据
 库之外的连贯的数据库 界面。
 
-%package DBD-Proxy
+%package -n perl-DBD-Proxy
 Summary:       DBD::Proxy - A proxy driver for the DBI
+Summary(pl.UTF-8):     DBD::Proxy - sterownik proxy dla DBI
 Group:         Development/Languages/Perl
 Requires:      %{name} = %{version}-%{release}
 
-%description DBD-Proxy
+%description -n perl-DBD-Proxy
 DBD::Proxy is a Perl module for connecting to a database via a remote
 DBI driver.
 
@@ -144,6 +146,14 @@ This is of course not needed for DBI drivers which already support
 connecting to a remote database, but there are engines which don't
 offer network connectivity.
 
+%description -n perl-DBD-Proxy -l pl.UTF-8
+DBD::Proxy to moduł Perla służący do łączenia się z bazą danych
+poprzez zdalny sterownik DBI.
+
+Nie jest to oczywiście potrzebne dla sterowników DBI które same
+obsługują łączenie się ze zdalną bazą danych, ale oprócz nich są
+silniki, które nie oferują łączności sieciowej.
+
 %package ProfileDumper-Apache
 Summary:       DBI::ProfileDumper::Apache - capture DBI profiling data from Apache/mod_perl
 Summary(pl.UTF-8):     DBI::ProfileDumper::Apache - przechwytywanie danych parametryzujących DBI z Apache/mod_perl
@@ -166,8 +176,6 @@ Apache'a. Można je analizować za pomocą dbiprof.
 
 %prep
 %setup -q -n %{pnam}-%{version}
-%patch0 -p1
-mv Roadmap.pod lib/DBI
 mv Changes lib/DBI/Changes.pod
 echo 'man DBI::Changes' > Changes
 
@@ -177,6 +185,7 @@ mv t/80proxy.t{,-needs-syslog}
 %{__perl} Makefile.PL \
        INSTALLDIRS=vendor
 %{__make} \
+       CC="%{__cc}" \
        OPTIMIZE="%{rpmcflags}"
 
 %{?with_tests:%{__make} test}
@@ -190,14 +199,14 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{perl_vendorlib}/DBIx,%{perl_vendorarch}/{DBIx,auto/{DBD,DBIx}}}
 
 # no reason to include Bundle::* in rpms
-rm -rf $RPM_BUILD_ROOT{%{perl_vendorarch}/Bundle,%{_mandir}/man3/Bundle::*}
-rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/DBI/.packlist
+%{__rm} -r $RPM_BUILD_ROOT{%{perl_vendorarch}/Bundle,%{_mandir}/man3/Bundle::*}
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/DBI/.packlist
 
 # not our os
-rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/{DBI/W32ODBC,Win32/DBIODBC}.pm
-rm -f $RPM_BUILD_ROOT%{_mandir}/man3/{DBI::W32,Win32::DBI}ODBC.3pm
-# different format in %doc
-rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/{TASKS,DBI/{Changes,Roadmap}}.pod
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/{DBI/W32ODBC,Win32/DBIODBC}.pm
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{DBI::W32,Win32::DBI}ODBC.3pm
+# already in doc
+%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/DBI/Changes.pod
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -205,7 +214,9 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc Changes README
-%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_bindir}/dbilogstrip
+%attr(755,root,root) %{_bindir}/dbiprof
+%attr(755,root,root) %{_bindir}/dbiproxy
 %dir %{perl_vendorlib}/DBIx
 %{perl_vendorarch}/*.pl
 %{perl_vendorarch}/DBI.pm
@@ -225,28 +236,29 @@ rm -rf $RPM_BUILD_ROOT
 %{perl_vendorarch}/auto/DBI/Driver.xst
 %{perl_vendorarch}/auto/DBI/DBI.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/DBI/DBI.so
-%{_mandir}/man1/*
-%{_mandir}/man3/DBD*
-%{_mandir}/man3/DBI*
-%{_mandir}/man3/TASKS.3pm*
+%{_mandir}/man1/dbilogstrip.1p*
+%{_mandir}/man1/dbiprof.1p*
+%{_mandir}/man1/dbiproxy.1p*
+%{_mandir}/man3/DBD::*.3pm*
+%{_mandir}/man3/DBI*.3pm*
 
 # in subpackages
 %exclude %{_mandir}/man3/DBD::Proxy.3pm*
-%exclude %{_mandir}/man3/DBI::ProfileDumper::Apache.3*
-%exclude %{_mandir}/man3/DBI::ProxyServer.3*
+%exclude %{_mandir}/man3/DBI::ProfileDumper::Apache.3pm*
+%exclude %{_mandir}/man3/DBI::ProxyServer.3pm*
 %exclude %{perl_vendorarch}/DBD/Proxy.pm
 %exclude %{perl_vendorarch}/DBI/ProfileDumper/Apache.pm
 %exclude %{perl_vendorarch}/DBI/ProxyServer.pm
 
-%files DBD-Proxy
+%files -n perl-DBD-Proxy
 %defattr(644,root,root,755)
 %{perl_vendorarch}/DBD/Proxy.pm
 %{perl_vendorarch}/DBI/ProxyServer.pm
 %{_mandir}/man3/DBD::Proxy.3pm*
-%{_mandir}/man3/DBI::ProxyServer.3*
+%{_mandir}/man3/DBI::ProxyServer.3pm*
 
 %files ProfileDumper-Apache
 %defattr(644,root,root,755)
 %dir %{perl_vendorarch}/DBI/ProfileDumper
 %{perl_vendorarch}/DBI/ProfileDumper/Apache.pm
-%{_mandir}/man3/DBI::ProfileDumper::Apache.3*
+%{_mandir}/man3/DBI::ProfileDumper::Apache.3pm*
This page took 0.181308 seconds and 4 git commands to generate.